Welcome! Log In Create A New Profile


RepRap and Compiz Issues

Posted by Anonymous User 
Anonymous User
RepRap and Compiz Issues
January 21, 2008 01:32AM
Hey Everyone,

This is my first post! I'm running Ubuntu and Compiz Fusion. I installed the RepRap software and got it working but seems like it is having issues with the Java and the Compiz. Has anyone experience anything like this?

The reason I say that there is something with the Java is because I ran into a similar problem with MatLab menus not being displayed under Compiz. Apparently, you have to do some hack with the Java to get it working.

Any ideas and help will be greatly be appreciated.
Re: RepRap and Compiz Issues
January 26, 2008 01:54PM
As a first step, remove Compiz and verify that the
Reprap code then works as expected. That way you
have verified that whatever issue you are
experiencing is in fact Compiz related.

Then, reinstall Compiz, and document exactly what
the unexpected or unwanted behaviour is. The
description "seems like it is having issues" is rather
too vague to be easily replicated or debugged :-)

If it is a general Compiz/Java issue, then I'd suggest
asking about this on a Compiz support forum, since
I suspect very few Reprappers run Compiz, as it's
not exactly necessary or useful to Reprapping.


Re: RepRap and Compiz Issues
January 26, 2008 02:20PM
>I suspect very few Reprappers run Compiz

I run it on one of my Ubuntu machines, I will try your latest installer and see what happens.

Re: RepRap and Compiz Issues
January 26, 2008 07:03PM
Yeah, I run Compiz on all of my machines, but 2 of them are set up with ubuntu on two seperate hard-drives, so I can select between two different machines to run inside the same machine.(One hard drive has Compiz the other doesnt')

Anonymous User
Re: RepRap and Compiz Issues
January 28, 2008 11:22AM
So I created an another user on my laptop that does not launch Compiz and it works right off the bat. I guess I won't worry about it too much.

If you did get Reprap and Compiz working, please let me know.
Re: RepRap and Compiz Issues
January 28, 2008 11:24AM
I have the same problem with compiz I just switch to metacity when I need to run the Reprap Host / AOI programs. To do this I have two shortcuts to two scripts (one for metacity and the other for compiz on my desktop that makes switching between the two easy. If you want I'll upload the scripts later on when I'm on ubuntu.

Anonymous User
Re: RepRap and Compiz Issues
January 29, 2008 03:32AM
Could you upload those scripts when you get a chance? Thanks.
Re: RepRap and Compiz Issues
January 29, 2008 10:10AM

The two scripts are attached. They are not written by me I can't remember where I got them from. You might need to enable them to be executable and then run them.

If you have any problems with them let me know.

open | download - disablecompiz.sh (43 bytes)
open | download - enablecompiz.sh (41 bytes)
Re: RepRap and Compiz Issues
February 11, 2008 02:23PM
I don't know if you are stil having problems, but I'm running compiz-fusion and the host software at the same time without any trouble (on Fedora).
If you need to switch it off the package fusion-icon is an icon that sits in your notification area, you can right click on it and switch window managers.
Sorry, only registered users may post in this forum.

Click here to login