Welcome! Log In Create A New Profile


Win XP communications problem

Posted by rusty 
Win XP communications problem
January 21, 2008 02:15PM
Hello all - I'm about half way through building my reprap and I'm having some problems with the reprap host 0.8.3 (I haven't tried any others) software communicating with my electronics - I think...

I've followed the build instructions to the letter (almost winking smiley ) - I'm using the PIC based first gen. electronics with the newer UC boards v1.2.1. I'm to the point where I test (test 3) the UC board using "Tools -> Stepper Exerciser" and I get an error saying that the host software can't find the COM1 port... (I can post the actual error if needed) - any thoughts...

*I'm running Win XP (fresh install) - I believe all the Java files are in the right location - The reprap host software starts and seems to be stable - I receive no errors in the console.

* I've changed my com1 baud rate on my system to 19200 (and checked it twice "mode com1 /status")

* The port in the "preferences" is set to "com1" - not "tty/com1" or tty/... etc.

* I've past all the voltage tests - everything is within the specifications.

* I've past all the other communications tests with my serial port - all my lights are green - when I short my rx/tx pins I get text echoed back to me in Hyperterminal and my lights blink on the PC card (also, no short = no echo) - I've tested just my serial port and it checks out with the same Hyperterminal test - my serial cable is straight through (tested with my multimeter).

*I'm NOT using a usb to serial adaptor.

* With one UC board plugged into the PC board I have one bi-colored led light up - when I plug in the serial cable the other bi-colored led lights up - (at one point one was red, but I re-wired my rx/tx and it turned green. < - all should be well yes/no??)

The only thing I haven't done is change out/reprogram the PIC - could I have an error there that would cause the host software not to find the electronics/com1 port. The debugging led on my UC board is glowing green and I'm testing with the X axis firmware programed PIC.

Any ideas?
Re: Win XP communications problem
January 21, 2008 03:19PM
I just checked my setup. I have "COM1" as the port name. If I change it to "com1", it fails with "there was an error opening com1". I'm guessing it has to be uppercase.
Re: Win XP communications problem
January 21, 2008 06:18PM
Yes! This worked I changed my port from "com1" to "COM1" and it works!thumbs up

Got the stepper tester up and running and everything looks good.

Thanks Steve.
Sorry, only registered users may post in this forum.

Click here to login