Welcome! Log In Create A New Profile


1284p Bootloader

Posted by Legot 
1284p Bootloader
February 19, 2012 01:21AM
Hi, I've built a Gen 7 board, and I've been trying all day to get a bootloader to work.

The Original Gen 7 bootloader requires a 644 or 644p because of the different device signature.
I also tried the mighty1284p bootloaders, but I keep getting this error:
avrdude: stk500_paged_write(): (a) protocol error, expect=0x14, resp=0x64
avrdude: stk500_cmd(): programmer is out of sync
and note that I am on 20mhz and those were intended for 16mhz.
I'm fairly sure this comes from a wrong bootloader, but for now, I am completely useless with programming.

I haven't found any bootloaders for a 1284p @ 20mhz, is there any way that someone could modify the original gen 7 bootloader to accept the 1248p?

I'm not sure how simple it would be, but the only error I am receiving is:
avrdude: Expected signature for ATMEGA644P is 1E 96 0A
         Double check chip, or use -F to override this check.
Which is to be expected, so I think it would just have to look for the 1284p signature, which I don't know...

Another thing, I am using an arduino as the ISP through the ISP Header on the Gen 7, and it is wired correctly, so I don't think that is causing the problem.

I did find this site [aka47.adsl24.co.uk]
But I can't seem to figure out what I need to do to burn the .hex onto my chip, It looks like it should work though.


Edited 1 time(s). Last edit at 02/19/2012 01:29AM by Legot.
Re: 1284p Bootloader
February 19, 2012 07:03AM
You upload a bootloader just like any other firmware. Works through ISP only, though.

Generation 7 Electronics Teacup Firmware RepRap DIY
Re: 1284p Bootloader
February 19, 2012 10:32PM
So I tried the Aka 47 version through both the arduino IDE and avrdude, but Each time, I keep getting the error
I'm also using the latest version of the arduinoISP sketch now, that's why it changed from the protocol error.
avrdude: stk500_getsync(): not in sync: resp=0x00
still...and I's been two days! lol, just getting annoyed.

Does anyone have any solution's for this? I couldn't dig up a reason.

Edited 2 time(s). Last edit at 02/20/2012 03:28AM by Legot.
Re: 1284p Bootloader
February 21, 2012 12:23AM
So I found that the reason for my problem with the Arduino as ISP was that any ArduinoISP sketch that is uploaded from the arduino 1.0 software doesn't work because of some sort of library mixup thing.

The solution was to upload the ArduinoISP sketch from an older version of the IDE, I used Arduino 0022 and it worked!
Re: 1284p Bootloader
April 15, 2012 02:07PM
thanks man you've made my live easier smiling smiley
Sorry, only registered users may post in this forum.

Click here to login