Welcome! Log In Create A New Profile

Advanced

Reprap.me's Stepsticks with 42BYGHW811 Steppers - not working - please help to make it work

Posted by peter6960 
Hi everyone

I started a build with 14 other people and helped them source the parts so we can get nice bulk buy discounts.
The shortage of Pololu's meant we had to go with Stepsticks and ended up buying from Reprap.me

I emailed Peter Boegely before ordering and he confirmed that his stepsticks are pololu 1182 compatible.

So I ordered on Aug 3rd

As the month progressed, my motors arrived, built the Gen 7 boards, etc.

Yesterday, I fired up the first board to a new printer only to find that the steppers arent working. Immediately I decide to rule out the new electronics, by moving the motor wires over to my known working Generation 7 board (with Pololu1182's) and it worked.

Something in me just wondered about the stepsticks immediately so my next test was to unplug the stepstick, and swop out my working pololu and put in one of the stepsticks (rest of board + motors now known working on the Pololu, just swopped pololu for stepstick) and viola same issues.

The issues I have looks like the following:

1. Holding: Instead of sitting quitely in a braked position, the motor vibrates around one spot.
2. Motion: Cannot get it to move the motor almost at all... Its like the stp frequencies is all off and never get to match the windings and therefore just virbates the motors and not rotate

Now I know my Pololus work, problem is I am sitting with 65 x Stepsticks and didnt ask any profit on the group-buy so I don't have funds to replace the Stepsticks with Pololus. Is there anything that can be done to make the Stepsticks work? Or was this just a bad idea? I know the motors are slightly over current rated, but they work wonderful on my 1st working printer.

Waiting to here from Reprap.me to see whether they'd be willing to help (or refund if unsuccessful).
Sorry you are having trouble. Couple of things to look at:

Is your current setpoint correct? Too high or too low can cause issues.

Are you sure you have the motor windings connected right. I had a situation with windings crossed and it acted similarly to what you are describing. Motor controllers got hot fast in this situation.

Another thing you could look at is the decay mode that the stepper is set to (this may not be an adjustable parameter without changing resistor values) but it can affect the smoothness of the motor but probably not to the extent you are seeing.
Re: Reprap.me's Stepsticks with 42BYGHW811 Steppers - not working - please help to make it work
September 15, 2012 09:52AM
One stepper driver can be defective, but 65 of them being defective and all of them in the same manner, is harder to believe. I would say it has to be something with the pinouts, wiring, or pots adjustments. As the OP describes the motor vibrating all over the place instead of rotating, can be the motor wiring aswell. Maybe the OP has found the issue and fixed it even but forgot to update the thread?
Thanks for all the help. Found that the stepsticks are actually overheating with pots set above 500mA already. Bigger heatsinks and a fan looks to work.

The pololus dont heat up so fast.

Reprap.me confirmed they sent me old stock with a older allegro chip (NO SWOP OPTION) so still regretting the purchase. Next build, proper pololus again no matter how long the backorder takes.

Any best practice suggestions in regards to the double motor Z axis?

Peter
Hello Peter,
which software did you use on yours ?
I am trying with Teacup and got no success at all just the ugly noise and no movement. Ans the nose starts when the first motor moves. I currently use 3 cheap Stepsticks from China and tried one from reprap.me and the chinese work fine, but the A4982 one starts making noise only as soon as the first other get enabled.

cu

Michael
Re: Reprap.me's Stepsticks with 42BYGHW811 Steppers - not working - please help to make it work
February 19, 2013 04:32PM
Interesting, I just got a set of the reprap.me stepstick drivers with a printer I bought, and I get the same problems as above. In short, I think these reprap.me stepsticks are junk. The date on mine appear to be "06.12", but clearly bad ones are still around, so beware.

The reprap.me stepsticks are bit devious, they have the reprap.org/wiki/stepstick url printed on them but they bear no relation to what is on the wiki. There is no indication they are made by reprap.me on the boards, but they look identical to the ones listed on the reprap.me website. Their webpage is a word for word rip-off of the Pololu website, but at least they pasted an image of their own boards over the Pololu ones.
One can always run a Pololu/StepStick "by hand": pull oth the ATmega, put voltage on the board (on Gen7, that's general 5V, not only Standby), connect Enable to 0V and touch Step with 5V repeatedly. Each touch should generate a step.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Good to know that im not the only one having problems with reprap.me.
I would note that to avoid potential damage to the semiconductors, you should use a decoupled switch instead of touching wires to manually step an input to a motor driver.
Yeah we really should get the word out ):

If you want I can paste the pages and pages of mails where I begged for my money back, for support, for anything... But nothing!

And its not the choice of chip, I suspect poor workmanship. Have other stepsticks we locally made the PCBs and assembled ourselves, also with the same older alegro chips. And they work without issue

lazzymonk Wrote:
-------------------------------------------------------
> Good to know that im not the only one having
> problems with reprap.me.
@Peter,

I'm afraid I get the same problem with my reprap.me's drivers I just bought from them.
I was suspecting the firmware but it is definetly not the case.

i tried Traumflug's way to make the motors turn "by hand" (in fact I did it "by software" having wirtten a dedicated quick and dirty sketch to generate a set of pulses on step pins.
The result is a not yet working motor.
The fact is it seems also to be in relation with the current given to the motors. I own a very old and small motor which pulls very few mA to the drivers and this one is rotating.
My new motors are supposed to drain 1.6A.

Did you find a way to trim your stepsticks and make them work ?
Honestly?

Throw them in the trash. Get your money back: Paypal disputes or VISA/MC/AMEX disputes.

Buy pololu1182s stock shortages are a thing of the past so no need to buy crap from that scaly oke
I once had StepSticks from reprapworld which malfunctioned similarly. The solution was to heat them up sufficiently to allow the solder to reflow:

1. Remove the plastics of the connectors pins. You can pull off that stripe easily.

2. Hold the StepStick over a not too small burning candle. Flat, above the visible flame, components side up.

3. The connector pins will fall out pretty quickly. Lay them aside.

4. Heat until you can see the solder going glossy. Heat another 5 seconds. Likely, you can smell a bit burned PCB substrate (Epoxy).

5. Lay the StepStick aside to allow slow cooling.

6. After a few minutes, solder the connector pins back in.

Sometimes I do such adventerous repair attempts. My trash can doesn't bother wether I throw in partially or totally damaged stuff. This time it worked, for two StepSticks out of two tried. smiling smiley


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Good news. I've contacted Peter Bogely from reprap.me he gave me the advice to limit the current in oder to get a smooth movement of the motor. (trimming the pot does the job)
I've just tested this and it is now working very smoothly from low speed up to very fast speed.

So my feedback on those 4982 stepper drivers is quite positive.

Alain
Sorry, only registered users may post in this forum.

Click here to login