Welcome! Log In Create A New Profile


Odd behavior

Posted by Demented Chihuahua 
Odd behavior
September 09, 2008 06:36AM
Hi all! Here with another problem...

Running a print on the OIT RepStrap and ran into a snag again. I recently replaced the x-axis stepper driver board because I burned out the last one due to improper cooling. Those driver chips get really hot really quick. Anywho...

When I run the stepper exerciser the system works fine. Run the extruder exerciser and things go without a hitch. Nothing to complain about. When I try and run a print one of two things happen: 1. the x-axis hums--seems to be switching so quickly it or at such low power it cannot drive anything or resist manual turning of the screw and the lights are flashing in sequence though it is barely visible--and does nothing or 2. the x-axis and y-axis leave their home positions to start the build, the heater comes on and waits for temp--which it never reaches but starts anyway--and then the extruder motor kicks in but none of the other steppers ever move again.

1. only happens when I haven't homed the x, y, and z axis before trying to start the build. 2. happens if I've homed the axis.

I'm running the RepRap host 0.8.3 (is that right???) and the arduino firmware 0.3. Nothing else unique about my electronics nor my software.

What gives?

I thought maybe it was an enable or sync problem with the wiring. Previous versions of the hardware said to connect these. The documentation now does not mention it being used. The Ardiuno code says that pin 15 is the enable pin for x, y, and z. However, the Single Arduino Wiring Diagram


says that pin 15 is used--if at all--for the solenoid valve. I tried connecting the enable pin. No luck. I tried connect the enable pin and the sync lines. No luck.

As mentioned before, all axis drive correctly and the line test works. Any help on this would be greatly appreciated.


Edited 1 time(s). Last edit at 09/09/2008 06:40AM by Demented Chihuahua.
Re: Odd behavior
September 10, 2008 01:21PM
Demented sir

A couple of simple things to check first.

(Sorry if you have done these already)

You may be suffering power supply or at least power supply connection issues.

Have a quick run around with a decent test meter etc and check for voltage drop as the variouse things happen.

(you seem to suffer more the more there is being driven, but could be a red herring)

The Heater not getting hot. hmmm if you have an osciloscope hook it up to the heater connection and se what your waveform looks like (pwm should be easy to spot and a bit of simple math will tell you what duty cycle it is running at)

Once again given all else I would definitely be trying to rule out Power supply and Power supply surge/glitches (due to switching loads etc) as a first port of call.

Could be your micro crashing, but again most common source for this if you are reasonably confident about the firmware is power issues.

When you are excersising the stepper you are running less of the machine at the same time than when you try to print so less power is drawn.

Hope this helps. Let me know how you get on.



Necessity hopefully becomes the absentee parent of successfully invented children.
Re: Odd behavior
September 11, 2008 04:02AM
Have done extensive tests on the power before this and somewhat limited tests on this now. Doesn't seem to be any problems with a power drop. I'm only seeing a fractional dip in voltage when I turn on a stepper and then only for a fraction of a second. Plus, the line test works fine in the stepper exerciser and that's two steppers working at the same time.

The weird thing about this is that just before the damn thing starts doing its humming-no-moving act the x and y axis move to their start positions as quick and easy as you please! To confound this fact, in the past when we've overloaded the power supply we trip a breaker in it and it shuts down.

I'm reminded of when we were having interference problems because of the steel frame. That isn't the case this time as the wiring harness is all shielded cable now. Crazy stupid.

Thanks for the ideas anyway. Any others?

Re: Odd behavior
September 11, 2008 09:14AM
Again if you are sure of the software/firmware.........

Add a sprinkling of decoupling capacitors, (one per IC minimum, 1000pf disk ceramic are usually good for this).

Put RF chokes on your supply lines to each board at the board end one in series with each supply lead, with a 1000pf and a handy electrolytic in parallel across each power rail to ground.

This is generally a good way to suppress RFI and glitches.

Check you have no current or hum loops (Shielded cable should as a rule only have the shield connected to ground at one end otherwise you get a loop between the shield and the ground wire)

Have you tried printing with the heater and extruder motor disconnected......

Then try with the heater.

Do you get any better results, if so the heater or extruder is a part of the problem.

If your heater is powering OK and the waveform is good, you need to know why it isn't getting hot.

Favorite candidates might be :-

1. The heater is open circuit. So draws no power and does'nt get hot. Check current to heater and continuity/resistance of heater coil to answer this one.

2. The Heater is short circuit. So draws far more than it should and still doesn't really get hot or at least hot enough. Again check heater current and continuity/resistance of heater coil to answer this one.

If all of this checks out it's got to be the drive.

I guess a less obvious one is check that any unused inputs particularly those that have interrupts associated with them or reset lines are pulled up/down as appropriate (Use a resistor to the appropriate power rail) . Logic doesn't like floating inputs it prefers them to be definitely High or Low. Floating lines are prone to acting as Antennas and picking up stray RFI/capacitance etc which can generate spurious resets and interrupts.

These are the usual electronic things. Again I suspect you have probably already eliminated these. But I gotta say them, I still get caught out by them sometimes after all these years.

A last hot favorite of all electronic equipment is dry solder joints giving intermittent and difficult to trace problems. No easy way to sort this other than inspection and if you fail to find any dry joints, re flow them all. Work through in an orderly manner so nothing gets missed.

Failing all of the above, it's sit down with a scope and meter, time and work your way through it all in an orderly manner.

Good luck, hope this helps in some way.


Necessity hopefully becomes the absentee parent of successfully invented children.
Re: Odd behavior
September 12, 2008 06:06AM
Many good ideas. Have eliminated some of them as you say but others I will try.

A note on the heater problem...I can run the extruder exerciser and get it up to temp in a fairly timely manner so it isn't open circuit or anything. The more I think about it, the more I'm leaning to your original idea that this is a power issue.

I'm gonna clear this up by trying to run the print without the heater or extruder motor lines connected in any way. Haven't tried this yet. Ran the extruder so that it didn't have filament in it but that did nothing for me. I figure that if things run without the heater or the extruder motor drawing any current, then it has to be a power issue as all of the systems work fine seperately.

Is my logic correct on this one? I mean, leaving aside all software problems--which again shouldn't really let the systems work seperatly but not together--this would indicate that problem as you originally suspected, wouldn't it. What I'm not sure about is how my power supply isn't just shutting down when I pull too much current.

I'll try this and post my results. Could be over the weekend, maybe. Work has been very trying lately. Can't wait to get back to classes!

Thanks for your help, Andy.

Re: Odd behavior
September 12, 2008 06:13AM
Demented Sir.

What are you using as your power supply ????

Ie to turn line/mains voltage into the power rails that you want.

Necessity hopefully becomes the absentee parent of successfully invented children.
Re: Odd behavior
September 12, 2008 06:14AM
I think its a 350 watt pc power supply. Nothing big or fancy but we know it's surge protected and that if we try and draw too much from it on purpose, it shuts down. That's why this doesn't make sense.

Re: Odd behavior
September 12, 2008 07:29AM
Switch mode PSU's usually have over load cut out.

And when the load gets too great for them they shutdown. Often they will try to restart and then if the overload is still present shutdown again.

SMPSU's that are continuously retrying are said to be tweeting. (The Apple SMPSU's that this got it's name from made a twit twit sound as it continuously tried to restart).

If the voltage on the output rails goes over a certain value (ie over voltage) the cut out circuit does the same thing and the SMPSU again tweets.

Inductive loads can generate not insignificant back EMF. It is not usual for this to cause an SMPSU to tweet but it could feasibly happen if the voltage detect is faulty or over sensitive.

(The Apple PSU's output voltage drifted over time and would end up exceeding the cut out limit causing the tweeting, the fix was to readjust the voltage using a potentiometer on the SMPSU board, below that which caused it to cut out)

On multi rail SMPSU's it is quite rare for all the rails to be monitored. Usualy one of the several is monitored.

SMPSU's with multiple outputs at the same voltage (ie multiple 5v connectors). These are usually just separate wires from the same supply rail in the SMPSU.

Clearly if your SMPSU tweets or glitches it is likely to at least crash your micro controler or trigger a brown out reset.

Possible solutions :-

1. Try another SMPSU preferably a different type. (PC's generally don't have a terrific lot of Inductive loads)

2. Put snubbing/smoothing onto the power supply rails to your motors/power driver boards

3. Add some substantial electrolytic capacitance across your supply rails. (remember to put blead resistors on them as they store quite a whallop)

1. is to be preferred. 2. is good practice as it helps with in rush current, 3. only if nothing else works which it should.

Necessity hopefully becomes the absentee parent of successfully invented children.
Anonymous User
Re: Odd behavior
September 12, 2008 11:54AM
I assume you have put a load on the 5V output of the PC power supply to help keep the 12V in regulation. [web2.murraystate.edu]

Another thought is since it sounds like you are at a university can you borrow a lab power supply to see if changing the PC power supply out makes a difference?

Start probing with an oscilloscope if you have access to one.
Re: Odd behavior
September 14, 2008 07:50PM
Okay, the state of the nation...hehe

I'm currently running the host computer and the reprap gen 2 software off of the same power supply. As pointed out by Andy, it's an smpsu. Fearing, but not really believing, power supply issues I hooked up a second power supply from a proven source...my other repstrap. Powered my three steppers from this power supply and then ran the test print again.

No luck. Same behavior but I have more info this time as to what is happening. Starting an initial print, the motors just sit there and hum and the lights switch on the front panel indicating that the motor is getting the correct pulses. I thought maybe tripping the opto switches might do something, it did.

The x-axis hums first so I tripped that one and the y-axis starts humming. I trip that one and the x and y move out to their start print positions--relative to where they were to begin with which was not the dock positions. From there, the heater turns on but doesn't really wait to come up to temp, and then the extruder motor turns on as if it is printing. The steppers at this point make no other attempt to move and, in fact, aren't even torque locked!

Now, can someone make sense of this? I'm going back to the arduino, making sure the lines are all plugged into the correct pins on it. After that I'm out of ideas for right now. Wow, this thing does a lot of weirdness.

As to the other ideas/suggestions...we have used a scope to see that we are getting the right wave forms. We are. More to the point, they drive the motors during part of the build process but not during others. Must be working at least part of the time.

The power supply...did try a bench power supply at one point. No difference. Now that I've hooked up another PC power supply it still isn't making a difference. Don't think it's a power supply issue. Don't get it.

I tried suggestion 1 from Andy. Loath to try 2 and 3 as I'm that lazy and really don't have the skills or confidence to do that. What do you mean by a substantial cap? What value is that? And what is snubing/smoothing for the power supply rail?

Again, thanks for the suggestions, help, and info. Keep it coming!

Re: Odd behavior
September 14, 2008 10:51PM
When homing, the head moves faster than when it's moving to the starting position. It sounds like the steppers aren't generating enough torque at the higher speed to move the head. Assuming all your hardware and electronics are OK, I can think of two other ways that could happen:

1. XAxisTorque and YAxisTorque aren't set high enough.
2. MaximumFeedrateX and MaximumFeedrateY (arduino) or FastSpeed (pic) are set too high.

Try playing with those parameters. Worth a shot.
Re: Odd behavior
September 15, 2008 12:36PM

Played with those. Some success. It was the FastSpeed that was the problem I think. Set too hi for it to home. Have it set lower now and it now homes at the beginning of a build.

However, and much to my disappointment, the other problem still remains. I can get it to go through the homing process, the move to the start build position, the heater turning on--though not heating up all the way--and then the extruder motor turning on. The Steppers, however, at this point still don't move. No noise, no flashing lights, nothing. I checked the speeds for them and they are set at a reasonable level that I know to work from the Stepper Exerciser.

The key thing here is that the lights aren't even flashing so they aren't being driven at all. I'm not sure why. How could they home correctly and move out to the proper start position nicely and yet not move during the build?

Thanks for the help Steve! Much thanks.

Re: Odd behavior
September 16, 2008 12:26PM
Well, that's a step in the right direction, at least. Now, the way a build is supposed to work is this sequence. At least this is what happens with mine. I'm using 0.8.3 with PIC firmware.

1. home X and Y
2. home Z
3. move X and Y to start position
4. Z up and down a bit (I think to the start position)
5. heater on (plus warmup)
6. Z up and down a bit
7. draw a long U shape to prime the extruder
8. Z up
9. X and Y to object print position
10. Z down
11. start drawing first layer

Working from memory at the moment but I think that's right. Even with no object loaded, it should still draw the U shape.

How much of that happens with your machine?
Re: Odd behavior
September 17, 2008 06:02AM
Using 0.8.3 software but Arduino firmware 0.3. Gets up to step 5 but take out all that z up and down stuff--my pic strap does that too but the arduino never has. Add to this the fact that the extruder turns on and runs and the software thinks its going somewhere--evidenced by the fact that when I cancel the build it tells me it traveled some random distance. It' thinks it's working but nothing happens outside of homing, moving to start position, turning on the heater, then the extruder and sitting there. It also makes occasional stops of the extruder like it has finished a segment and is moving the head around to the new segment. weird.

Re: Odd behavior
September 29, 2008 10:06PM
DC- have you made any progress on this? I have a similar problem where printing starts fine, but then at some point (always the same on any given object, and always within a minute or so of starting the print) the stepper motors just stop and never start up again. The extruder motor and heater keep running, so I get a big pile of melted HDPE at whatever point it gives up.
I'm running two power supplies by default, one for the heater and another for all the motors. I brought another one into the picture to run the stepper motors, still no luck.
All the tests work fine for me up until printing fails.
I'm running the latest released software for windows on an XP system, going to try the liveCD next.
Re: Odd behavior
September 30, 2008 06:31PM

...sadly I do not have anything new to report. The machine is back in it's permanent home at OIT in Klamath Falls Oregon while I am in my new home in Portland Oregon. (you can look at the world reprap map to get a sense of the distances involved if you don't know the area)

My classmate will continue working on this issue but the progress may be slow and may not get reported till fixed. I'll keep this thread updated with what he finds. It's odd that you have the same problem on an entirely different OS. I'm wondering if we haven't found a new problem.

Are there any functioning Arduino Straps out there in the wild? Or even functioning Aruino Darwins? I haven't heard of any off the top of my head...please, somebody show me wrong on this one so we can lay this annoying problem to rest once and for all.

Sorry I was no help to you. I'll keep things posted here though.

Re: Odd behavior
October 01, 2008 05:46AM
Thanks for the update, Demented.
I don't think the problem I'm seeing is the same one you're seeing- when the printing stops, the motors are locked (not completely idle).
Sorry to hear you aren't working on this project anymore- I hope you find something else fun to spend time on smiling smiley
Re: Odd behavior
October 02, 2008 12:54PM
um, still working on a repstrap--mine not the schools--so I'll still be around here just posting rants and complaints about *different* annoying problems! hehe I'm re-doing a lot of my previous work on my machine. I left it in quite a state of dis-repair when I started work on the OIT RepStrap. Things are looking much better now and I am making HUGE progress at a much faster rate than before. Turns out, making a few of these things helps later progress on other projects or when you attempt to do over something done before. Experience...feh! Who could have known!?

Sorry, only registered users may post in this forum.

Click here to login