Welcome! Log In Create A New Profile


HELP with RepRap Pro Melzi Electronics

Posted by Megator 
HELP with RepRap Pro Melzi Electronics
February 11, 2013 02:32PM
Hello Rep Rap Community,

This is my first post and sadly it is no a happy one!

I have recently had some issues with my RepRap's electronics and am uncertain as to what is wrong and how to fix it.

Recently mid way through a print the nozzle sometimes moves to a completely random position and then continues to print the model. Sometime it even adjusts the Z height down in such a way as to crash into and knock the original model off of the bed. I know that the issue is not with my G-code files as I review all of them in a G-code viewer before printing.

Then today I tried to print with ABS for the first time and the bed would not reach a 120 degrees even after an hour of heating. Previously I have gotten it up to 130 degrees with no problems and much faster. Also as I printed the bed temperature dropped by 10-15 degrees within the first 10- 20 layers causing my print to warp and become unstuck.

After trying to print one last time before bed I could suddenly no longer communicate with the Reprap through Pronterface and the LED light on the melzi electronics failed to light up when I plugged in the USB. I can see that my computer can still recognize the board when I plug it in but nothing happens when I try and connect. I also checked and can see that the motor drivers are still getting a current when the USB is plugged in.

I am at a loss as to what I should check on the board to see if it is still in good working order? Or maybe I need to reinstall all of the drivers on my computer?

Any help with my problems would be greatly appreciated.

Kind Regards,

Aitor Molina
Re: HELP with RepRap Pro Melzi Electronics
February 11, 2013 03:51PM
Shifts in prints like that i got for various reasons, from mechanical up to electrical which is more subtle: when i started a grinder motor in a next room, the print would either shift or comms would stop. So i am just asking, maybe there is some reactive power users you are using while this shifts occur? E.g. electrical motors, transformers, perhaps neon lightning?

From the rest of your description feels like "it slowly ran out of juice". Also i guess you have an atx psu, coz if you would of had a linear psu with significant bulk capacitance the paragraph 1 wouldnt be the case. The current psu that you were using, how much current does it say it provides on 12v, and how much you were drawing, including bed? E.g. measure the bed with multimeter, do ohms law. Thats to say make sure there arent any shorts on bed or things like that and if all looks ok try another psu. Lets hope its only the psu that has issues. So, can you replace the atx psu and see if there is any change?
Re: HELP with RepRap Pro Melzi Electronics
February 12, 2013 04:26PM
Hi NoobMan,

Thanks for the quick reply! I dont think its mechanical as the movements are quite exagerated (cm not mm). As for reactive powers I am unsure the only things that would be plugged in around it are a laptop, printer, space heater, TV, various small electronics chargers. Next time I will try not to run any of these machines and see what happens.

I dont have another PSU try sadly, but I will measure the current running through the bed as you suggest.

However I can not not connect to my Melzi electronics at all so I can not currently check that now.

I suspect that the ATM 1284 chip on my Melzi is caput as I can not communicate with the Melzi through Pronterface or the Arduino IDE.Is there any way to physicaly check if the chip is damaged? I was thinking of measuring the voltage on the AREF or AVCC. Would that work?

Re: HELP with RepRap Pro Melzi Electronics
February 13, 2013 12:57AM
Ok those kinds of electronics arent going to affect anything, the level i was talking about was significant motors like 500w+ without softramp (no vacuum cleaners or washing machine ones), welding tools, a room with 10-20 neons of 20w each, etc this kind.

Checking the bed is made offline, if you have a multimeter, you measure its resistance in ohms while nothing is connected to it: from the reistance read use ohms law to see how many amps it should draw, and compare that with what is written on the label of the atx psu. Also offline check with multimeter, on the board, you can also try measure the resistance between voltages and ground at the inputs of the board, if you get fairly low values those might indicate a short, though take that information with a bit of salt.

Yes ofc you can measure voltage on the +5V line wich i guess it comes from usb? I looked at the schematic and seems to be a selector to choose if it makes +5v from the 12v or takes +5v from usb, so first if that selector is wrong position it wont use the usb for power. The usb can detect if consumer draws more than a value (~0.2A i think) and if it is so, it cuts it off. Also, measure the +5v volts on the usb connector, it could just happen to have that short detection part got burned, in which case it the usb might not offer power at all (i have that in a desktop pc motherboard).

You can also can try start the atx psu without anything connected and measure its voltages, although that wont be a good indication if it actually can supply the current or not when is actually under load. Sort of speaking, i would rather suspect the atx before anything else, if only for wishful thinking. Best of luck!
Re: HELP with RepRap Pro Melzi Electronics
February 13, 2013 09:31AM
Ok so I measured the resistance of my bed at 1.5 to 2 ohms (at both the bed and Melzi connections) in line with what the mendel assembly guide says. Using V/R=I gives me 12v/1.5ohms=8 amps. For the hot end this is 12v/3.0ohm=4 amps for a total of 12 amps. My PSU is rated for 20 amps so I dont think thats the problem and it is the one supplied with the kit so I think they would have matched it to the components im using.

Also offline check with multimeter, on the board, you can also try measure the resistance between voltages and ground at the inputs of the board, if you get fairly low values those might indicate a short, though take that information with a bit of salt.

I dont quite understand this portion? do you mean check the tracks on the board back to the transistor or something? or at the screw connection on the board? (I have done that and get similar values to that of the bed)

So I always had the board setup to use USB power (I did not realize it asked me to opperate it the other way unless you were uploading firmware to it). Last night I checked and with the Melzi plugged into one of my USB ports and not the PSU I got 4.84 volts at the AREF, AVCC, and VCC pins of the 1284P chip. Also all of the grounds were connected to the powersupply grounds with resistances of under 300 ohms. I guess that means it is at least getting power from the USB.

Can you explain how the short detection system works? Is there anyway to measure if it got triped? and then can one reset it?

I suspect the chip of being corrupted or worse now.

I tried to upload new firmaware to it but I can't even burn a bootloader to the chip. I get this error from the Arduino IDE

Binary sketch size: 1128 bytes (of a 129024 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Thanks for the help,

Re: HELP with RepRap Pro Melzi Electronics
February 13, 2013 01:51PM
Ok, ill try to explain what i mean, it was a little different: offline measure resistance between +5v line (e.g. 4.84v somewhere), and a ground point. Basically measure the resistance between the 2 inputs of a "black box" / whatever device. If resistance is way too low, then there is a short, and vice versa.

I think its very common, sometimes its a first thing to do as debug practice. Say you wanna repair whatever broken device which you know it should consume like 300w/240v coz its on the label, and take its / power plug / power cord / input leads / and measure resistance across. Same as with the heated bed. E.g. if its a 240v mains device and reads 10 ohms then thats too low coz it gives 24a/5.8kw so you know that it will actually blow the fuse as soon as you plug it in. So dont plug it in yet, need to fix that first. Its good practice coz saves you a trip to the fuse panel.

Perhaps this is situational and limited and interpretable from case to case. But if you suspect a short somewhere, this might be a good method to show it up. After all shorts can only happen between different potentials, to think in a different way.

I'd say if you measure between 5v and gnd around 300ohms that would point to a figure of 17mA in that state, which i'd say is quite reasonable. It does NOT mean that will actually draw 17mA when powered up, but whats important is that in case of a short, the number there would of been quite different. Again its just an generic offline check.

I think the 12v/3.0ohm=4 amps for the extruder is interesting. First, i think the generic reprap resistor is 6R8, so i have to ask, are you sure your resistor is particularly 3.0 ohms? Second, put the test leads like this: one on the heater block (aluminium part or what it is), and second onto each of the resistor leads. Wobble the resistor inside while doing it. If you read anything at all, you might have a short inside the heater block, so current by-passes the resistor or at least parts of it, especially if the leads contact the block. This can be a plausible cause for the description given, e.g. not being able to heat up, perhaps even the fet entered thermal runaway, so check this too.
Re: HELP with RepRap Pro Melzi Electronics
February 15, 2013 04:13PM
HI Noobman,

You are right that was measuring the resistance with the rest of the board connectd. However when I disconect it I still only get 3.5 Ohms. There is no short with the aluminium heater block, but one of the wires from the heater block came lose it created a short just before it died.

I am almost certain that the problem is on my Melzi board as I cannot communicate with it through the IDE or Pronterface.

Do you know if the Melzi board can burn a bootloader onto the chip that is installed on its board?


Re: HELP with RepRap Pro Melzi Electronics
February 15, 2013 07:07PM
No it can't. You can only program it via USB when the boot loader is installed. To install that you need an ISP programmer.

Re: HELP with RepRap Pro Melzi Electronics
February 15, 2013 08:17PM
To burn the bootloader you probably want an ICSP programmer, the cheap ones might have issues with >64kb which i think this board has. So in this case you would probably be better with an atmel programmer. Which has a chance to cost more or less in the range of a new melzi board.

I think that just trying to burn a bootloader probably wont fix issues created by shorts & over currents/voltages. Dunno why from all things you are focusing on the bootloader (where did the old bootloader go?). Cant treat broken things as they are working, and hope they comply.

I think that you also need to express clearer, in general. I still am not quite clear what the 3.5ohms figure represents, between which points. Also the figure of 300 ohms from your words few posts ago says its resistance between different parts of ground, i just assumed on my liking that its +5 to gnd, and atm it seems it wasnt correct. Resistance is always measured offline, no need to specify so. Perhaps try find a real life friend to help you. Sorry you are in a tough spot right now, i can see that. Best of luck!

Edited 1 time(s). Last edit at 02/15/2013 08:18PM by NoobMan.
Sorry, only registered users may post in this forum.

Click here to login