Welcome! Log In Create A New Profile


Diagnosing PWM Driver board problem

Posted by Ross 
Diagnosing PWM Driver board problem
December 17, 2008 04:40PM

I hope someone can assist me with this problem.

I have assembled the PWM Driver board (V1.1) from RRRF and the power LED lights when power is connected but none of the output LEDs light when I run the exerciser code (loaded or unloaded). I am assuming they should light up as this was the case with the stepper motor boards I tested and they worked fine.

I have checked all components are soldered in correctly, checked the transistors are soldered correctly and double checked the connections to the Arduino.

I tried running a PS fan from each of the ports but get no activity on either the LED for the port or the fan. The fan does work when I connect it directly to the PS.

Since none of the 3 ports generate any activity I can only assume that there is a fault in some area that controls all 3 ports.

Can someone give me some hints on the tests I need to perform to determine where the problem is? Voltage readings with a meter at test points etc. would be good.

Regards, Ross
Re: Diagnosing PWM Driver board problem
December 17, 2008 05:53PM
You can test the board by connecting the inputs to 5V and see if the corresponding LED lights. It it does the problem must be at the Arduino end. If not then it must be a construction error. Check the parts are the correct parts and the transistors, diodes and LEDs the right way round. I particular check R1,R2 and R3 are 1K (brown black red). I am sure I read somebody had received 100K (brown black yellow).

Re: Diagnosing PWM Driver board problem
December 17, 2008 05:56PM
In fact here is the post I remember: [forums.reprap.org]

Re: Diagnosing PWM Driver board problem
December 21, 2008 04:01PM
Thanks for the idea, nophead.

I am using the spare 5v pin on the Molex connector with a hookup wire to see if it will turn on the channel but still no luck.

As in the post you mentioned I have verified the resistors are 1K ohm and 560 ohm. I have also used a meter to trace the tracks and ensure there are no breaks. I replaced both capacitors and a transistor on one channel to no benefit. I have also desoldered the diode to ensure I did not fry this rather than solder it but it tests ok.

Interestingly I purposely inserted this reversed to ensure the board was marked correctly and when I did this the channel came on as soon as I applied power. This is what I would expect so I soldered it back in (after checking it was still ok). I guess that this proves that the circuitry up to the transistor is ok but that the input line to the transistor is somehow faulty. What do you think?

I am now totally lost on this. I find it extremely difficult to believe I have fried all 3 channels as it all looks like they are mounted fine. I have checked for dry joints by attempting to move each component with the power applied, no luck. I can only assume that the problem is in an area that is common to all channels. My last thought is to trace all the connections with the meter and look for any bridges to ground. Since the reverse of the board is a common ground this is likely.

Thought I was onto something when I examined the circuit diagram and noticed that the pin labelling for the molex connector is the wrong way round (http://www.flickr.com/photos/hoeken/2487838735/sizes/o). This board takes 12v but shows the power rail connected to pin 4 which on the pinouts I have should only carry +5v.

Afraid my skills in diagnosing circuit problems is pretty naff and would appreciate any help getting this sorted.

Thanks in advance, Ross
Re: Diagnosing PWM Driver board problem
December 21, 2008 04:57PM
When you connect the input to 5V what voltage do you get on the base of the transistor? It should be about 1.4V.

Can you post a picture of your board, I might be able to spot what is wrong.

Re: Diagnosing PWM Driver board problem
December 22, 2008 03:31PM
Thanks nophead,

Aw bugger!

I just checked the colour code of the input resistors and a colour code of Brown/Black/Yellow works out to 100K not 1K. I misread the colour codes when I verified it earlier.

PS:I took photographs of the board but found they were badly out of focus and it was impossible to see anything (all the technology in the world can not make me into a photographer).

Now I'm off to get some 1K resistors to try. Will keep you posted.

Regards, Ross
You were right, nophead. Problem solved!

Replacing the 100K resistors with the 1K ones solves the problem. All 3 channels work as expected with a load now.

Many thanks for your assistance in helping me sort this out.

Regard, Ross
Sorry, only registered users may post in this forum.

Click here to login