Welcome! Log In Create A New Profile


Unusual stepper ratings - vref settings for new Melzi

Posted by Mr Joshua 
Re: Unusual stepper ratings - vref settings for new Melzi
February 23, 2014 05:55PM
Yes I've used that plenty of times now cheers!

Ok, so the latest is that I've tried again using the Marlin firmware with the device defined as a Mendel.

It behaves strangely with this. 'most' of the controls work, but the steppers are intermittent. It might be that all the directional steppers work ok at first but then one or more axis stops responding seemingly randomly.
They may sometimes then begin working again, or not, seemingly as they feel like it. Resetting seems to help at that point, although after resetting the number of axis working manually is not always consistent. It seems to have a mind of its own basically!!

I will try again with the sprinter firmware and see if it works this time at all, since that's meant to be the right one, but last time I tried it, it seemed like there was a communications issue as a connection was made ok between software and printer, but no commands seem to go through, ie they stay queued in repetier for some reason. It's like the printer is connected but not listening somehow.

The plot thickens.
Also, I have doubled checked all the wiring connections, and tried a different USB cable but neither made a difference.

Is it possible that with these 'bad' stepper motors that they could make the board behave in a slightly erratic way in respect of the steppers working one minute but not the next?

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
February 23, 2014 06:16PM
Make sure that you define the correct motherboard and it has correct pinout in a file called like pins.h or something like that. Perhaps the poor behaviour is because some pins are wrong, just something to check.
Re: Unusual stepper ratings - vref settings for new Melzi
February 23, 2014 06:32PM
Thanks - the board is right, it's set as 62 which is the Melzi, but I'm not sure about the pins thing in all honesty.
I'll check what is set in that file but I've no idea what it should be so I'll have to research that.

If that was wrong could it cause the erratic behaviour? I was wondering if that was potentially a side effect of the motors that I've got being not very compatible...

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
February 23, 2014 06:44PM
Here's the pins file for the marlin firmware that's on currently.
I've no idea if it's right or not though sorry!

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
February 23, 2014 07:39PM
I think in that file 62 is sanguinololu and then melzi is 63 instead.

The uC has a pin numbering scheme. If you open the pcb source (the source file in which the pcb was made), that will show basically your entire board and you can see which pin is used in a certain way. Those pin numbers are then put into the pins.h file, so the firmware knows what each pin is supposed to do. For example between sanguinololu and melzi many pins coincide, but still some are different because who made the board optimized things in its own way. At least thats the logic behind it. To make things confusing, normal arduino boards have pins with numbering which do not necessarily coincide with the uC pin numbering, and on top of that there is some analog and then some digital numbering. It doesnt matter much and normally boards pins.h are already correct in firmware, but just be aware what they mean and what wrong pinout reference definition can do.
Re: Unusual stepper ratings - vref settings for new Melzi
February 24, 2014 06:05PM
Thanks for the info (again!) - I'll try to check this out to confirm.

I got the new steppers today (ie the correct ones), one of them having a nice severed wire as an added bonus!
They're wired in but it's really no better. I was getting the same inconsistent & erratic behaviour with it in the sense that occasionally I might have all the axis motors responding correctly, then it'll just refuse to do anything, then bits begin to work again as they see fit.
I did however set the vref on the melzi pots to 0.6v as they were at around 0.3 ish (a guide I read recommended 0.6-0.8v), and I noticed something interesting.
After doing this, the PSU has begun to misbehave somewhat, powering itself down repeatedly when trying to power the printer up.

Now it's a claimed 650 watt ATX PSU but I don't believe that as it was very cheap. It states 28amps on the 12v rail.
I doubt that's true, but even if not, it still should have enough power to easily handle the steppers alone surely, ie without powering up the heaters?

I have a couple of known decent spec ones, so I'm going to borrow the OCZ one that's in the arcade machine I built and try with that. If nothing else I can rule out the PSU then as the fault.

This might be a silly question, but how susceptible are these things to electrical interference? The reason I ask is that the printer and the PC controlling it are less than a meter away from my house's main power board/fuse board/consumer unit, and I'm wondering if that could somehow be interfering with RF or something?

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
February 24, 2014 07:36PM
I think I finally have some useful progress at last!

New PSU and it seems to be behaving far better, and have moved the carriage & bed to their end stops before switching on. They behave quite well now.
I think the end stop on the z axis needs tweaking still.

2 issues I think now.
The bed doesn't appear to be heating (bed temperature shows as -33C at room temp of about 13C), and the extruder doesn't appear to be feeding/retracting, despite going past the default temp for it to be enabled.

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
February 24, 2014 11:54PM
If your bed reads below the minimum temp, it won't heat. Same goes for the hot end (for hot end readings). This is because a very "low" reading is also the same as having the thermistor disconnected. If the thermistor is disconnected, you can't tell when to switch off, which would be dangerous.

1. Try heating the bed to ~20 deg C before turning it on. A hair dryer or even just putting your hand on the bed might help. If this works, then you want to change the minimum temp reading in Marlin for the bed.

2. Got the right thermistor settings/calibration? Haven't accidentally electrically shorted the heated bed to the thermistor somehow? Got the bed on the right connector (eg: not the one for the second extruder) ??
Re: Unusual stepper ratings - vref settings for new Melzi
February 27, 2014 09:13AM
Sorry - I thought I'd replied to your post Cefiar but it seems I didn't!

I will check what you've suggested tonight all being well. Have had a very busy few days, however I did make some progress last night.

I took the printer to my friend's house to sit it beside his one, and compare. It seems my other friend that I bought it from (nearly complete but not quite) had made a few mistakes when assembling it, so I corrected these things and got it mechanically at least how it should be set up.

Currently, the issues I've got can be summarised as below:
1) The extruder motor is not responding to manual commands in either direction (even after the nozzle is over 170 and it's 'enabled'). Not sure why.
2) Non of the end stops are functioning. Pressing them appears to make no difference to the movement in either direction of any axis.
3) The bed doesn't heat, and states that it is at -33c at ambient temperature. Already covered, above.

So I'll look at the bed issue tonight and see what I can find out from there.

No idea on why the extruder is being ignorant to its instructions, but the end stops not working is I presume something that needs tweaking in the config file.

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
February 27, 2014 09:14AM
I've compiled a list of things to check tonight anyway...

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 04, 2014 01:30PM
Hi Mr Joshua,

I am also experiencing some trouble dealing with an rp3D.com Melzi board.
I also have managed to upload the firmware, although I tried with Marlin...with similar results as you.
Right now I am stuck into trying to upload the firmware (again), which is something i did two days ago but now I'm unable to replicate.
As soon as I get somewhere I will upload through this thread.
By now, just want to send moral support...smiling smiley

Re: Unusual stepper ratings - vref settings for new Melzi
March 04, 2014 09:43PM
Thanks for the reply mate, what exactly is the current issue you have?

I think I made progress tonight at last!
I found another firmware that is a version of marlin meant for a prusa (I think), and tried it.

I now have all axes working including the extruded!
Oddly, I have to turn my machine 180 for the axes to move in the correct direction (so the Y motor is now at the rear instead of front).

All 3 axes now move correctly to manual inputs, and when I press the home button for each axis there is movement towards the end stop. When the stop is pressed, the steppers halt, or move back a little. So this is great!

The nozzle thermistor is showing a little too warm (maybe 10c warmer at ambient that it is) and the bed thermistor is show 28 at ambient when it should be around 10c. Both heat up ok though.

I think the only real issue I still have is that the Z axis moves mega slowly. Guess this is a configuration setting to change.

Definitely progress though, I'll link up to the firmware tomorrow in case it's a help to you.


Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 05, 2014 08:06PM
Well I'm absolutely delighted to report that finally, my printer is alive, and has printed something (sort of).

It wasn't 100% successful, but I can't describe how happy it made me to see it printing something after all the hassle trying to make it behave.

So the remaining issues are these:
1) Importantly, the Z axis moves mega slow compared to other firmwares, and is not moving the correct distance that it thinks it is. I researched and found one person's solution to this was the Printer Settings in repetier, to set the Z axis feed rate from 100 to a higher figure. I tried this, and sure enough it moves a LOT faster from manual commands to the Z axis, but when it's printing, it did the first layer or 3, then began dragging the nozzle through the deposited plastic because it clearly wasn't lifting itself up enough for each layer/slice. I'm slightly confused currently as to which speed related (or step value related?) parameter I need to correct in order to fix this, but basically if I can figure that out then it will be able to print real proper stuff at last!!!

2) Minor issue - the extruder thermistor reads the correct temperature, but the bed thermistor reads about 15C too high. This seems odd since I have them both specified as the same thermistor, so why it would think one is a lot different to the other is beyond me.

Other than that though, it appears to be functioning correctly.

I'm so happy to have it at this stage, so if anyone can advise which setting I likely need to correct for the Z axis thing, I'd be mega grateful!!
The thermistor thing is less of an issue but it'd be nice to fix that too admittedly.

Many thanks
smiling smiley

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 06, 2014 04:27AM
Hi Mr Joshua,

Congratulations! grinning smiley
A little step forward but when looking back..so much knowledge gained!
Anyway...I still haven't fixed my own problems but I think I can help with yours..smiling smiley

After endless hours of research and trial and error I have figured out that the myriad of firmwares that exist can basically group into three:
  • Sprinter development
  • Official reprap.org Marlin development
  • repraPRO Marlin development

And the myriad of available hardwares that exist giving place to our beloved Melzi are four:
  • Sanguino
  • Gen7
  • Melzi with Atmega644
  • Melzi with Atmega1284p

Both lists are more or less in chronological order (i believe), and create a combinatorics of 12 possible configurations all of which would take a loot of time to master...not to mention the workarounds...confused smiley
To make the story short, it appears to me like the reprapPRO (aka RRP) started their own branch of Marlin (which is a "mashup of Sprinter and grbl") that would fit in their old melzis with Atmega644. I understand they did so because the "official" reprap Marlin uses thermistor tables that, once compiled, take larger memory than an algorithm to calculate the temperature and in this way they "improved" the firmware by making it fit in a smaller chip.
However, this is where all of our pains began. By making a branch that looks so much like the original one but what suits only to the printers they sell, reprapPRO contributed to make the already confusing reprap development even more confusing...they even store their code in github, like reprap!!drinking smiley. (Don't take me wrong, I don't think they had bad intentions and i acknowledge all their invaluable contributions, but this one...ojojoj...).
So, the conclusion is, once the chips of the Melzis and Sanguinos grew in size to an Atmega1284, now they have capacity for the "official" Marlin firmware, but unfortunately now it cannot measure the temperatures properly because the thermistor table can't take in consideration the little resistor that is put in series with the connector of our Melzi...spinning smiley sticking its tongue out
But, that is not the end...regarding motors, if yours don't fit exactly the specifications of those of reprapPRO, then you are also doomed...the stepper.cpp program that controls them (well, actually it controls the stepper drivers) is so much different from that of the "community" development that you need both their motors and their stepper drivers, which i assume are the ubiqutous allegro4983, but couldn't find any reference for that...
To finish with this, the only way out here seems to be:
  • Tweak the firmware to adjust temperature tables (I don't dare to check the algorithm..eye popping smiley)
  • Wait until someone with more knowledge does (yawning smiley)

As I see it, only the first option is a viable one...Regarding the temperature, i am quite fearsome (please if someone else is reading this stop me before I begin...confused smiley). About the motors, I have succeeded also in controlling them by means of the "official" reprap version of Marlin, so I recommend you to do it because, at least in my experience, they sound smoother than with the reprapPRO...

I will keep you updated! Good luck!

EDIT: For the Z axis I have it set up to 4000 in the line:

#define DEFAULT_AXIS_STEPS_PER_UNIT {81.80,80.70,4000.0,600.0} // default steps per unit for Ultimaker


Eventually I have all the axis working, homing as they should, although the stepper drivers get a bit too hot for my taste. Regarding the temperature readings, after some hours of struggling with the HUGE piece of code that is MARLIN I found out that someone else has already done it: the rp3d.com people! grinning smiley
So, this is what I have done:
  1. Get the Marlin from the thread that Mr Joshua pointed in Soliforum : http://www.soliforum.com/topic/5436/pangu-i3-the-best-price-quality-ratio/ (thanks Mr Joshua and YScool smiley
  2. Edit the thermistor table using the reprap calculator pointed by YSB: http://nathan7.eu/stuff/RepRapCalculator/RepRapCalculator.html#TempLookup
  3. Connect with Repetier and...enjoy!

Now I have to adjust a bit the potentiometers in the stepper drivers, because the motors sound too loud and they are getting VERY hot, even though the voltage is set to 0.8V as indicated by reprapPRO (sorry, their link is down today..sad smiley). I will follow up these instructions (hoping that I have the a4982 drivers...): http://reprap.org/wiki/Pololu_stepper_driver_board

Edited 4 time(s). Last edit at 03/06/2014 03:49PM by ndujar.

Re: Unusual stepper ratings - vref settings for new Melzi
March 06, 2014 03:34PM
Thanks for that reply - I appreciate the input smiling smiley

Yes it's been frustrating getting to this point with all the problems but only from the perspective that it was meant to be something that would have worked more or less straight away.
I do enjoy the learning, and getting a better idea of what's what by virtue of it not working until now. I would be very lazy about taking the time to learn though had this thing worked from day 1, so all this is to my advantage really.

Re' my two remaining issues I'm not at this point hugely concerned over the bed temperature reading.
As I say it's reading 15C above real temperature, but I'm wondering if I can cater (temporarily at least) for this by setting the working temp 15C higher than it currently is?

More importantly, the one issue I really have to address before I can do prints properly is the rate that the Z axis moves.

I realised that with all the corrections and faults I've had to look at and resolve I've actually overlooked the part of the commissioning/calibration process whereby I should measure how far each control moves, relative to the manual commands issued for a given distance.

I think most movements are close to being correct, but know for sure that when I tell the Z axis to move 10mm, it actually moves closer to 2mm!! So I assume from this that the step size setup for Z at the very least is incorrect. I've never looked at those settings so I will investigate tonight and look on the wiki for how I calculate all that stuff.

I will also look for the setting you described (DEFAULT_AXIS_STEPS_PER_UNIT) to see how mine is currently set!

Hopefully once that's done I'll be able to actually print something properly, but I'm still really pleased that I got it do 'something' anyway.

I get the point of the suggestion re' changing the firmware, but I think with getting this one so close I'm going to persist with it for now as it's so close to working correctly now. I don't want to potentially go back to square one again with different firmware if I can avoid it easily.


Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 06, 2014 05:08PM
Update - I found the Z steps/mm was set as 533.33mm/s and should be 2560!!

So I changed that and so far so good - it is currently printing a 20mm box in ABS. I can see it's not quite right as it prints but it's doing it anyway so I will let it finish then inspect/analyse.

One thing I have noted is that it first prints like a perimeter layer or two that is not the main print, before it starts the model it is printing. I'm guessing this is:
1) To ensure the filament is fed through and ready to begin, and
2) Gives you a chance to see if it's sticking to the bed or behaving right before it starts the model.

Is that the case?

When it begins both the perimiter print and the model itself I notice the plastic extruded is done in a very wiggly line. Does this indicate a fault?

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 06, 2014 05:15PM

The perimeter line around is called skirt. You can configure it in Slicer and yes, I also think it serves the purposes of pre-testing adherence and other stuff.

Regarding the wiggliness, it might be (but i'm not sure) that the layer is too high. It should be a number slightly smaller than the nozzle size (mine is 0.3 and my layers are 0.25).

Happy printing!

Re: Unusual stepper ratings - vref settings for new Melzi
March 06, 2014 05:54PM
Thanks - I'll look up where the layer thickness is set, cheers.

Here are some photos of my printer's first successful (but rather inconsistent quality) printed object. It's meant to be a 20mm block.

Here it is on the bed with the squiggly surround bit:

Position of the print job on the bed (no idea if this is right?)

And close ups of the printed item. The underneath/first layer (it missed the first corner of fill in for some reason):

And from the top. You can see it has sunken a bit in the middle, and along each edge, leaving the corners raised:

I'd be really interested in feedback on the visual appearance in terms of obvious things I might have less than optimal settings on, leading to the print being a bit 'wonky'!

So so happy to have actually produced a print though at last. smiling smiley

Edited 1 time(s). Last edit at 03/06/2014 05:58PM by Mr Joshua.

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 06, 2014 06:07PM
Congratulations...is actually very good...grinning smiley...is it PLA or ABS? I am having a terrible time with ABS...hot smiley

Maybe you want to have a look at this: http://reprap.org/wiki/Print_Troubleshooting_Pictorial_Guide
Your "wobbliness" problem is, unfortunately, not listed eye rolling smiley but it might be caused by excessive pressure in the exit of the nozzle. I would try to calibrate the extruder motor to make sure it is not pressing too much...

Happy printing! grinning smiley

Re: Unusual stepper ratings - vref settings for new Melzi
March 06, 2014 06:30PM
Thanks mate smiling smiley

It's ABS that I've used. I was going to buy some PLA but my friend gave me a reel of ABS that he had spare so I thought I'd use that even though it's meant to be more difficult to get good results with ABS.

Thanks for the link - I'll have a look, and I need to look for the layer height setting and adjust that too potentially.
It could be the extruder steps actually. I measured all the Axes movement was correct before, but didn't test the calibration of the extruder I must confess!

What trouble are you having yourself? I hope you get it sorted out ok.thumbs up

Edited 1 time(s). Last edit at 03/06/2014 06:32PM by Mr Joshua.

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 06, 2014 06:44PM
Hi thanks for the support! smiling smiley

I mostly have trouble with the hotbed. In the beginning my board was a RAMPS1.4 that got the hotbed controller MOSFET fried and now I am trying with this Melzi.
The theory (and the hard experience) is that if the bed is not warm enough, then the adherence is crap. I have tried many things (ABS juice made out of ABS and acetone, sugar in water,...) but still because of not getting good temperature in the bed the pieces shrink in the corners and after a while they begin to loosen, so eventually the extruder just pushes the piece off...normally close to the end of the printing!! moody smiley

So, that being said, congratulations again...smiling smiley...I think tomorrow I will try a bit more...

Re: Unusual stepper ratings - vref settings for new Melzi
March 06, 2014 06:48PM
That must be very frustrating! What temp do you have your bed set at?

The thermistor for my bed gives the wrong temp readout for some reason, so when the ambient temp is 11 degrees say, the extruder temp will say 11C, but the bed will say 26C.
So because the default bed temp was 110, I changed it to 125C so it would really be giving 110 if you follow my rationale?
I think it's too hot though and is warping the prints from seeing a pic on the link you provided.

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 06, 2014 07:07PM
I have it set at 100C, because of the warping that you mention, but the truth is that I was doing the temperature control manually with a switch because of the fried MOSFET of my RAMPS..eye rolling smiley
Fortunately, now I finally have my Melzi running, so as soon as I have the time I will get back to it..smiling smiley

Regarding your temperature control, I am not quite sure the rational is correct. The curve of the thermistors in not linear but more like this:

So it could be that at 110C you are having a completely different reading...

Again, it is just a matter of finding the upper bound at which both extruder and hotbed work fine so I think your approach of leaving it as it is is also correct...smiling smiley


There is quite a lot of science behind all this temperature control that IMHO is getting very complicated: [reprap.org]

Edited 1 time(s). Last edit at 03/06/2014 07:10PM by ndujar.

Re: Unusual stepper ratings - vref settings for new Melzi
March 06, 2014 07:10PM
Ahh ok thanks. I have reduced it to 115 now to try.

Shame about the fosfet sad smiley Hopefully it won't happen again.

Do you happen to know where the layer height is stored at all?
*ignore actually - I found it in slic3r* thanks

Edited 1 time(s). Last edit at 03/06/2014 07:14PM by Mr Joshua.

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 06, 2014 07:20PM
Hehe..no worries..is part of the painful process...smiling smiley

Layer height is controlled in the Slicer.

If you have Repetier it is the second menu, under the button of "configure". Then Slicer pops up and you can see it in the first menu where it says "Print settings".

If you have Pronterface or any other you will have to find the Slicer, open it and change the configuration...

Happy printing!

Re: Unusual stepper ratings - vref settings for new Melzi
March 13, 2014 07:48PM
Well I've progressed a little now but in some ways not.

I managed to damage the extruder assembly by getting it too hot, and it had been printed in PLA instead of ABS so it wasn't too pleased and mutated itself as a result.
I managed to get it working again and swapped to PLA, plus fitted the proper tensioners to the belts etc.
The PLA prints to begin with were WAY more neat than the ABS ones, except for one problem I just cannot resolve so far.
I can't get the damn things to stick to the bed at all. sad smiley

I might get 3/4 of the way through the 20mm box test with it looking great, then it suddenly comes free from the bed. It's not curling at all - it just suddenly comes loose.
I'm printing to kapton covered glass, and have wiped it with acetone. I've tried tons of variation in both extruder and bed temperatures, but all to no avail. I just can't get the sodding stuff to stick at all.
I've even removed the kapton from one half of the bed as I'd read it can work better that way with PLA but it's no different. The gap between the bed & extruder is maybe 1mm or so. It's pretty close.

Any good ideas?

I can't do much right now anyway as i need to build up the new extruder assembly my mate has made for me in ABS. It's very different to my current one, so I need to find suitably long M3 bolts etc to fit the filament clamp.

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 14, 2014 05:02AM
Oh terrible news about your extruder...good thing to have friends around..smiling smiley

Regarding PLA, acetone (with dissolved ABS) does not work with it. ABS juice is only for ABS.

A good solution mentioned here (http://reprap.org/wiki/Print_Troubleshooting_Pictorial_Guide#Bed_Adherence_insufficient) is blue painter's tape. It works...

Happy printing!

Re: Unusual stepper ratings - vref settings for new Melzi
March 14, 2014 06:34AM
You can also try print PLA on glass, that is if you can find a small piece of glass.

And perhaps double check the acetone label, if its that type of acetone for removing paint from finger nails, it may have other components like aloe vera stuff or paraffin which is a wax and wont help with adhesion. Sort of speaking label should say that content is only acetone and water, and nothing else.
Re: Unusual stepper ratings - vref settings for new Melzi
March 14, 2014 08:04AM
Thanks guys

Sorry, when I mentioned acetone I meant just using that to wipe the bed clean, not using ABS juice. I should have been more clear.
Not sure re the label, it was a gallon I bought when rebuilding my boat but there's no label on it now.

I've tried direct on heated glass but that won't stick either. Going to get some hairspray at lunchtine!

I nearly got the new extruder assembly working last night but the mounting of the stepper motor does not seem to allow the pinion to mesh with the main gear, so I need to get the dremel on it to modify the fit. It's a bit of a mess though. I'm not certain if it will work correctly but I'll try again tonight.

I'll try to buy some blue tape. Does it go by another name at all that specifies more what it is?

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 14, 2014 08:45AM
From my experience PLA on glass should be a quite reliable, even more if the bed is heated mildly like 50-60C - if glass on heated bed reaches like full abs temperatures the glass may crack and break.

Perhaps there is something else wrong, with the acetone or temperatures. Imo, try hijacking your girlfriend/wife supplies for some nail polish remover which at content says only acetone and water, and try with that one instead, just to be sure. Or perhaps your extruder pla temperature is too low and plastic gets cooler before reaches the bed, hence wont stick, so try measure heater temperature with a tmermocouple multimeter to check if thats the case.
Sorry, only registered users may post in this forum.

Click here to login