Welcome! Log In Create A New Profile


Unusual stepper ratings - vref settings for new Melzi

Posted by Mr Joshua 
Re: Unusual stepper ratings - vref settings for new Melzi
March 14, 2014 10:40AM
You might also want to put the extruder a bit closer to the printing surface. It depends on the size of the nozzle, but surely 1mm is too much.
Actually, the "correct" distance for the nozzle is such, that when it is not printing you can pass a piece of paper and feel the friction, but without blocking.

This is an excellent tutorial:


Regarding the blue painter's tape, it is something like this:


It has some paper-ish texture, but overall has a rough surface here PLA can attach. It doesn't work with ABS at all, by the way..:-/
However, I am inclined to believe that the problem is that of the separation...

Re: Unusual stepper ratings - vref settings for new Melzi
March 14, 2014 04:30PM
Thanks - I haven't measured it as 1mm but I'd guess it's around that, maybe a touch less. I've read different things about the height - some saying a piece of paper, others saying thickness of a credit card etc.
It is definitely much more than a sheet of paper though so once I reassemble it, I will adjust that accordingly thanks. smiling smiley

I picked up a roll of Scotch blue painter tape on the way home tonight. It's 3M, and I think has 2090 written on which I'd seen someone else say they have good results with.

From my experience PLA on glass should be a quite reliable, even more if the bed is heated mildly like 50-60C - if glass on heated bed reaches like full abs temperatures the glass may crack and break.

Perhaps there is something else wrong, with the acetone or temperatures. Imo, try hijacking your girlfriend/wife supplies for some nail polish remover which at content says only acetone and water, and try with that one instead, just to be sure. Or perhaps your extruder pla temperature is too low and plastic gets cooler before reaches the bed, hence wont stick, so try measure heater temperature with a tmermocouple multimeter to check if thats the case.

The glass is fine up to really high temperatures as it's boroscillicate stuff and I've had it up to over 110C so far.
I'll see if I have another empty acetone tub around still to see if there's a label but yeah, the wife will have some. I'd read that NVR acetone generally wasn't good stuff to use though due to other ingredients they mix in. Won't hurt to try I suppose.

PLA temp I've tried between 185 and 200 (possibly higher, I forget). It extrudes easily.

Anyway, I'm just rebuilding this new extruder assembly. I've got the stepper to fit correctly now, but just found there's no means of attaching the damn hot end to the housing!! The old PLA one had two bolts the went through the side of the plastic on the hot end to secure it, but the new housing has no holes and, as they hung lower than the rest of it, I can't just drill a couple since they need to be positioned where there's actually no plastic on the new ABS piece. If that makes any sense!
So the slot around the upmost part of the hot end, sits pround of the new housing. I think I will have to make a piece of ally that sits across the whole foot of it and goes through the groove in question to secure the hot end in place.
Not feeling too motivated though as my garage is freezing and I've just been drained by the kids throwing a tantrum when I was settling them to bed!

Maybe time to just have a beer and ponder it until later this evening. smiling smiley

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 14, 2014 05:29PM
Beware the temperatures indicated by the sender are some estimations based on the thermistor table calculations. There is no zero or no other absolute reference in it, so if the tables have errors (they do), the temp indicated on screen can be +/-10-20C difference. Hence is better to double check with a multimeter thermocouple. Or at least by hand, with the filament free you can try pushing down the filament by hand and it should be easy to push. It its hard to push, you should make it easy to psuh, for example increase temp or increase the inner diameter of the most of the zone where the filament passes through, just a little like with +0.2mm increase on 80% of the upper length.

Regarding the hot end, if its teflon with 16mm diameter, you can find a piece of copper pipe with 16mm inner dia usually used for heating radiators, narrow the bottom, and fit the teflon inside that. And then solder with a heat burner some other piece of copper or metal to help attach that to the rest of the extruder. Copper would somewhat help keeping the teflon cool and mechanically rigid, so it wouldnt be bad at all. Anyway its just an idea, and if i understood the situation correctly.
Re: Unusual stepper ratings - vref settings for new Melzi
March 15, 2014 05:22AM
Thanks for the suggestions - I've got an infrared temperature gun thing and I know the bed heats around 15-20C lower than it states on screen. It's harder to gauge with the extruder.
I printed this last night and I'm so pleased to finally get something that worked (I got the blue tape!), but as you can see the infill is really bad.

I wasn't sure why but when it finished I could see it was no longer extruding correctly. I had it at 200 degrees, and at times when I push the filament it came out freely but then seemed to jam. I've got no idea why as the extruder gets a good grip on it. Not sure if I've got dodgy settings that could be causing the hobbed bolt to get clogged up if it's trying to go too quickly. I've got it set at 13mm extrude, at 150mm/min, with 3mm PLA, 0.5mm tip, and 0.4mm layers.

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 15, 2014 09:57AM
If there are any extruder jam, that can be dangerous if its hardware related. Maybe the diameter of the filament path is too tight and when filament gets hotter its dilatation presses against the walls and gets it stuck. Or it could happen that the nozzle has some dirt in it and just blocks the exit hole (seems unlikely but i got that few times). Heat up the extruder at 200 and then let the filament free of idler and stepper, and have the filament totally free without any grip. And move filament by hand, see if goes up and down in a fairly easy way. It should not be really easy, but not hard either. If its hard to move ot if it tends to stuck or jams, then you should figure out why is that and fix it before proceeding further. The idea is to to bypass the extruder's grip on the filament and see how hotend behaves.

In all fairness the pictures could also look like that if the slicer settings has some extruder parameter with a wrong setting (e.g. the filament diameter, or flow rate, or things like probably smaller than it should). It could be very well that is the cause and the extruder and hotend work just great. But it doesnt hurt to check extruder and hotend first. Because if it is about a hotend that tends to jam and you upper the extrusion force in this context, things can go band and the extruder can break itself under the pressure, or it may get permanently jammed and you may need to physically dismantle it to clear the jam.
Re: Unusual stepper ratings - vref settings for new Melzi
March 15, 2014 01:31PM
Ok thanks. I've had the extruder apart many times but not examined down inside the hot end I must admit.

I've tried what you suggested and the filament is hard to push through. Strangely it seemed good at first, but then got more difficult. I had it up as hot as 230C (and this is PLA not ABS) and it was still needing a lot of pressure by hand to feed through.

I have a suspicion that it's poor quality PLA that could potentially be the issue here since it was very cheap stuff. When I bought it, I didn't realise there was a big variation in quality but have read a lot on this since.

I might ask my mate if he has some I can use so that I can try it with known good quality plastic.

Another thing is that I've swapped from ABS to PLA and I've no idea if there's a particular method you should do in order to do this. Could it be possible for instance that due to the lower print temperature with PLA that there's a bit of ABS still in there that is restricting the flow of the PLA? Basically to change them over I pushed the ABS through as best as I could, then pushed the blank end of a 3mm drill bit in to push it all through, then I inserted the PLA.

On another note, I wonder if there is any design for an extruder that uses double the gripping area of a normal Wades extruder? I have an idea about having one where an opposite main gear meshes with the existing one and of course turns the opposite way, driving a second hobbed bolt against a second bearing, but higher up. I wonder how easy this would be to make, and if it would help reduce slippage and stoppages etc....

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 15, 2014 02:09PM
By the way, this is how I attached the hot end after finding i couldnt bolt it like it previously was:

6mm ply then i chamfered the edges to squeeze it in place. As you can see in this pic, it sort of looks like plastic somehow is leaking around the hot end. Not sure where from though.

I also cut slices into the grooved feed bearing although in hindsight Im not sure there was any point since it's not driven!

This is the PLA I bought by the way - the grey stuff:

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 15, 2014 08:20PM
Yes that the upper picture seems like leaking? I see plastic coming from the upper part of the block down to the bottom part also covering the nozzle. As it comes from there its probably leaking through the upper thread. You may need to fix the leak if there is one. Could use some teflon plumbing tape thats made to seal threads on metal plumbing pipes. Also i read some posts back, i think you should try printing with lower speeds than 150, try with 70 and see if there is anything different just in case thats the cause. You can also extrude in air and see if the filament is uniform and extrudes nicely.

Also should find the reason why is hard to push, if the nozzle can be dismantled and left with the block alone, then could try pushing the plastic like that without nozzle but still heated up, and wait for the filament to dilate and see if the filament dilatation is to blame, or else if the nozzle is at fault. If the filament dilatation is to blame, you could check the exact diameter of your hole and say if it is 3.0mm could increase it to 3.2 with a drill, this is an idea. But by now if the inner diameter would of been 3.0 or less and heated up to 230c probably by now the cooled filament would of been already stuck, so probably its not that. Perhaps the nozzle was blocked, which would build pressure and get it leaking if thats the case. If the nozzle was not blocked by something, then perhaps its inner diameter is too small, make sure it is 0.4mm or bigger, and use lower speed settings in slicer program - halve all speeds related to extrusion.

The plastic quality probably does not have any impact, not like that at least. Must be something with extruder hardware issue, or slicing parameters being bit high, but probably both. Dunno what else, as thats all that is involved.

Edited 1 time(s). Last edit at 03/15/2014 08:25PM by NoobMan.
Re: Unusual stepper ratings - vref settings for new Melzi
March 15, 2014 08:55PM
Thanks for the suggestions.

I think I mentioned the leak earlier but possibly I just meant to and didn't actually write it. I haven't read back through it and I'm sligjhtly demoralised right now.

My friend (that I bought the part built printer from) brought his machine round tonight so I could compare settings, try out my PLA in his machine etc etc. The PLA I've got printed fine in his machine so that's not the problem.
Most of my settings are the same as mine too.

I mentioned the leak to him and he said to heat up the extruder then tighten the block with a 14mm spanner so I did that and it was a bit loose. So that was fixed.

Then I had an issue where the extruder was jumping suddenly to 354C reading, and then the steppers would not respond to manual control. I knew of course the reading was nonsense, and it quickly became apparent the insulation on the thermistor was a bit retracted and causing the wires to short. I presume the steppers refusing to work was some sort of safety thing when it thought it was too hot? It hasn't happened before so must be. Anyway I unsoldered it and put new heatshrink on it.

So we printed the same spool holder part on his machine with my filament and it came out perfectly.

i was about to test it with a few tweaked settings (speed set to 100mm/m, 12 extrude, 13 retract, 200 extruder/75 bed, 0.5 nozzle/0.4 layers), then the heater was a bit tight to fit back in the hot end block due to leaked plastic over it and inside the block.

So I cleaned up the heater element, and was about to clean the block when things went bad.
My mate suggested to remove the block (unscrew) it from the rest of the hot end, use the pocket blowtorch to heat the plastic in it and clean it easily. Not such a bad idea until I began undoing the block (unheated, and assured that it wouldn't break as they're really strong etc), then as I'd worried a bit about, the hot end sheared off.

My friend was very apologetic that he'd insisted I undo it without needing to heat it first despite me being a bit reluctant. He wanted to take his extruder off and give it to me but I couldn't accept that so I am out of the game for a week or so now while I find a low cost hot end and wait for it to arrive here.

So after all that, I've still got no idea why it wasn't extruding correctly. But I suppose I will at least have to buy a new hot end and maybe that will help. Who knows.

Bugger. sad smiley

Edited 1 time(s). Last edit at 03/15/2014 09:07PM by Mr Joshua.

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 16, 2014 03:58AM
Hi Mr Joshua,

I'm very sorry to read about your extruder. This 3D printing business can get very annoying sad smiley

Reading again carefully through all the posts, I believe I might have found some explanation for your misfortune...if that is of any relief...
This is one possible course of events:

1.-What if the wrong reading of the thermistor caused a very high temperature that...
2.- ...caused the PLA to actually overheat, burn and "carbonize", creating a ...
3.- ...jam in the tip of the nozzle?

It seems plausible to me, as it explains the leaking effect...

If that were the case, maybe by cleaning the inside of the nozzle with a little drill (in cold so you can sense the difference in material) you might get somewhere. I ignore where exactly your extruder got broken. I assume it happened in the very joint where the plastic insulator and the metal block meet, which is kind of catastrophic but only to some extent...smiling smiley

I would invite you to have a look at this:


It is a development of a DIY extruder, where they give clear instructions on how to build one with unsophisticated machinery.
The part you might be interested on is the actual insulator...

Of course, it is just a suggestion to bring you "back on the game"! smiling smiley

Alternatively, some reprap holidays can also help to "flush the bad energies"...

Edited 1 time(s). Last edit at 03/16/2014 04:00AM by ndujar.

Re: Unusual stepper ratings - vref settings for new Melzi
March 16, 2014 04:09AM
If you've got a 0.5mm or larger nozzle, a good thing to use when changing between ABS and PLA is Laywoo-D3 wood particle filament. I wouldn't try Laywoo-D3 in anything smaller than 0.5mm though - tends to clog.

It will run at both ABS and PLA temps, so you simply leave your extruder at the temp you were using, push the Laywoo-D3 through (to remove all your old plastic, then as soon as you get clean wood extrusion, change the temp to what you want to use and repeat the process with the new plastic you want to use.

Note: If you can, when changing you should probably back out most of your filament while slightly colder (eg: PLA reversed/pulled out at say 160 if you use 185, or ABS reversed/pulled out at say 190 if you use 225) to remove most of the existing filament, and hopefully not waste as much. You still run the Laywoo-D3 through at the normal temp.

FWIW: I tend to just remove the idler pressure from my extruder drive (so I can pull/push by hand), turn off the hot end, then watch the temp drop. Once it hits the target withdraw temp for that plastic, I just pull it out by hand. I can them just turn on the extruder again and feed through the Laywoo-D3. Rinse and repeat with the target plastic once you've got the Laywoo-D3 done and you're switched.
Re: Unusual stepper ratings - vref settings for new Melzi
March 16, 2014 07:26AM
Thanks guys - haven't fully read those 2 posts as I'm just doing something but will come back to them later on.

Here's a pic of the carnage though for now sad smiley

Prusa Mendel i2 - Melzi V2
Re: Unusual stepper ratings - vref settings for new Melzi
March 17, 2014 03:45AM
Sry for your hotend. As it leaked before, thats where it was leaking from, most probably through a fissure at that place.

Supposedly the nozzle was clogged or the filament was too hard to push and pressure builds inside melting area, that would be the most fragile point hence it fails at that location. I had exact same point of break some time ago, i concluded it was due to two things. One, i was tightening the thread too hard, and it puts pressure unto the upper part, which could of been sort of avoided if the thermal barrier would of started at an angle, a slope instead a 90 degree. To see that imagine that one would force the thread at room temperature, that would still predictably fail at exact same point. Also, the block had no support on itself, so when the filament is pushing hard into the melt zone, it basically tends to push the block away, which would make again a rupture at same spot because well, that is indeed the weakest point of failure.
Re: Unusual stepper ratings - vref settings for new Melzi
March 18, 2014 07:54PM
That all makes sense yeah. The honest truth though is that it just snapped because I tried to undo it without heating it first.
It was stupid because I could feel it was too tight, and I've snapped a lot of bolts over the years so I shouldn't have tried, but anyway.....

New one is en route, so I'm a bit annoyed as I thought it was coming from the UK and would be here in a few days, but it's coming from HK so will take a while I guess. sad smiley
In the meantime I can improve some other bits on it, so that hopefully once the new hot end is installed I should have functional prints quite quickly. Hopefully...

Prusa Mendel i2 - Melzi V2
Sorry, only registered users may post in this forum.

Click here to login