Welcome! Log In Create A New Profile


Melted laptop CPU after switching on heatbed

Posted by tobben 
Melted laptop CPU after switching on heatbed
July 21, 2014 03:16PM
Hi guys!

This weekend, I replaced the Melzi on my parents' Mendel. This is all I ever did to the new Melzi:

  1. Wired up
  2. Adjusted trim pots
  3. Uploaded RepRappro Marlin
  4. Connected with Pronterface

Motors and hotend worked fine, but when I switched the heatbed on, I got a disconnect. I rebooted my laptop (because of software updates) and hooked the USB cable back in. That's when the CPU melted. Quite fast.

I understand that a fuse in the USB port should have saved the CPU, but I don't know why I got this large current (> 0.5 A) from the Melzi when switching on the heatbed. The only thing I have found on the subject is this: [forums.reprap.org] and this: [reprappro.com] On Friday, I will step through the little RepRappro guide.

EDIT 1: Also found budjar and nopheads conversation hidden in this thread: [forums.reprap.org] suggesting that a bad ground connection could be the error source. I actually double checked that resistance to PSU ground was ok before commisioning, but I have no firm definition of 'good enough', I just measured a < 2 ohm resistance. Could bad ground still be the cause?

Do you have suggestions on where I should point my multimeter? Has the same happened to you, or have you heard about incidents like this before? I feel like I have to understand this incident before I can continue my RepRap adventures :-|

Edited 4 time(s). Last edit at 07/21/2014 03:30PM by tobben.

Re: Melted laptop CPU after switching on heatbed
July 22, 2014 05:16PM
Compare the voltage between the ground on the PSU and the ground on your laptop, without the Melzi connected to the laptop.

If there's a significant difference, that could be your issue.

I would suggest using a high-voltage AC scale first, then working downwards, then try DC. I would also recommend NOT touching the ground of both devices with anything but the probes till you're sure there isn't something weird.

eg: If somehow the PSU has live AC on what should be the ground and the laptop is grounded (or vice versa), current will flow through YOU if you touch both. Even if you wired it correctly, do not underestimate that the laptop may be incorrect or that a moulded plug, a power board, or even a household wall socket could be wired incorrectly, leading to situations where Ground/AC are reversed.
Re: Melted laptop CPU after switching on heatbed
July 26, 2014 05:47AM
Thanks for the answer! I measured voltage between the housing of a usb-cable plugged into my new laptop and the PSU-ground. It was a 275 mV DC difference. I think this should be ok? I'm not able to make the measurmement with my old laptop's USB-port, and there might have been a grounding error there...

The computer and the PSU were plugged into the same double contact with ground connectors. The wall plug that the double contact used was ungrounded.

Best regards

Re: Melted laptop CPU after switching on heatbed
July 26, 2014 08:00AM
My printer now runs again! This is quite embarrassing.

Here's what I did: Scrapped the old USB-cable got a new one. Switched power jumper to USB. Got connection in Pronterface, led flashed happily. Noticed that ground cable in 12 V supply socket was actually a bit loose/moveable. Remounted it firmly. Switchet power jumper to PSU. Printer worked perfectly.

Lession learned: Pay attention to mounting of power cables from PSU onto the Melzi!

I already knew bad power connection is a usual cause for this dramatic incidents, I don't understand how I could miss this myself for so long... Hope this is my last stupid mistake. Haha.

You were right, Cefiar. Ground difference between board and USB was really the problem. Thanks again! smiling smiley

Best regards
smileys with beer

Re: Melted laptop CPU after switching on heatbed
July 26, 2014 11:22PM
No problem Tobben. Glad to help.

FWIW: The only embarrassing mistakes are where you fail to learn from them and repeat them again. winking smiley
Sorry, only registered users may post in this forum.

Click here to login