Weird problems with Techzone electronics
May 16, 2010 05:59PM
Hi, I'm attempting a reprap build for the first time and I ordered Techzone's electronics. They don't seem to be behaving properly and I'm not sure if its something I'm doing wrong or if they're broken, and was wondering if anyone could help me out.

I've connected the motherboard to USB and ran the reprap host software. The first strange thing is that it appears to only get intelligible responses when the baud rate is set to 38400 (everything I've read says to expect 19200). Next I turned on comm's debug, and I get this:
comms: G-code: T0 dequeued and sent [0.000s/-1274046077026ms]
comms: GCodeWriter.waitForOK() dud response: R3G Master v106 [0.001s/1ms]
comms: GCodeWriter.waitForOK() dud response: Host timeout [1.005s/1004ms]

This is confirmed if I connect to the USB device with minicom or similar and start typing in commands. Everything I do after the first boot of the board responds with a couple control characters, then "Host timeout".

I thought that maybe it was an incorrect firmware installed, so I tried installing the FiveD_GCode_Interpreter from the reprap-mendel bundle. I attached a jumper to the only two pin connector on the board and used Arduino to install the firmware with Sanguino selected, and it gives me this:
avrdude: stk500_getsync(): not in sync: resp=0x48
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x48

I'm at the limit of my debugging skills here (I'm a software engineer with limited electronics experience). Does anyone have any ideas? Did Techzone give me a dud board?

Re: Weird problems with Techzone electronics
June 03, 2010 09:14PM
The errors you posted at the end are most commonly caused by using an off-the-shelf USB-serial cable which doesn't auto-reset nicely. I believe the fix is to press the reset button as soon as the Arduino software shows the "Binary sketch size" message. I have also seen this error when the incorrect serial port is selected in the tools menu, the serial port is in use by another program like minicom or the serial cable isn't connected.

Darwin clone, Gen 2 electronics, Arduino Duemilanove w/ AtMega328, 5D Firmware, Pinchwheel extruder
Re: Weird problems with Techzone electronics
June 04, 2010 09:41PM
make sure you have the cable hooked up properly, we had ours reversed and were getting odd messages. I don't know if they're burning the bootloaders or not, maybe someone else can give some insight onto that. We burned another bootloader on ours cause we assumed it wasn't on there, while in fact we just had the cable on upside-down. If the power light is kinda dim, it's prolly in backwards.
Re: Weird problems with Techzone electronics
June 04, 2010 10:20PM
Thanks for the help everyone, but Mdbaughman2 already helped me with this. It turned out to be a combination of a flaky cable between the motherboard and the usb adapter, and me not understanding the differences between the reprap firmware and the makerbot firmware. I got around the cable by using six jumpers as a makeshift connection. I'd previously posted this to this thread but somehow my post disappeared. No idea what happened. Thanks for the help regardless.
Re: Weird problems with Techzone electronics
June 05, 2010 08:46PM
I have found that the best fix for the cable problem is to solder the wires to the punch-down connectors... I just had to redo my serial cable...
Re: Weird problems with Techzone electronics
January 07, 2012 03:19PM

I believe the fix is to press the reset button as soon as the Arduino software shows the "Binary sketch size" message

WOW thanks, Worked for me. Thanks Mccoyn

edit: I realize this is a 2 year old post but I thought I should let anyone else who had this problem know.

Edited 1 time(s). Last edit at 01/07/2012 03:20PM by Atomhax.
Sorry, only registered users may post in this forum.

Click here to login