Welcome! Log In Create A New Profile


Thermocouples vs. RAMPS

Posted by sderose 
Thermocouples vs. RAMPS
December 08, 2015 05:21PM
I'm having trouble reading thermocouples on a MendelMax 2-like printer I'm building. In short, they're reading about 20-30C too high when at room temperature, and the readings jump around a lot.

I bought a dual-head Mk9+ extruder (http://www.makergeeks.com/duexretopr.html), with Type K thermocouples (page says thermistors but they're not). They're wired to Ultimaker tc1 thermocouple amp boards (http://wiki.ultimaker.com/Thermocouple_Sensor_Board_v1), which use an AD597 (http://www.analog.com/media/en/technical-documentation/data-sheets/AD596_597.pdf) to feed 10mV per degree C to analog input pin in AUX-1 on a RAMPS 1.4 shield on an Arduino Mega2560. No extra/extension wires between. I see the same symptoms whether the Arduino is running Marlin firmware or my own code.

When everything is at room temperature, the hot bed (separately monitored via a thermistor) reads 17C (the basement is a little cool). But the thermocouples read in the 35-55C range.

More troubling is that the readings bounce around a lot: +/- about 10 degrees. With heat, the reading rises and when it gets to the target 190C the printer can extrude, but it's still bouncing around so much that soon the printer shuts down, thinking it's over- or under-heated.

If I completely disconnect the thermocouple from the AD597 board (and replace it with a copper wire), remove the board from its mounting, and replace the wires to it, then I still get the bouncing. If anything it's even wider, as in (at 5-seconds intervals):

72.3 31.6 107.2 22.8 52.0;
36.0 38.8 -5.4 55.4 39.3;
40.8 32.5 25.2 98.1 70.8;
103.3 108.2 92.2 21.3 127.4

BUT if I directly measure the voltage between the ground and signal pins on the AD597 board, then I get a rock-steady 0.495V +/- 0.001.

Both AD597 boards act the same. I tried 3 different sets of wires. And I resoldered the connectors on one of the AD597 boards. This suggests a problem at the RAMPS board or higher.

BUT, I then removed the AD597 board entirely, and connected a pot to the same +/-/signal pins on the RAMPS. Wherever I set the pot, it reads a pretty steady (pseudo-) temperature, as in these 4 sets of readings:

20.3 21.3 22.8 23.7 18.4;
35.5 35.5 36.9 35.5 36.9;
-5.4 -5.4 -5.4 -5.4 -5.4;
39.3 41.8 40.8 40.8 41.3

That seems to rule out problems at the RAMPS end. And that doesn't leave much (esp. since I tried 3 different sets of wires).

Does anyone have ideas on what could be wrong or what I could try next?

Many thanks!
Re: Thermocouples vs. RAMPS
December 08, 2015 05:50PM
I spent a lot of time trying to get thermocouples to work as my bed temperature probe on my Delta.

I (practically) never succeeded. When the printer was off it was all fine but as soon as I started the printer it did as you describe. Jumped around entirely erratic. I actually spent a lot of time making hardware filters and eventually I connected an Arduino to run some more exotic filtering on the signal. That did the trick and I could run with it. But it is obviously a silly solution.

It was the cross-chatter from all the other electrical components, especially the motors (which are also under the heat-bed on a Delta)

My experience to this day - Stay away from thermocouples if you are running RAMPS, go with thermistors.. Other people do run with thermocouples (it seems, few 100% confirmed cases of it working) so it can maybe be done.

PS. I also used the AD597 chip. Never tried the MAX chip that I only got my hands on later.
Sorry, only registered users may post in this forum.

Click here to login