Welcome! Log In Create A New Profile


Max endstop issue

Posted by reece.arnott 
Max endstop issue
November 22, 2007 01:28AM
I have all my opto-endstops working... except for one!

The max endstop on my z controller board (v1.2.1) is not working i.e. it never stops the motors. If the opto-endstop is replaced by a known good one it still doesn't work. Even when you just insert and take off the jumper it still doesn't work.

The min works just fine. I was thinking of swapping the chips around to see if its an issue with the z chip firmware but thought it was more likely I would cause more issues with bent pins getting the chips in and out. So I thought I'd try reviewing the electronics in situ first.

Of course I have no idea where to start so I thought I'd cry for help...


What should I be looking for? As I've had a few issues with getting the chips properly inserted in the first place could this be an issue with a bent pin on the chip and if so, which pin?
Re: Max endstop issue
November 22, 2007 02:52AM
Hi Reece,

... first, measure the voltage at all the pins of a 'good' endstop and then at the Z-max - this should eliminate simple supply-malfunctions ...

Then try to activate the opto-switch with a thin black sheet of cartonage or plastic (paper eventually didn't work), to see, if it basically works ...

And then go through the wires, to check if there's a shortcut or break anywere ...

Last step would be debugging the software ...

Re: Max endstop issue
November 23, 2007 12:22AM
Fixed it.

As I suspected it was a bent pin on one of the corners of the chip. I just took the chip out, carefully unbent it and carefully reseated the chip. I probably should have taking note of which pin it was but I didn't and now I can't tell. Oh, well.
Sorry, only registered users may post in this forum.

Click here to login