Welcome! Log In Create A New Profile


Rumba ABL servo issues

Posted by Felice 
Rumba ABL servo issues
November 04, 2016 01:02AM
Hi there,
I have Marlin 1.1.0-RC6 and a Rumba board.
I am trying to implement the ABL but the servo does not move.
I have connected the servo (SG90) on exp.3 pins:
2 (+5V)
4 (-)
and then I tested the servo on both pin 6 and 5 for the PWM

In Marlin I have activated the auto bed leveling options and the R/C servo support, in fact if I send a G29 the printer moves and does the mapping of the bed on 4 points. I have manually pressed the Z end stop to cause the routine to complete and return the mapping in Pronerface. I have also tested the same with RCBugFix downloaded a couple of days ago but same results.

I have tried to send the command manually to move the servo M280 P0 S90, I tried the same command on P1 and P2 on both pins 4 and 5, but nothing....I cannot move the servo. I have checked the servo functionality before and after the test on rumba with an Arduino board and the servo is functional.

I checked in pins_RUMBA.h and the servo 0 is assigned as #define SERVO0_PIN 5
I have checked the voltage on pins 2-4 of Exp. 3 and the voltage (5V) is there.
I have opened an issue on Marlin GitHub but even there I am not coming right.

Please help.
open | download - Configuration.pdf (133.3 KB)
open | download - pins_RUMBA.pdf (25.9 KB)
open | download - EXP.3 Rumba.png (40.8 KB)
open | download - Rumba.jpg (119.3 KB)
Re: Rumba ABL servo issues
November 05, 2016 05:45AM
I solved the issue. It was a wiring mistake.

I posted my own answer here:


Edited 1 time(s). Last edit at 11/05/2016 05:46AM by Felice.
Sorry, only registered users may post in this forum.

Click here to login