Welcome! Log In Create A New Profile


Converting a Prusa i3 3D printer to a laser

Posted by rfresh737 
Converting a Prusa i3 3D printer to a laser
April 29, 2017 11:17PM
I'm converting my Prusa i3 3D Printer over to a laser machine because I want to try out the Z axis stepper motors to allow cutting of thicker woods.

I've got the two Z stepper motors working using a spare EleksMaker L6 controller board, running Grbl 1.1e.

I'm running both Z steppers from one Z axis port on the controller board (see attachment). I have the wires soldered such that the one Z port is driving both Z steppers.

The steppers for the X and Y axis work fine as they are belt driven. The two Z axis steppers turn long screws, vertically, which sends a gantry up or down.

I send a g-code Z distance of 50mm but the Z motors turn enough to maybe move the Z axis up 5mm or so. I've tried a lot of different Grbl $102= values, but after I set it, it works for the first time only. After the first time, the Z axis only moves about 10% of what distance was commanded. I don't understand what is causing that behavior. I'm also not sure what Grbl adjustments I need to make to get the two Z steppers to move the distance commanded by the g-code.

So if I set $102=160 and try to jog 10mm, it will jog 10mm the first time after setting =160. If I jog again, it jogs maybe 1mm. If I set $102=80 and try to jog 10mm, it will jog 10mm that first time after the setting. If I jog again, it jogs maybe 1mm.

The motors and frame are from FolgerTech and it is the prusa i3 clear acrylic frame.

Any help appreciated. Thank you.
open | download - 3D L6 small.png (289.8 KB)
open | download - 3D Work Bench small.png (478.8 KB)
Re: Converting a Prusa i3 3D printer to a laser
May 01, 2017 02:46AM
My best guess is, you are using slow speed at first, so the z-axis is able to follow.
But later, when the much faster X- or Y- axis was moved, grbl tries to move z-axis with much higher speed, causing the stepper to skip steps.

Did you try to change max. speed settings?
snip from grbl-wiki

$110, $111 and $112 – [X,Y,Z] Max rate, mm/min

This sets the maximum rate each axis can move. Whenever Grbl plans a move, it checks whether or not the move causes any one of these individual axes to exceed their max rate. If so, it'll slow down the motion to ensure none of the axes exceed their max rate limits. This means that each axis has its own independent speed, which is extremely useful for limiting the typically slower Z-axis.

The simplest way to determine these values is to test each axis one at a time by slowly increasing max rate settings and moving it. For example, to test the X-axis, send Grbl something like G0 X50 with enough travel distance so that the axis accelerates to its max speed. You'll know you've hit the max rate threshold when your steppers stall. It'll make a bit of noise, but shouldn't hurt your motors. Enter a setting a 10-20% below this value, so you can account for wear, friction, and the mass of your workpiece/tool. Then, repeat for your other axes.

NOTE: This max rate setting also sets the G0 seek rates.

Edited 1 time(s). Last edit at 05/01/2017 02:54AM by o_lampe.
Re: Converting a Prusa i3 3D printer to a laser
May 01, 2017 11:00AM
I was trying to move the Z axis at 2000 mm/min and it could not handle that speed. A speed of 100 to 150 worked fine.

Thank you for the help...!!!
Sorry, only registered users may post in this forum.

Click here to login