Welcome! Log In Create A New Profile


Extruder controller and stepper, low torque

Posted by j_andberg 
Extruder controller and stepper, low torque
March 16, 2011 02:41AM

I have been lurking here about one year. I have my Mendel finished, but I am having extruder troubles,
and need advice. I have searched the archives, but have not found the same problem (I think).

The pertinent facts:
1. My extruder is a Wades, stepper driven, controller v2.2.
2. I have the motherboard and extruder controller grounds tied together (did not help).
3. I do not have the 180 ohm resistor at the RS485 input (was not on my purchased boards).
4. I do not have the jumper just at the left of the crystal on the extruder controller (only one
post mentioned it). It is not on the board mod page, either.
5. I think I have the color code for the steppers correct, but I could not find it in the
documentation (except for a color picture).
6. I did not find anything in the configuration.h to set it up for a stepper, so compiled it as is.

My problem is that my extruder is too weak to extrude reliably, even at 270C with ABS. If I have the
current control pot set way down, it does not turn. If I set the pot up to 1/4 to 1/3 of a turn,
then the chips will overheat (but the stepper works, mostly). The symptom is that when one set of
LED by the driver stays lit (when the stepper is stopped, like when it is heating up) that driver
quickly gets so hot (100C+) that I have to hit reset or pull the plug to prevent a failure.
Gradually reducing the pot setting again makes it too weak and it stalls more than turns. Note that
I can fairly easily turn the gears by hand and extrude.
Any ideas will be greatly appreciated.

many thanks,

Re: Extruder controller and stepper, low torque
March 16, 2011 09:03AM
You're using the h-bridges on the extruder controller to drive your extruder stepper? That was always a nasy hack. Worked fine for some people, not so well for others. The only advantage is that you didn't have to buy additional hardware, the stuff you already had (designed to control a DC motor) would work. It will never work as well has a genuine current-chopping stepper controller, like the pololu or even the gen3 stepper controllers. You'll always have less torque, more heat, less speed, and less reliable operation. In particular, when the stepper is stopped the current (and heat) quickly goes to max and stays there. So you have to limit the voltage (via PWM) which limits the current rise time, which limits the max speed and limits the time at max current, thus limiting the max torque as well.

So your solution is probably to get a real stepper controller, and hook that up to the mainboard instead of hooking the step/dir signals to the extruder controller..

Having said all that however, have you metered your stepper motor to make sure your coils are where you think they are? With the h-bridges, that can cause problems too.

Which firmware are you using?

I'm building it with Baling Wire
Re: Extruder controller and stepper, low torque
March 16, 2011 05:43PM

I am using the host firmware, with all settings as in the distribution. Is there a link to a schematic that shows the motor coils and the terminals 1A,2A,1B,2B, so I can check it?


Re: Extruder controller and stepper, low torque
March 28, 2011 06:22PM
Problem solved..... Pilot error.....

1.) I created a gcode file from the host software several months ago. (It had the default PLA temperatures.)
2.) I ran the host software to test the extruder at the dump point. It worked, but the force was pretty weak (at 260C with ABS).
3.) I ran the code created in 1. to print something, and my stepper did not turn with enough force to move.

Duh..... I did not realize the extruder temperature was in the gcode, as well as in the host. The file I was trying to run was setting the temp to 190, letting it stabilizing and then running. The result was no turning.

Actually, I finally got my Pololu driver order, so I made it up on stripboard and am using it now. Much better, as suggested. One question I have is that the extruder stripboard wiki says:

"In motherboard firmware's configuration.h change E0_STEPS_PER_MM to 32 for 1/16 microstepping. "

If I really calculate the proper number for a Wade's extruder, it is much less than this. Does anyone have insight into the correct value?


Sorry, only registered users may post in this forum.

Click here to login