Welcome! Log In Create A New Profile

Advanced

Reprap firmware Radds servo/bltouch does not deploy

Posted by mrwizzard 
Reprap firmware Radds servo/bltouch does not deploy
November 20, 2017 04:37PM
So i have a bltouch on PWM3 on the due/Radds, it was previously on PWM1 on repetier. it worked fine there. I did the usual config and disabled H3 via M307, set probe type to 4. However running the M228 P3 S10 I1 (or any variant) fails to deploy or do anything when sending gcode manually. unless it's a PWM3 issue at hardware level, is there any possibility of mis-configuration here?

Commands use to set it up ( i know there is more to getting the probe working as a probe but i cannot get it to deploy so that's step one for now):

M307 H3 A-1 C-1 D-1
M558 P4 X0 Y0 Z1 H3 F120 T5000 ; Set Z probe type to switch, the axes for which it is used and the probe + travel speeds

Ideas? do i need to pin map something? anyway to test on PWM1?

Edited 1 time(s). Last edit at 11/20/2017 04:37PM by mrwizzard.
Re: Reprap firmware Radds servo/bltouch does not deploy
November 20, 2017 06:13PM
What is PWM1 on the RADDS normally used to control?


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet.
Re: Reprap firmware Radds servo/bltouch does not deploy
November 21, 2017 03:31AM
Did you know, you have to feed external 5V to the "servo connector" block on RADDS? There's a label for 5Vin...
Without that, the servo will not work.


Re: Reprap firmware Radds servo/bltouch does not deploy
November 21, 2017 01:59PM
Quote
dc42
What is PWM1 on the RADDS normally used to control?

Not sure (i don't think the schematic is open source), but i had it on PWM1 with repetier, single extruder and PWM hotend fan and PWM cooling fan so it's not connected to those at least.

PWM1 is on P5 (PC25 and PWM2 on P6 (PC24). I just set it in repetier config under servos.

is there a way to switch it to PWM1? or do i have to mod the firmware and re-compile?


Quote
o_lampe
Did you know, you have to feed external 5V to the "servo connector" block on RADDS? There's a label for 5Vin...
Without that, the servo will not work.

Yes, of course. i just went from repetier to reprap firmware and PWM1 to PWM3. it doesn't work on PWM3 or it's something firmware related maybe. it has continuity from the pin to the probe so nothing broken at least. i guess i'll have to check the pin on the due if it has a signal at all and check the radds board if it's not a config issue.

Edited 2 time(s). Last edit at 11/21/2017 02:01PM by mrwizzard.
Re: Reprap firmware Radds servo/bltouch does not deploy
November 21, 2017 04:14PM
I've checked the pin mapping. Arduino Due pin 5 is P60 in the M42 and M280 commands, and pin 6 is P61.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet.
Re: Reprap firmware Radds servo/bltouch does not deploy
November 21, 2017 07:42PM
Quote
dc42
I've checked the pin mapping. Arduino Due pin 5 is P60 in the M42 and M280 commands, and pin 6 is P61.


Thanks, that works smiling smiley i guess my pwm 3 don't work.
Re: Reprap firmware Radds servo/bltouch does not deploy
November 22, 2017 02:35AM
If it helps for later reference, there is an (old?) schematic on the site of the RADDS developer.

Edited 1 time(s). Last edit at 11/22/2017 02:36AM by o_lampe.
Attachments:
open | download - RADDS_26_sch.pdf (54.2 KB)
Re: Reprap firmware Radds servo/bltouch does not deploy
November 26, 2017 02:02PM
ok, while i got the thing to deploy, there is conflicting or lacking information on how to get the thing to trigger.... what am i plugging this into? all i see is E0 End stop, which is actually PWM 3 apparently but then instructions say use PW3 to deploy it. in any other firmware, marlin/repetier this is plugged into Z-Min.

So what's it plugging into? Z-Min? Or PWM3 or analog pin 5 (probe type 5?)..... all i get is already triggered errors that lock up the controller that needs a reset or it never triggers at all.
Re: Reprap firmware Radds servo/bltouch does not deploy
November 26, 2017 02:55PM
I didn't do the RADDS port, but according to [github.com] the E0 endstop pin is digital pin 39.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet.
Re: Reprap firmware Radds servo/bltouch does not deploy
November 26, 2017 05:46PM
I saw, it just wasn't labeled E0 but PWM3 which is weird. oh well, i'll give that a shot smiling smiley Thanks.
Re: Reprap firmware Radds servo/bltouch does not deploy
May 04, 2018 09:44PM
I have been trying to find more info on the servo block on the Radds? What did you determine was the best way to do this? Here is a link to a thread I started with my information: [forums.reprap.org] Any advice, diagrams, specific information on this topic would be much appreciated. Thanks in advance!
Re: Reprap firmware Radds servo/bltouch does not deploy
May 05, 2018 04:03AM
Using RepRap Firmware or Repetier for Radds are two different things. You have to specify, which FW you choose. The support for RRF on Radds is "limited" to say the least...
Re: Reprap firmware Radds servo/bltouch does not deploy
May 05, 2018 08:06AM
I'm using Repetier firmware. But even before firmware, I'm searching for how to physically connect the servo block on the Radds to power the bltouch? Is it controlled in firmware? As I said in the embedded link above, "I'm not a total newbie, but not well versed in electronics." Thanks for any help.
Sorry, only registered users may post in this forum.

Click here to login