Welcome! Log In Create A New Profile

Advanced

Unstable temp reading [MKS GenL]

Posted by Moff_Tigriss 
Unstable temp reading [MKS GenL]
March 07, 2018 10:46AM
Hi !

I have an issue with my new MKS Gen L with Marlin 1.1-bugfix, the temp reading is not stable, oscillating between 18-27°c with a room temp of 20.

Facts :
- Nothing connected to the board, no drivers.
- It's the same with nothing connected to the probe pins, or a fixed resistor. All three probe pins does the same (I don't have what to make my own pull up resistor to test with another analog pin).
- The PSU is good and stable (and also checked with a MKS Base).
- If the main 12V is cut, but the board is powered via USB, the temp reading is stable.
- A stable Marlin does nothing.

I tested a lot of point on the circuit, and i can't find anything providing an unstable voltage :
- After fuses
- Before and after the power converter (MP1584EN)
- On the AREF (98) pin of the Atmega2560
- As far i can go on the AREF trace (finish under the ICSP pins, so i think the VCC pin is connected to it).
- On the diverse power pins available
- After the pull-up circuit of the probe header

Bonus :
- Nearly impossible to connect the board via USB, and i need to do a manual reset when flashing the board. And i have troubles with Octopi (maybe a too long USB cable, wich worked with the MKS Base, i didn't tested more after seeing the unstable temps).
- I have seen the same issue on some forums, for the MKS boards, but answers are never useful, or the problem is not clearly identified. And there is an occurrence of one RAMPS doing the same.

So, there is very little room for something going bad here, so i'm looking for some help and ideas smiling smiley Note, i don't have an oscilloscope, so i'm limited for measures.

I know, that board is cheap and closed source (and i hate it too, but it's still the best 8bit alternative with plugable drivers), but, heh, troubleshooting is good !

Thanks !
Re: Unstable temp reading [MKS GenL]
March 07, 2018 12:42PM
Did an ultimate test : remove Marlin, and use the sketch example AnalogReadSerial.

Power only via USB, measure is very stable.
Power only via PSU, measure really unstable.
Power both, measure really unstable.

Using a real good 12V PSU change nothing. Main power is grounded.
There is a thing, the power converter output is 4.40 when powered by 12V, but 4.90 when powered by USB only. So maybe the chip is not in good health, or something even before, maybe a capacitor ?

Now, i really did everything i can with my limited tools.
Re: Unstable temp reading [MKS GenL]
March 07, 2018 12:43PM
I have the same board and I don't have this same issue. Since it's an all-in-one, you either have a problem with your power supply (not particularly likely), or bad voltage regulation on the board's power input. Hard to troubleshoot without a schematic. I'm at work right now too and I can't just go look at the pcb itself atm. Since it is stable with only USB providing the 5V I'm guessing you have a regulation issue on the PSU input side. I'll take a look at my board when I get home later today to see if I can give you a few ideas on where to look.
Re: Unstable temp reading [MKS GenL]
March 07, 2018 09:41PM
Yep, it was the power converter ! The implementation of the MP1584EN is straight from the datasheet, so it's relatively easy to figure out what is what.

I desoldered the pin 1 of the MP1584EN, and connected an external 5V after (or before*) the inductor. The board work fine now, even if it's a really ugly fix, and i can't connect to the USB with the external power ON (garbled communication).
But the SD card work fine, so the fix will do the job until a new board come (13$... finding a regulator here will cost me the half of that, so... grinning smiley).

* It's connected to the ICSP connector side. 5v applied to the other pin of the inductor do the same as before, maybe because other pins of the MP1584EN are still connected.

Edited 1 time(s). Last edit at 03/07/2018 09:44PM by Moff_Tigriss.
Re: Unstable temp reading [MKS GenL]
March 08, 2018 12:01PM
glad to hear you were able to find a temporary workaround.
Re: Unstable temp reading [MKS GenL]
January 05, 2019 05:50AM
Hi ,

i had the same problem and was able to find the cause.
my board was brand new and the temperature readings where really unstable too.
at my board it was a bad cap
the 22uF near the MP1584EN
i replaced it with a really low ESR one and that fixed the problems

greetings
Samuel
Re: Unstable temp reading [MKS GenL]
February 18, 2019 08:34AM
I have a similar issue but I'm not sure if it's the same I switched from the Creality board to the MKS genL, and my thermistor readings are all over the place.

In the photo the smooth part of the graph is connected to the creality melzi, I swapped the thermistors, power supply, and usb cable to octoprint. The jagged part is connected to the MKS genL
I looked at the reference voltage with my mini dso on both boards and It didn't really look different.

I thought maybe it was firmware related, I flashed my creality board with the newer creality firmware version and it wasn't as smooth, but wasn't like this.

I ordered a new mks genL just to see if it was the board.
Update: I received the new board tried it, its doing the same thing.
Any thoughts?

Edited 1 time(s). Last edit at 02/18/2019 01:32PM by agrub918.
Attachments:
open | download - IMG_temperature.jpg (95 KB)
Re: Unstable temp reading [MKS GenL]
March 04, 2019 02:40AM
I had the same issue and it appears that a workaround is to connect a LowESR 1000uF/16V capacitor on 5V line.
I used exposed pins on the board with some dupont connectors with shortest possible capacitors leads soldered to the connector.

Maybe @primsam is right that the capacitors near the LDO are not so good and this rises the issue. If I have time I can try to change it.
Re: Unstable temp reading [MKS GenL]
March 06, 2019 09:29PM
@surenz thanks for this post, I was racking my brains unable to get stable temps at anything higher than 240. Fitted a couple of 1000uF/10V low ESR caps. One on aux 1 pins and 1 on servo pins and low and behold steady at 280.

@agrub918 maybe give that a try. Your graphs look very similar to how mine did before adding caps.

Now just have to figure out how to stop the nylon warping like a banana.

I was also wondering if there's an optimum position to place the cap/s or if it doesn't make a difference?

Edited 2 time(s). Last edit at 03/06/2019 09:33PM by ecob81.
Re: Unstable temp reading [MKS GenL]
March 21, 2019 01:47AM
I believe I'm having the same issue. Just installed MKS Gen L after stock Ender 3 board died. Everything is working, but the hot end temp is never stable. It constantly fluctuates about 5c. I've read your discussion and solution, but I'm new to a lot of this and learning as I go. Could someone please provide a pic with the capacitors added to the board?
Re: Unstable temp reading [MKS GenL]
March 27, 2019 05:49AM
Sorry for late reply but I've used those pins (in the red rectangle) to connect the capacitors. Caution with polarity.

I think that the output capacitor used for MP1584 implementation in the MKS Gen L is lower than the recommended in the datasheet.
At least the SMD capacitors used in the buck converters I have are a lot bigger than anything on the MKS Gen L and I see only one 22uF/35V which is IMO the entry capacitor.
Attachments:
open | download - Screenshot_1.png (673.4 KB)
Sorry, only registered users may post in this forum.

Click here to login