Welcome! Log In Create A New Profile


Double V ref from stepper drivers

Posted by Shreks donkey 
Double V ref from stepper drivers
February 05, 2019 05:59PM
I've just replaced an MKS Gen L V1 board and I had problems with the steppers as soon as I powered it on. It had jerky movement on the X axis and then it failed to home and halted. The Z axis didn't even move.

I thought I'd check the V Ref on the stepper drivers (generic A4988 modules) and the V Ref is roughly double what it was when the modules were in the old board. They were running at 0.89v for the X and Z and 1.1v on the Y, on the new board they are running at about 1.8v and 2.2v respectively. I switched the old board back in and they were running the same voltage as they were originally. With the new board back in the voltages are up again. It turns out that one of my driver modules has now failed as well.

This is a dual voltage board which can be run at 12 or 24 volts (I'm running it at 24v), but neither board has any jumpers fitted to select the operating voltage. I don't even know if it needs a jumper to select the voltage, there is a vacant socket on the board labeled 12 / 24v but it doesn't look like a typical jumper header it looks like a socket for a 2 pin cable.

I reflashed the firmware with the original firmware and it's still the same. I originally had it setup with Marlin 2.0 bugfix and it had the board was listed as a MKS Gen L but the original firmware (Marlin 1.1.x) had the board listed as an MKS_BASE (which is a bit confusing, it didn't have the MKS Gen L in the boards list) .

I have some tmc 2208's for the X,Yand Z and a lv 8729 for the extruder but I'm not keen on putting more driver modules into it until I understand what's going on. I also ordered another set of A4988's to use for testing and backups etc but they won't be here until next week.

Is this operator error or could the board have a faulty voltage regulation circuit for the stepper drivers?
Re: Double V ref from stepper drivers
February 11, 2019 10:38PM
Just an update if anyone was interested.

I looked around quite a bit for info about this with no luck, so it seems like it's an unusual problem. It ended with a dead A4988 driver module (I'm guessing from the abnormally high voltage) and it didn't want to waste any more time with the MKS board so I just threw a new board at it and now all is well.I can only assume the other board had a faulty voltage regulator.

I've had the new board running with A4988's, TCM 2208's and a LV 8729 (not all at the same time) and they all work fine.
Re: Double V ref from stepper drivers
February 12, 2019 09:18AM
I would watch this video

Computer Programmer / Electronics Technician
Re: Double V ref from stepper drivers
February 12, 2019 05:02PM
That video was the inspiration for the TCM's and the LV driver modules. I have it running that configuration now, it's running quieter and giving me a better finish on my prints. I was thinking of setting them up in UART mode but I need to do a bit more homework before I plunge into that. There's a good series on the different modes they run on youtube.
Re: Double V ref from stepper drivers
March 15, 2020 03:48PM
Hey, just an info for anyone that comes to this topic - switched from MKS GEN L V1.0 to SKR V1.3 and had exactly the opposite problem - my Z that runs on A4988 driver wouldn't go up, only vibrated.
Checked the voltage on the potentiometer and it was about half of what I've had set on the MKS... The same driver I only swapped went from aprox. 0,6V (MKS gen L) to aprox. 0,3V (SKR V1.3) Same for both extruders I run on A4988 drivers too.
Both boards powered using 12V psu.
Seems like the MKS somehow doubles the voltage/current that goes to the drivers.
Sorry, only registered users may post in this forum.

Click here to login