Welcome! Log In Create A New Profile


MAXTEMP BED...please reset.

Posted by DanL 
MAXTEMP BED...please reset.
April 04, 2019 10:26AM
When I print directly from the LCD, all temperature indications and control work and printing is normal. But as soon as I connect my laptop thru USB, the LCD flashes "MAXTEMP BED Printer halted Please reset".
I am using Marlin and Simplify3D. This problem just popped up when I tried to reflash Marlin with some speed and acceleration changes.
Again, everything on the printer works perfectly until I attach the laptop.
How do you reset? The LCD screen is frozen, the control knob and reset button do nothing. The reset button on the MKS board and powering off/on do nothing. The message occurs only when I attach the laptop, and, using Simplify 3D to to enter G-code, I get the error message there also, but can enter no code.
I have searched but get no results for this particular laptop-only problem.
Re: MAXTEMP BED...please reset.
April 04, 2019 10:52AM
I would suspect this is usb power related.

Do you have access to a dumb 5v only usb power bank?

Plug the controller into a powerbank, does it still lockup?
Re: MAXTEMP BED...please reset.
April 04, 2019 11:50AM
Great idea, Dust.
Just tried a USB charger. The LCD comes up clean...no errors and ready to go. So the problem is in my laptop...????
After the USB charger power-up, i tried hooking up my laptop via USB again and no error message! The laptop was on battery only.
Then I disconnected the USB and plugged in the 'puter to its PS. Hooked up the USB to the printer and: ERROR message.
Disconnected everything again. Hooked up USB computer to printer with computer on battery power only: no error message....all good. Then plugged in computer PS and immediately: ERROR Maxtemp Bed.
What the heck.
Somehow, the use of the laptop power supply triggers the Maxtemp error message and locks up the LCD inputs and even the MKS reset button.
So what could be the problem?
I am so sick of the MKS/Marlin BS every time I change even the slightest firmware variable. Is Duet WiFi the answer????

Edited 1 time(s). Last edit at 04/04/2019 11:53AM by DanL.
Re: MAXTEMP BED...please reset.
April 04, 2019 10:01PM
I doubt this is firmware related.

Are the laptop and the printer plugged into the same power plugs? (or strip board)
Re: MAXTEMP BED...please reset.
April 04, 2019 10:17PM
Yes, same outlet...so common ground, same V.
Just did edited Marlin upload from computer on battery...no ps on puter and everything was fine.
This was the proverbial straw on the camels back....just ordered a Duet WiFi.
My LCD is starting to freak out, too - jumbled text - so not hat tough a decision.
Sorry, only registered users may post in this forum.

Click here to login