Welcome! Log In Create A New Profile

Advanced

LCD12864 started dimming and showing garbage, and now nothing!

Posted by Maany 
LCD12864 started dimming and showing garbage, and now nothing!
June 28, 2019 06:46PM
Hello,

I have assembled my 3D Printer and was working and printing fine with it for a few months, until recently my LCD 12864 contrast was getting dimmer and dimmer with time (over a period of 2 weeks), today it started showing garbage and display is barely seen, until it finally gave up and now it just lights up without any display, only the background light.

i'm using ramps 1.4 with Arduino Mega 2560 R3

regulator on Mega is getting 12v and giving 5v (and is not heating up)
regulator on the back of my LCD is getting 4.1v and giving 3.7v (is this right?)



any ideas on what might have caused this? and how to fix it.

I have a project to finish and I need to print without a pc. (oh by the way, when i plug the usb into a laptop, it runs perfectly, with perfect contrast, I don't think the length of the cables is an issue here), but I mainly rely on printing from SD Card, that's why I need to work from my LCD menu.

Edited 1 time(s). Last edit at 06/28/2019 06:48PM by Maany.
Re: LCD12864 started dimming and showing garbage, and now nothing!
June 29, 2019 03:55AM
Deleted

Edited 1 time(s). Last edit at 06/29/2019 03:56AM by dc42.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: LCD12864 started dimming and showing garbage, and now nothing!
June 29, 2019 04:10AM
Would it be a solution to have it print by adding powered USB hub for the time being so that you can at least finish the prints you need finished?


http://www.marinusdebeer.nl/
Re: LCD12864 started dimming and showing garbage, and now nothing!
June 29, 2019 04:14AM
4,1 is way to low... and the 3.7 seems high, should be 3.3v for the sd card

This is a common issues, the mega voltage regulator is damaged as it was never designed for a ramps + glcd so it isnt putting out 5v any more.. when you plug in the USB 5v is taken from usb
Re: LCD12864 started dimming and showing garbage, and now nothing!
June 29, 2019 09:42AM
Thank you all for your valuable input, adding an external power source to mega fixed it, until I replace the regulator or solder an lm7805 on it

Edited 1 time(s). Last edit at 06/29/2019 10:47AM by Maany.
Sorry, only registered users may post in this forum.

Click here to login