Welcome! Log In Create A New Profile

Advanced

SPI interference - Display artifacts

Posted by jgrmstr 
SPI interference - Display artifacts
August 11, 2019 09:33AM
Hey everyone,

I'm trying to add a graphic LCD to my printer (Hypercube Evo + RADDS). It's a 128x64 ST7565 display. I've got it pretty much running on a test setup (Arduino Due + breadboard + display) but I'm already experiencing some issues when I touch/move the jumper wires or if they're too close together. Then the display freezes, shifts some lines or displays some weird artifacts or even stops working entirely. I'm using software SPI btw.

So I'm quite sure these are some interference issues between the wires and I'm not confident installing the display into my printer because the wires will be a bit longer and definitely close together. My question now is what can I do to avoid this? Do I need a shielded cable? Can I lower the speed for the software SPI in Marlin? Or will actually installing it help?
VDX
Re: SPI interference - Display artifacts
August 11, 2019 10:06AM
... looks, as if you'll need better shielding or rising the signal vs. EMI level.

When getting problems with longer data lines in flat cables, I've used cables with GND lines between two data lines for up to 1m cable length.

For even longer cables then either "level-shifting" (signal levels: 5V->24V---->24V>5V) ... or I've soldered small resistors with 47 to 470 Ohms (needs some testing) into the data lines to dampen the EMI ...


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: SPI interference - Display artifacts
August 11, 2019 01:51PM
Thank you!

At first I tested twisting each data line with an additonal ground wire, a suggestion I read somewhere else, with no success.

After that I tried your suggestion and put 47 Ohms resistors in the CLK, SI and CS line and at least on the breadboard I have no issues so far.
VDX
Re: SPI interference - Display artifacts
August 11, 2019 02:25PM
... hopefully it helps!


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: SPI interference - Display artifacts
August 11, 2019 04:49PM
I haven't checked the ST7565 data sheet, but if it is like the ST7920, its specification will call for a minimum of 3.5V high level on its inputs when it is powered from 5V. In which case, it won't run reliably with its inputs driven directly from a 3.3V processor. Use level shifters, which is what good 32-bit controller boards include on the LCD outputs. [Edit: maybe RADDS includes level shifters, although I don't remember seeing them on the schematic.]

Edited 2 time(s). Last edit at 08/11/2019 04:52PM by dc42.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Sorry, only registered users may post in this forum.

Click here to login