Welcome! Log In Create A New Profile

Advanced

Z axis only goes one way

Posted by Adroid 
Z axis only goes one way
February 21, 2020 12:12PM
Hi all,
I received an MKS Gen v1.4 replacement for my Tronxy x1. Flashed it with Repetier and using RepRapdiscount full graphics display. Only problem I am having is that the Z axis only wants to go down not up. Wit power off I raise the Z axis and then power the board on and try the homing and all is good. Then I move the X and Y axis in both directions (no problem). However the Zaxis only clicks when I try to move it up. Swapped driver boards and still does the same thing. Checked ref. voltage and It is good. And now I am at a loss.
Re: Z axis only goes one way
February 21, 2020 01:32PM
What stepper motors do you have?
What are you using for a Lead-screw?
What is your current ref voltage for the Z-Axis, and do you have dual Z-Axis steppers?

On My 3D Printers I have dual Z-Axis stepper motors and have to use almost double the ref voltage.

Edited 1 time(s). Last edit at 02/21/2020 01:34PM by Roberts_Clif.


Electronics Technician / Computer Programmer
Re: Z axis only goes one way
February 21, 2020 07:58PM
Answering Roberts_Clif questions. My stepper motors are all sl42sth34-1504a, Lead-screw is 8mm (4 starts?), ref. voltage for zaxis is .63 with just 1 stepper. I managed to replace the damaged chip on the Melzi board and all motors move the way they should. I really like the MKS board and I would like to use it instead. I think it is very wierd that the z axis will only move down. Reversing direction doesn't seem to help.
Re: Z axis only goes one way
February 21, 2020 08:31PM
I really like my controller style though its drivers are soldered to the controller.
Tried to replace the fried drivers without success, believe the replacement chips i purchased were not pin compatible.

Your stepper motor should be able to lift the Z-Axis wonder why it is not.

Did you measured the Melzi to get ref voltage for the MKS, if so you may want to tweak it up or down a little to see if a little higher or lower will make it work.


Electronics Technician / Computer Programmer
Re: Z axis only goes one way
February 21, 2020 10:23PM
Didn't think of that because the x and y axis are working fine. I will try raising and or lowering the ref. voltage.
Re: Z axis only goes one way
February 21, 2020 10:41PM
Just upped the ref. voltage and it worked!! Upped it from .63 to .73 and it moved up with no problem but to be safe I am leaving it at .76. Thanks!
Sorry, only registered users may post in this forum.

Click here to login