X, Y, and Z axis. Error: printer halted. kill (Make noise)
December 26, 2018 05:17PM
Hello, a few days ago I had assembled 3d printer. After installing Marlin firmware, I had opened pronterface and tried to move X,Y or Z axis but it make noise and doesn't move. I had not install heated bed yet but hotend is working fine. When I click X,Y or Z homing it gives an [ERROR] Errortongue sticking out smileyrinter halted. kill() called!. All the endstop is opened but not triggered. Copy of the firmware is also attached. I hope my problem get resolved.
Attachments:
open | download - Marlin.txt (143.6 KB)
Re: X, Y, and Z axis. Error: printer halted. kill (Make noise)
December 26, 2018 09:01PM
Do you have the type of stepper configured correctly
#define X_DRIVER_TYPE A4988
#define Y_DRIVER_TYPE A4988
#define Z_DRIVER_TYPE A4988
//#define X2_DRIVER_TYPE A4988
//#define Y2_DRIVER_TYPE A4988
//#define Z2_DRIVER_TYPE A4988
#define E0_DRIVER_TYPE A4988
//#define E1_DRIVER_TYPE A4988
//#define E2_DRIVER_TYPE A4988
//#define E3_DRIVER_TYPE A4988
//#define E4_DRIVER_TYPE A4988

When using
#define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN
Include line below as you are not deploying a Probe.
#define FIX_MOUNTED_PROBE

You have almost the same setting that are use in my 3DP11/12 what 3D Printer is this for.

Edited 1 time(s). Last edit at 12/26/2018 09:01PM by Roberts_Clif.


Electronics Technician / Computer Programmer
Re: X, Y, and Z axis. Error: printer halted. kill (Make noise)
December 26, 2018 09:38PM
Thanks for your reply. I had define stepper configured and also #define FIX_MOUNTED_PROBE but the problem remain the same. The noise is coming but X, Y and X axis are not moving. This 3d printer is Prusa i3 (RepRap).
Re: X, Y, and Z axis. Error: printer halted. kill (Make noise)
December 27, 2018 08:35AM
Make sure you have inserted the 3 jumper links under each stepper driver PCB.

Edited 4 time(s). Last edit at 12/27/2018 09:56PM by Roberts_Clif.


Electronics Technician / Computer Programmer
Re: X, Y, and Z axis. Error: printer halted. kill (Make noise)
December 28, 2018 01:16AM
Thanks a lot. I had forget Jumper to put. Now X, Y, and Z axis are working fine but now the Extruder stepper motor is not responding. I had check the stepper motor by pluging into x axis place, It works but when I put x-axis stepper motor in the place of extruder on ramp 1.4 it doesn't works. I had also tested the stepper driver but that is also fine. In extruder I had also plug in jumpers so that not the problem. So If anyone can help me out.
Re: X, Y, and Z axis. Error: printer halted. kill (Make noise)
December 28, 2018 08:08AM
The Extruder will not operate unless the Nozzle temperature is up to 170C minimum.
This is a software protection feature to prevent cold extrusion, that could cause damage to your 3D Printer.

However you can disable this with M302 S0 ; always allow extrusion (disable checking)

Edited 2 time(s). Last edit at 12/28/2018 08:59AM by Roberts_Clif.


Electronics Technician / Computer Programmer
Re: X, Y, and Z axis. Error: printer halted. kill (Make noise)
January 09, 2019 01:12PM
Sorry for the late reply. Thanks the problem got resolved. spinning smiley sticking its tongue out
Sorry, only registered users may post in this forum.

Click here to login