Welcome! Log In Create A New Profile


Problems with Latest? Marlin Firmware,

Posted by Ted62 
Problems with Latest? Marlin Firmware,
January 18, 2015 02:40PM
First let me say that although over a few years I have successfully built an early printrbot, a ord bot and a cherry pi delta, until now I have not encountered many problems with the software. Where I have I have managed to resolve it within a few hours searching this forum, googling etc.

Recently installed a servo operated auto bed levelling probe to my Ord Bot. I thought it would be a good time to update the Marlin Firmware to the most recent. Below my experience.

Downloaded the firmware from [github.com] and unzipped it.

Tried to compile it with a "as downloaded" configuration.h, edited it to include the graphics and motherboard which resulted in page of a cryptic errors. See my post "Can't compile with full graphics controller".

Eventually after searching through the list of errors I realised a number of files were missing from my libraries. These were included in the download, but in a separate directory. I could not find any readme files or documentation indicating that if I was using a graphics card with a SDcard reader I would need to install them to my libraries.

Installed the files and great Marlin now compiled and uploaded with the graphics screen lit and a display.

Edited the configuration.h with the changes required for my printer i.e thermistor type mechanical settings for endstops etc.

Compiled - success.

Tried running the printer using pronterface - extruder drive would not run. Yes I did send a M302 before trying.

Searched this forum for any information and found several had had similar problems but with no clear solution, and no clear information which version of Marlin was being used.

Strange the printer had been working perfectly before I tried to update it.

Checked out the motors and drivers by swopping them around and could find no fault with them when using the X Y or Z axis, but would not run on the extruder.

Switched the extruder pins in the pin.h to change the extruder from 0 to 1 still no drive. Also noted the pins in some cases are duplicated i.e extruder, Z2 and Y2. Commented out the duplicated entries

Spent several hours trying different approaches with regards to changing the motherboard defined which again is not clearly described. Configuration.h instructs "select from boards.h" which list several boards for Ramps (non of which include Ramps 1.4). To no avail still no extruder motor. I feel the listing in the V1 was less confusing.

Checked the continuity of the pins on the Ramps board all Ok.

One poster had indicated he had a problem with the solder on the arduino and as I had a spare board I changed the Ardiuno. All to no avail.

I have now reverted to my earlier version and it all works.

It is not my intention to complain as I realise and appreciate the great deal of work put in by the editors of the software and all for free. These are just my experiences with the latest version. I'm not sure if my problems are caused by my inexperience/lack of knowledge with the latest firmware, but I have not had problems with previous versions. Hopefully the developers/editors will visit the forum from time to time and pick up un my comments and follow up/dismiss as appropriate.
Re: Problems with Latest? Marlin Firmware,
January 21, 2015 05:33PM
It's very probably because an "independent PID parameters for each extruder" feature introduced recently after 1.0.2 release.
It tries to store 3 PID parameters into EEPROM settings for each inactive extruder but reads 4.
You can check if it's the case by M502 "factory reset" command. Extruder should work until the next reload.
Re: Problems with Latest? Marlin Firmware,
January 25, 2015 02:29PM
I have just swapped over to Marlin because I had issues with Repetier firmware that I couldn't fix on my Rumba board.

I have a similar issue, try to print and extruder doesn't work. I tried emergency stop, complete power off and nothing worked. What did work was going to EEPROM settings, Restore factory settings, and then Save them back to EEPROM. Extruder now works.

But, I do have another issues, which I guess I will post in a new thread. My heated bed, running on PID and Autotuned successfully, will get to my set temp (120 degrees) but when it actually starts printing, the bed temp will drop to 105 degrees and very very slowly work it's way back up. see pic.

I guess I'll try another firmware, failing that, swap back to my Ramps or Sanguino board.
Re: Problems with Latest? Marlin Firmware,
February 11, 2017 06:13PM
Same story here Ted. I sign each and every word you say. I don´t consider myself as 3D nerd, but I am also no novice. I have build some printers from scratch before, all documented in my blog etc, but what I have experience in the last 3 days has no word to it. I thought meanwhile the installation had grown to be userfriendly and less complicated. How is this supposed to work for newbies?
Concerning: [marlinfw.org]

What about the board.h, where can it be found anyway? Why is it not included in that Marlin zip?

BTW; That link where you can check reported issues is broken: [marlinfw.org])

Edited 1 time(s). Last edit at 02/11/2017 06:14PM by maboo.

Meine 3D Druck Abenteuer
FLSUN Delta Drucker für Deutschland
Books on 3D patents:
[goo.gl] (english)
[www.amazon.de] (deutsch)
Sorry, only registered users may post in this forum.

Click here to login