Welcome! Log In Create A New Profile


firmware for a MKS base v1.2

Posted by sludgeblink 
firmware for a MKS base v1.2
February 17, 2015 02:02PM
i am in need of help i got this 3d printer as a kit and put it to gather had it working it would print but it would not print right. so i looked up way it was missing up and found out that it could be the acceleration setting in the firmware so me being me looked around found out how to change the firmware and tried to do it my self. long story short i ended up missing everything up and nothing will work now. i used marlin i attached the configuration.h file so you can see what i did wrong and maybe help me out.
open | download - Configuration.h (38 KB)
Re: firmware for a MKS base v1.2
March 19, 2015 03:43PM
I am having single filaments being skipped in the middle of the x axis of certain models. i was thinking of upgrading FW but it sounds scary. Wish you the best of luck in fixing it.
Re: firmware for a MKS base v1.2
March 19, 2015 05:02PM
I have read that the board is compatible with marlin firmware from one user, can't confirm for definite. so you can perhaps flash marlin firmware on it.
Re: firmware for a MKS base v1.2
March 29, 2015 05:00PM
Yes it is 100% marlin compatible. It is basically a Arduino MEGA2560 and a RAMPS1.4 on a single board. I have just flashed my MKS Gen v1.1 with the latest Marlin dev build and it worked fine after changing a few settings.
Re: firmware for a MKS base v1.2
May 01, 2015 05:29PM
hububalli, would you have any instruction on how to properly configure the board? I am in the same boat. random issues with these boards when they arrive. mine doesn't use the whole bed and at times randomly goes all garbled on the LCD and when printing from SD it will print good at times and others have slice the object so it's good on the bottom but the top it's slid to the left and continued to print. I'd say it's a crap upload when they send them out.
please if anyone has success with them would be greatly appreciated.
Re: firmware for a MKS base v1.2
May 24, 2015 10:52AM
I'll try to offer a few ideas. First the garbled screen is usually due to long cables from the MKS to the LCD getting too close to some other cable or other source of magnetic interference. The information traveling down those tiny wires is in the form of ones and zeroes and the current level is very weak so any inductance along the cable run will destroy the data. Even static discharge from your hand when you reach up and touch the LCD can do it. Now that I better understand these issues and after having isolated my cables to the LCD I never have any problems with it going garbled.

On the issue of losing it's place later in the print and printing a mess, try going with a slower acceleration rate and also lower the XY Jerk, mine was on 20 originally and lowering it to 10 solved my problem with that. I also lowered my acceleration from 3000 to 1800 at the same time. It no longer does that but it prints a little slower now. That was OK with me because a finish print that is a little slow is better than a fast printed piece of garbage. I am still learning myself and hope that helps a little. I have had my printer for about 6 months and the MKS board is still going strong. I have been learning to make small changes in the firmware and see what the effect is. There is a wealth of information out there describing what each parameter does.
Re: firmware for a MKS base v1.2
May 28, 2015 04:30AM
I bought my Prusa i3 3D printer with MKS Base V1.2 controller recently. Initially the firmware was in Chinese and everything was working fine. But I changed the firmware to Marlin Firmware and now my Extruder moter is not working. Can you please help me solve this problem?

Edited 1 time(s). Last edit at 05/28/2015 04:31AM by upen.
Re: firmware for a MKS base v1.2
May 28, 2015 07:40PM
I don't hit the boards daily but felt I might offer a suggestion to get you some help. First you might show exactly what printer you obtained so people can see the configuration of it (A link to it would be helpful). There are different types of extruders etc and in order to help you they will need to know details about your exact printer.
Re: firmware for a MKS base v1.2
July 20, 2015 04:29PM
i am newbie also i am using MKS base 1.3 board but now i like to add approximate sensor for auto leveling i need help should i just upload new Merlin firmware or what? i like to backup first the original firmware if posable download the original and add the auto leveling and the upload but i dont know how to download the original any one help thanks
Re: firmware for a MKS base v1.2
November 19, 2015 05:52PM
I have exactly the same issue. The Type of Printer is a HIC TOP

It was working fine till a power surge in the house fried the controller board.I have hooked the extruder motor into the Y axis on the board and it works fine pushing filament in and out. but when I load the firmware from HIC TOP I can not get the extruder motor to function. can anyone help me rebuild the firm ware from scratch. I am new to this kind of programming, but I am a software developer by trade.

Thanks in advance
Key Master
Re: firmware for a MKS base v1.2
November 20, 2015 03:31AM
Usually the extruder motor only works when the hotend is above eg. 170°C
Did you try that?
Alternatively you can also send M302 from pronterface before you try to extrude.
Re: firmware for a MKS base v1.2
November 20, 2015 10:39AM
I will try it when I get home from work tonight. But I am pretty sure that I ran the extruder at 210°C and it would not work, But I give it a shot. If thats all it is I will be a very happy camper.
Re: firmware for a MKS base v1.2
November 21, 2015 12:54PM
Just wanted to let you know that is exactly what the issue was I was trying to cold extrude the filament. I waited for it to heat up and the motor kicked in just as expected. than you very much for your help. Now I just have to revel the bed and I should be in business. Thank you again for all your help.

Re: firmware for a MKS base v1.2
August 01, 2016 10:27PM
Re your comment about flashing the MKS gen v1.1. On my Prusa i3, I have MKS_2z v1.2 board. Marlin has got me stumped and so I ask a basic question what and how do I flash to Marlin or the board.
Any body else who wants to throw their 2 bobs worth in I would appreciate it.
Thank you
Re: firmware for a MKS base v1.2
October 04, 2016 11:34PM
Hi guys, I got the VCP driversand I think I uploaded the firmware but the configuration.h tab is not showing up. Anyone know how to fix this?
Sorry, only registered users may post in this forum.

Click here to login