Welcome! Log In Create A New Profile


installing firmware gen 2

Posted by gbot 
installing firmware gen 2
June 15, 2010 01:35PM
Oh Please help.

am installing the gen 2 firmware on arduino 0018 and am following the instructions below....................

Program the Arduino or Sanguino to talk G Code
Download all the files at:


into a directory called GCode_Interpreter.

Make sure you have an up-to-date Arduino IDE. I'm using Arduino 0015, and that works fine.

Copy the files extruder.h.dist, parameters.h.dist and pins.h.dist to extruder.h, parameters.h and pins.h. These are your local copies that you will configure to your particular RepRap machine.

Plug your Arduino or Sanguino into a USB port on your host computer, then open the Arduino/Sanguino development environment. Load up the file GCode_Interpreter.pde. You should get eight tabs: GCode_Interpreter, ThermistorTable.h, extruder, extruder.h, parameters.h, pins.h, process_string and stepper_control.[/color][/color]

the strange thing is, they wont work, I get loads of errors. However there is an additional file in the folder called init.pde and when this is included it does load with no errors.

Snag is when I run the arduino on the reprap console NOTHING happens on test. I know I have the reprap console cofiguired correct because I have had my mates reprap on it and it works.

Its so frustrating.................... Could anybody confirm that the files and istructions are correct. THanks Graham..
Re: installing firmware gen 2
June 15, 2010 08:19PM
> Its so frustrating

Yeah, it's so frustrating to always see people post "I get loads of errors" without further hints on what the actual received behaviour might be. Does your computer burst into flames when you upload the firmware? Which lights on the Arduino light up? Does the firmware compile? Did you test some of the sample code coming with the Arduino IDE? "Blink" should always work and requires no further hardware.

Just tell us what you see and copy error messages here. :-)

Generation 7 Electronics Teacup Firmware RepRap DIY
Re: installing firmware gen 2
June 16, 2010 05:46AM
thanks jump-ing............. looks like a good dose of sarcasm did the trick, felt a wally when I re-read my post.

looked over it all this morning and......................

it seems you do need the init file in the sketch as this sets many of the pins, despite this not being mentioned in the instructions. I was attaching my mates arduino to a windows pc that was running reprap console this worked fine. I then I attached my arduiono and it didn,t; it seems this is because the machine sees the different arduinos as different ports even though they are on same usb, I changed these in the reprap consoles preferences (bottom left) and BINGO... Communication and spinning steppers on test.

Sorry, only registered users may post in this forum.

Click here to login