Welcome! Log In Create A New Profile


Stepper Extruder Again. Code Help apprec.

Posted by StefHH 
Stepper Extruder Again. Code Help apprec.
August 03, 2010 07:46AM
Hello RepRappers,

while having my repstrap built up now and googling around for over a week for a way to drive the stepper extruder ( v1.2 MoBo; v2.2 ExCo), the fun and exitement in the project starts to disappear for me. I did not expect the entire project to be just for people oh so keen in writing their own code or beeing extremely familiar with programming/ using arduinos. I did my fair shar in learning about compiling, uploading firmware, commenting/uncommenting things ( absolutely no clue about all that one week ago) but without results, well, it is just frustrating, especially if one does not know what he is doing.
I can find a lot of bits of code in several forums about what to type here and there and how a small arduino program looks like to drive a stepper extruder, but without programming background, that does not help AT ALL. (This might be the typical thing were insiders just do it because it is so easy and natural, and outsiders do not even know which folder to go to and what program to use.) Well, at the end i have the strong feeling that the project will precisely fail its intention of bringing the printer to the masses, if such obvious and common things like how to use a stepper extruder are so badly documented.

Please Please don't get me wrong! I have the deepest respect for all the work, time and effort all of the founders of the project and the contributors have put in this! It is unbelievable how far you went until now, and in such a short time. Maybe it is just a bit too early for people without electronics background to step into the project (i am industrial designer) but i also think that those "outside" people can contribute their fair share and should be able to do so without an PhD in Math winking smiley . This should be the biggest benefit in open source projects: make it accessible to everybody, including mom and grandpa, who might both have brilliant simple solutions for problems were we are not able to think outside the box anymore!

Sorry if i am wrong or if it is my fault, obviously lots of people have managed getting their RR to run. I am just getting confused and frustrated about the various softwares, firmwares, version numbers, tweaks and hacks and all that stuff and there is no place were this information is gathered and sorted and put in step by step instructions (from the very beginning to the very end, as boring as this might be). The reprap wiki has a great start on this but also seems to put a lot of knowledge in advance.

(now please help me with that extruder... i have a wade-style stepper Ex that wants to be driven from the extruder controllerboard v.2.2 with the latest, automatically uploaded (great!) (Cupcakecnc?) firmware . I am using replicatorG (because the host software gives me nullpointerexeption (wtf?) when doing stl->gcode. also, the host firmware makes my x+y steppers whine and get hot while in standby. ).
So: repG, MoBo 1.2 with makerbot firmware (latest), want arduinoslaveextruder firmware on the ExCo but compiling does give me errors so i cannot upload the stepper-modified firmware. I am going mad. And more googling brings up no more helpful information but just techtalk ... With the host software, at the ExtruderStepper at least made some noise, although did not move. In both programs (host and repG), the xyz axis are working fine.
Oh. I am running win7 64bit...

Thank you guys for the great work!

Re: Stepper Extruder Again. Code Help apprec.
August 03, 2010 06:23PM
Perhaps you want to set any host software aside for now and issue commands by hand. Hook up a serial terminal (GtkTerm, minicom, HyperTerminal, ...) to the USB/serial port and start typing. "M105" should send you back a few digits, a temperature reading. Adjust the baud rate if you get gibberish. "G1 X10 F50" should move your X axis slowly a few millimeters.

Whining motors are typically seen when trying to move them faster than they can follow. They don't move at all, then.

Generation 7 Electronics Teacup Firmware RepRap DIY
Re: Stepper Extruder Again. Code Help apprec.
August 04, 2010 04:35AM
Thanks for your reply. I guess that you are assuming more knownledge than is existent here.
I am happy that there is any kind of host software at all, as anything else brings up more questions: What is a serial terminal? How do I hook that up to the Port? Where do I start typing?What is a baud rate? G1X10F50? ....
As I said earlier, having no programming background at all ( a little bit of Flash&Lingo...), I was REALLY happy about the host's GUI. I think this was the kickstart that made me start trying, together with a pretty good documentation at least about the hardware. I see that there is a documentation for the software-side, too, but that just pulls up too many questions to be handled... Anyway, with both the host software and repG I got xyz to move, only the extruder is not working. I see that the board is flickering and the motor at least whines/locks, but it does not move...
Maybe someone has a link to the already stepper-ready-altered extruder controller firmware? I found some files on my computer but they are in .hex format. no idea what to do with them. I already downloaded the last ex firmware from github and changed the comments at the stepper portion (the commenting/uncommenting thing) but the files won't compile (I am using arduino 0018), they will not compile unaltered, too. There is always the same error ... (other files compiled fine, so I know the software is working)

Re: Stepper Extruder Again. Code Help apprec.
August 04, 2010 04:38AM
I will try to compile my stuff with arduino 0017 and report my results later...
Re: Stepper Extruder Again. Code Help apprec.
August 04, 2010 04:51AM
You sure you have the right processor selected?

Bob Morrison
Wörth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Stepper Extruder Again. Code Help apprec.
August 05, 2010 10:16AM
Yes, arduino Diecimala selected. no difference with arduino 017.
Anyway, i tried a different firmware now ( reprap fived gcode interpreter and corresponding extruder firmware, both compiled fine), where the mobo firmware went on the board just fine, but the extruder portion just would not. Of course, i plugged the ftdi into the ex-board and also paid attention to putting it the right way around. tried it a thousand times... Strange thing is that all the lights on the extruder board come on when plugging the ftdi in. the 4 ones on the side with the heater connectors are bright, allthe other ones are just very very dim. is that normal behaviour?

Re: Stepper Extruder Again. Code Help apprec.
August 05, 2010 10:33AM
Based on your latest post it would appear that your problem is no longer compiling but uploading.
If that is the case do you press the reset button on the stepper board?
For BOTH my Motherboard and my Extruder Controller as soon as I press the upload button on the Arduino software I then press and hold the reset button on the board I am uploading to until the text appears on the Arduino screen then I release the button. Using this method my firmware uploads every time without any problems.

Bob Morrison
Wörth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Stepper Extruder Again. Code Help apprec.
August 05, 2010 11:16AM
I repetedly tried it this way. For the motherboard it worked just fine. Now with all those lights on (see above post) i getting afraid that my extrudercontroller is somehow messed up. not shure if it was like this from the start. As i said, i sucessfully uploaded some firmware on it earlier ( i guess through the repG update routine, which is now not working, too.).
How are your ex board lit?
Re: Stepper Extruder Again. Code Help apprec.
August 10, 2010 12:53PM
It seemes like i have turned the pot on the extruder board up too much. I turned it down and then the firmware upload went fine. why? no idea. anyway, my extruder stepper is still not working, only humming when i click on extrude in the host software. I had this before and thought i might just turn up power with the pot. doesnt work. because of that, the pot was still turned up. Also the termistor does not show signs of life...mh. well. If at least my repstrap would be pretty, so that i could enjoy looking at it even if it is not working...
Re: Stepper Extruder Again. Code Help apprec.
August 31, 2010 05:34AM
It`s me again...

In the meantime, i got my extruder at least halfway to work. I am doing all my testing through the RepG control panel. The Extruder Stepper does turn (although it seems do be a bit weak) , the heater is heating and the thermistor is reading. Anyway, it seems like i cannot get my extruder hot enough to properly extrude. I am getting it barely hot enough so that i can push the filament by hand (very hard) to get SOME extrusion. temp reading seems to be fine although it never really reaches the set temperature. I have unscrewed the brass barrel from the ptfe and just clamped it down to make sure that this is not the problem. Another thing i found is that, if i turn the pot an the ex-board up more than just a very few degrees (presumed it is turned all the way counterclockwise), the entir boards seems to shut down. the temp reading drops to zero and all the lights on the heater rail turn on, getting brighter the more i turn the pot up. when i turn it all the way back, the reset led flashes once and the board seems to reset. What can be wrong here? At the very beginning of my wiring, i notices the two of the extruder stepper motor wires were touching each other. Could this have fried anything on the board? Is there a way to find out of some of the chips are dead?
Any help is appreciated. I am going mad having this machine here for almost a month now and not getting it to work.


p.s. to the attachements: first is the barrel/nozzle, with two different heater wires attached, one at the barrel and one at the nozzle, that i am using one at a time to figure out why it is so hard to get extrusion.

second pic is the ex-board in working condition, pot turned all the way c-clockwise

third pic is e-board with pot turn clockwise just a wee bit. you see that the upper right leds went off, what you propably cannot see is that the leds on the left (the ones that appear to be off) are just veeeery dim, but on.

fourth pic. all the leds on the left are on and are just getting brighter when turning the pot up even more (pot is now in the middle position) . if you look closely, you see that almost every led on the board is on at least a little bit.

now here is the big question: what is wrong here?
open | download - IMG_0219.JPG (214.9 KB)
open | download - IMG_0220.JPG (285.4 KB)
open | download - IMG_0221.JPG (303.9 KB)
open | download - IMG_0222.JPG (295.1 KB)
Sorry, only registered users may post in this forum.

Click here to login