Welcome! Log In Create A New Profile

Advanced

Marlin4Due compiling error when activating servo_endstops for autolevel

Posted by Repraph 
Marlin4Due compiling error when activating servo_endstops for autolevel
February 27, 2016 11:59AM
Hi all,

I am printing for 2 years now on a self build Prusa I3 Rework.

Recently i got a RADDS1.5 and now i want to switch to 32bit with Marlin4Due.

The firmware compiles fine in Arduino IDE 1.5.8 , until I activate the

#define Z_ENDSTOP_SERVO_NR 0

for a BLTouch Autolevel Sensor. After activating I get the following errors:


In file included from Configuration.h:5:0,
from Marlin.h:18,
from Marlin_main.cpp:30:
macros.h:22:25: error: pasting "SWITCH_ENABLED_" and "{" does not give a valid preprocessing token
#define ENABLED(b) _CAT(SWITCH_ENABLED_, b)
^
macros.h:18:22: note: in definition of macro '_CAT'
#define _CAT(a, ...) a ## __VA_ARGS__
^
Marlin_main.cpp:2787:15: note: in expansion of macro 'ENABLED'
#if ENABLED(SERVO_ENDSTOPS) || ENABLED(Z_PROBE_ALLEN_KEY) || ENABLED(Z_PROBE_SLED)
^
Conditionals.h:549:30: error: token "{" is not valid in preprocessor expressions
#define SERVO_ENDSTOPS {X_ENDSTOP_SERVO_NR, Y_ENDSTOP_SERVO_NR, Z_ENDSTOP_SERVO_NR}
^
macros.h:18:27: note: in definition of macro '_CAT'
#define _CAT(a, ...) a ## __VA_ARGS__
^
Marlin_main.cpp:2787:15: note: in expansion of macro 'ENABLED'
#if ENABLED(SERVO_ENDSTOPS) || ENABLED(Z_PROBE_ALLEN_KEY) || ENABLED(Z_PROBE_SLED)
^
Marlin_main.cpp:2787:23: note: in expansion of macro 'SERVO_ENDSTOPS'
#if ENABLED(SERVO_ENDSTOPS) || ENABLED(Z_PROBE_ALLEN_KEY) || ENABLED(Z_PROBE_SLED)
^
Fehler beim √úbersetzen

I really dont know what to do with it, as soon as I comment the SERVO_ENDSTOPS, the code compiles fine.

Any advice is greatly appreciated!

Repraph

Edited 1 time(s). Last edit at 02/27/2016 12:00PM by Repraph.
Attachments:
open | download - Marlin_main.cpp (210 KB)
open | download - Conditionals.h (17.4 KB)
open | download - Configuration.h (40.2 KB)
open | download - macros.h (726 bytes)
Re: Marlin4Due compiling error when activating servo_endstops for autolevel
February 27, 2016 01:11PM
Have you tried using Arduino 1.6.4, that's the version I used to get it to compile. The version of the Arduino IDE used can cause problems.
Re: Marlin4Due compiling error when activating servo_endstops for autolevel
February 27, 2016 02:41PM
I just gave it a try with the exact same results....angry smiley

Thanks for the quick reply anyway

Edited 1 time(s). Last edit at 02/27/2016 02:47PM by Repraph.
Re: Marlin4Due compiling error when activating servo_endstops for autolevel
August 06, 2017 12:40PM
Did you find a solution? I'm having the same problem while trying to add a BLTouch using 1.8.3.
Sorry, only registered users may post in this forum.

Click here to login