Welcome! Log In Create A New Profile


Azteeg X3 Pro + Repetier - Problems with third extruder

Posted by ElColor 
Azteeg X3 Pro + Repetier - Problems with third extruder
May 17, 2016 11:40AM
Hey there!

I am using the Azteeg X3 Pro running with Repetier 0.92.

So far I was using it with two extruders and everything worked fine. Now I would like to use a third (..forth, fifth..) extruder. Therefore I used the configuration tool to create a new configuration.h file defining 3 (..4,5...) Extruders (EXT0, EXT1, EXT2). Same settings for the 3 extruder motors.

With manual control I can still move EXT0 and EXT1 without problems. But When I try to move EXT2, it only works in one direction. Or more precise:

Moving EXT2 "up" -> motor is turning to the right.
Moving EXT2 "down" -> motor starts turning to the left and immediately switches direction (turning to the right as well).

Extruder 4 & 5 (EXT3, EXT4) do not move at all (completely quiet).

What I tried so far:
- download new firmware
- changing stepper drivers
- changing motor + wiring
- redefining pins in pins.h:
pins of EXT0 -> EXT2
pins of EXT2 -> EXT0
-> same problem as before but on the motor connected to the physical extruder 0 port. Motor connected to physical extruder 2 port now works fine. So the Problem needs to be connected to the firmware.

Anybody experiecing the same problems? Any ideas what could be wrong?

Sorry, only registered users may post in this forum.

Click here to login