Welcome! Log In Create A New Profile


Gen 3 Electronics Extruder 2.2 Issues

Posted by Skoll 
Gen 3 Electronics Extruder 2.2 Issues
December 17, 2010 12:13PM
I'll try and get to the point and explain my situation.

im not very competent with coding. i have attempted to install firmware stated in the reprap wiki. but i have no success and i dont know what i am doing is correct. this is why im using replicatorg. also i pretty much have no knowledge of electronics terminology.

what i am using
*windows 7 32 bit,
*replicatorG 0020
*Techzone Gen 3 Electronics
firmware from replicatorG
2.3 stepper controller

Everything is work fine except the extruder motor.

it some times turns in the desired direction but it seems to have trouble moving, and has no torque at all. other times it fails at moving completely. when this happen an error message comes up on replicatorG "packet lost". this also seems to effect the temperature read out as well.

i have searched the internet and these forums for a good week about trying to solve this problem but everyone similar discription i have read has a slighlty different problem to me.

things i have tried to fix the issue
checking the motor coils (all working)
checked the chips on the Extruder for unsoldered connections (confident that they are)
checking the connections from the MB to the Extruder Board (confident its correct)
updating replicatorG to the latest version (V 0022) still same issue exists.

well that's my problem, any feed back is greatly appreciated
Re: Gen 3 Electronics Extruder 2.2 Issues
December 17, 2010 05:11PM
... maybe you have an extruder-board with open AGND-GND-link - check if the two pins near the oscillator are short .. if not, then solder a piece of wire between them as shortcut ...

Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: Gen 3 Electronics Extruder 2.2 Issues
December 17, 2010 05:22PM
Try turning up the pot on the extruder, this increses the ammount of torque you will need in order to push the filament through.

Myself I had a catastrophic problem, I used a DC motor that was filtered, but still too much EMI, such that it burned out one of the motor drivers. I now use a seperate stepper driver amd switched to a stepper.

To me it sounds like you still need to adjust the pot with a little screwdriver.
Re: Gen 3 Electronics Extruder 2.2 Issues
December 17, 2010 08:08PM
Im not sure which part of the you mean, as you have a different EC to me. but i circled in RED what i think you ment (vicktor), and circled in yellow what i think (grogyans).

adjusting the POT didnt seem to have any effect.

im starting to think it might be a comunication issue between the MB and the EC as i keep on getting the following message when the motor fails to move:

[01:06:08] Packet response code: Unknown code
[01:06:08] Packet payload: empty
Re: Gen 3 Electronics Extruder 2.2 Issues
January 16, 2011 05:33PM
Ok, im still having issues. i thought i would leave it a while and research my self on the problem and let people have a brake for xmas.

i have tried installing firmware recommended by reprap.org and looked through the code and it seemed to me nothing needed editing. yet nothing worked. not even the x,y,z motors.

so i reuploaded using replicatorg. but still suffering from the same lack of torque / missing steps with the extruder. does anyone have any ideas? this is becoming very frustrating and seems like a waste of money now.
Re: Gen 3 Electronics Extruder 2.2 Issues
January 17, 2011 07:14AM
The gen 3 extruder board uses DC motor controllers in a bodged up way to control a stepper. The PWM for the DC motor driver (which sets the torque on your stepper) can be set explicitly by the software, or set to a value based on reading the voltage from the pot on the board. When I first started, I had all sorts of problems where sometimes the extruder seemed to enough torque and sometimes it was really weak. I never worked out what was causing this, because in the end, I just hacked the firmware to hard-code the PWM to 255 (which I think means it drives the strongest). I could do this because the coils on my steppers are about 30 ohms. With lower resistance steppers they would get too hot or possibly burn out the driver chips if set to run at max power.

I suggest you try hard coding the PWM in the extruder firmware.
Re: Gen 3 Electronics Extruder 2.2 Issues
January 18, 2011 12:08PM
using replicatorg v 23, i set the PWM to 255, the problem still persists, i also replaced the wires with store bought ones just incase it was my shoddy wiring. and attached some cooling fans in case it was a over heating problem. nothing seems to work.

it does turn in the right direction sometimes and on other doesn't move at all. and when it does move it can be quite easily stopped with my fingers.

i am using NEMA 17 stepper motors, i have read they are very unlikely to burn out.

any other ideas?

maybe it is the firmware that replicatorg uploads... or a faulty extruder board.
Re: Gen 3 Electronics Extruder 2.2 Issues
January 19, 2011 09:27AM
Driving a stepper with two h-bridges (and no current sensing/control) is a nasty hack, and has never worked well. All sorts of people have had problems getting it working.

You'll notice that the stepper is actually "controlled" via two extra wires running from the motherboard to the extruder controller. Have you connected these two wires? Have you connected a ground wire as well? rs-485 being a differential signaling method doesn't require the ground be exactly the same between the two boards, but the extra two wires do.

The official "stepper motor extruder using the Gen3 electronics" hack uses these two wires to control the extruder stepper, and rs-485 for fan control, temperature reporting and control, etc. The extruder controller polls the two wires, and then manipulates the h-bridges appropriately. It also checks the pot to determine what to set the PWM too. But only if it's been given the proper M-code - you can set the PWM directly via M-code, at which point it ignores the pot setting. Note that you shouldn't start with the PWM set for more than about half - one of the downsides of this hack is that it's easy to burn up the h-bridges.

It's much simpler and more reliable to add an extra stepper controller (either pololu or whatever you're already using) and hook the control wires from the motherboard (which are step and direction) to it instead, and use that to drive your extruder stepper. You'll get better control, more reliable operation, and less screwing around with a stupid hack. But you have to spend more money. sad smiley

Right now I can't seem to find the info about which wires from the motherboard are step and direction, nor where to hook them up to the extruder controller. But missing the ground wire may be your problem anyway.

I'm building it with Baling Wire
Re: Gen 3 Electronics Extruder 2.2 Issues
January 19, 2011 09:45AM
SDA to D10
SCL to D9

See the Mendel Wiring Diagram.

Bob Morrison
Wörth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Gen 3 Electronics Extruder 2.2 Issues
January 19, 2011 11:20AM
@ jgilmore

yes i think the wires are all connected correctly. but this i the first i have heard of a ground wire, and can not see one mentioned in the techzone diagrams or reprap. could you elaborate more?

i think the only option left to me is get a fourth stepper driver. and try and hook it up that way.

but the thing that bother me is i can not get it to be consistent. it either fails in one way, or a completely different way. with the condition being constant.

@ rhmorrison

it's a different board.

Re: Gen 3 Electronics Extruder 2.2 Issues
January 19, 2011 06:37PM
The grounds of the mainboard and the extruder board need to be the same. Try connecting them together with a third wire.

I'm building it with Baling Wire
Re: Gen 3 Electronics Extruder 2.2 Issues
January 21, 2011 04:45AM
Sorry still not following, do you mean the ground pin from the 6 pin TTL?
Re: Gen 3 Electronics Extruder 2.2 Issues
January 21, 2011 08:46AM
There is a message here That has a link to a picture. Look at the black wire on the diagram.

Basically, there is a six pin right angle header with two grounds, vcc, rx, tx, & reset. run an extra wire from the outermost gnd on that connector to the GND on the 12V connector on the extruder controller.

here is a link to the picture linked to from the referenced post.

I'm building it with Baling Wire
Re: Gen 3 Electronics Extruder 2.2 Issues
February 06, 2011 08:49PM
I'm not sure if this problem has been solved but I noticed that Skoll is using the firmware from replicatorG on Mendel with techzone remix Gen 3 electronics. I didn't think that this firmware supports the stepper motor on the extruder. Have you tried running with the reprap host software and firmware? Note that you have to load the firmware to the motherboard and then to the extruder controller separately by connecting each board's 6-pin serial connector to the USB-serial adapter.
Sorry, only registered users may post in this forum.

Click here to login