Welcome! Log In Create A New Profile


Arduino Uno and Teacup firmware uploading and/or connection Problems

Posted by ajnordin 
Arduino Uno and Teacup firmware uploading and/or connection Problems
September 07, 2016 01:54PM

I'm just going to lay it out: I am new to 3D printing. I am currently building a small 3D printer (by small I mean 33 cm^3 print area) mainly for learning purposes and to hopefully reuse the bulk of the electronics for a bigger and better 3D printer. I have built the bulk of the printer (X,Y,Z axes, electronics hooked up, etc), but I have yet to build/get an extruder, hot end, temperature sensor, endstops, etc... Anyways, I just want to get the main electronics and firmware figured out.

- Printer made from recycled CD/DVD drive laser sleds and stepper motors for each axis.
- Arduino Uno for the controller
- Easy Driver boards for the stepper motor drivers.

My problem is the firmware. I only know of two CNC firmwares that work with Arduino Uno: Teacup and GRBL. (I know that GRBL is mainly a CNC milling firmware, not 3D Printing).

When I run GRBL on my setup, I can move all the axes manually using a GRBL controller program on my HP Pavilion Laptop running windows 7, and I can even run gcode created using makercam to draw out basic shapes with a pen mounted to it. So GRBL sounds great, but I can't do 3D printing with it sad smiley

So I found out about teacup, which sounds fantastic because I have read of people who run teacup on the Arduino Uno. So after some (or a lot of) trial, error, forum and wiki searching, I found out what I needed to input into config tool to build it and upload it to my Arduino. So I got it uploaded to the Arduino Uno. Configtool said that it was successful, and so I tried to connect with it using 115200 Baud Rate and the correct COM with Pronterface, and Repetier... and it didn't work. I tried Pronterface first, and it just said connecting for a LONG time 5-10 mins. so I selected debug communications in Menu > Settings > Debug Communications. It kept showing the same command being sent over and over and over. (SENT:M105)

After hours of searching Forums, Google, the Teacup wiki, etc. I realized that I probably set up teacup wrong or did something wrong in config tool. So these are the steps I took in setting up config tool, building and uploading:

- Installed python
- Installed wxpython
- I have the Arduino IDE already.
- Got the Teacup_Firmware-master folder
- Ran configtool.py
- Input the printer specs
- Input the board specs-- I used the board.cnc-shield-v.3.h (which I heard was closest to Arduino Uno)
- Adjusted the pins (which were already set to exactly how I have all the pins set up).
- Saved the printer and board.
- Under Menu > Edit > Settings > Modify Settings I changed the Arduino directory to where the Arduino IDE program folder is located
- In Modify Settings I changed the AVR programmer to "arduino" instead of the "stk...something" one (because it wouldn't upload to the board using that one).
- Made sure COM port and Baud rate were correct
- Selected Build, it built correctly. (as far as I know)
- Finally Selected Upload.

It uploaded, and said that it uploaded correctly, so I thought everything was fine and dandy... then I tried to connect with it using pronterface and that's where all of the recent drama spurred from-- it wouldn't connect.

I will attach screenshots of my settings, .txt files of the code that the build and upload buttons created. The Configtool1-5 pictures attached are my input settings.

I'm pretty sure the reason that it's not working is because my atmega 328p Arduino Uno doesn't have enough RAM (it's using 519.48% RAM, but only 55.46% FLASH and 0.78% EEPROM). So my question is how do I reduce the amount of RAM that is needed? Others have gotten teacup to work with Arduino Uno, so what did I do wrong? or better yet, what do I need to do to get it working? If anyone can help I would be extremely greatful!
open | download - Configtool1.jpg (118 KB)
open | download - Configtool2.jpg (91.2 KB)
open | download - Configtool3.jpg (117.2 KB)
open | download - Configtool4.jpg (154.7 KB)
open | download - Configtool5.jpg (156.2 KB)
open | download - Build.txt (38.2 KB)
open | download - Upload.txt (1.6 KB)
open | download - Pronterface1.jpg (128.8 KB)
Re: Arduino Uno and Teacup firmware uploading and/or connection Problems
September 07, 2016 02:18PM
I guess you use given printer config? This has a too huge Movebuffer size. Please reduce it from 96 to 8. I'm running some testing machine with Teacup on an Arduino Nano. Works also perfect smiling smiley

Edited 3 time(s). Last edit at 09/07/2016 02:46PM by Wurstnase.

Triffid Hunter's Calibration Guide --> X <-- Drill for new Monitor Most important Gcode.

Re: Arduino Uno and Teacup firmware uploading and/or connection Problems
September 07, 2016 03:46PM
Ah, I see! I will try it, see if it works, and post my results!

Also, what is the function of the movebuffer size?
Re: Arduino Uno and Teacup firmware uploading and/or connection Problems
September 07, 2016 09:06PM
Ok, well I just feel dumb now... It worked when I set the move buffer size from 96 to 8. Thank you so much! I got teacup working quite nicely on my printer using pronterface. I can move the axes around manually, I just need to test some Goode with it.
Re: Arduino Uno and Teacup firmware uploading and/or connection Problems
May 30, 2017 05:45AM
Hello !
I setting the same as you, on an arduino nano, it is seem perfect but when i control manually in pronterface, the z axis does not go up normally, it is weak, i click again, it run well
What problem is it, could you help me. Thanks and sorry because i am not good in english
Re: Arduino Uno and Teacup firmware uploading and/or connection Problems
June 18, 2017 10:42AM
Hello i amde a 3rd printer also myself by using uno too but want to ask u where have u connect the heater of the extruder and where the thermistors which pins? Also have u made any adjustments on teacup for those?
Sorry, only registered users may post in this forum.

Click here to login