Welcome! Log In Create A New Profile



Posted by makeme 
February 27, 2011 07:22PM
Hey guys, so, I just got to the point where I tried to get a toolchain established. I'm using RAMPS v1.2 and I managed to get tesla/tonokip's firmware working.

After dealing with Arduino's stuff I got to the place where the wiki says to enter the provided values in the pins.h file. [reprap.org]
So, the first thing I did was replace what was in pins.h with what was in the text box labeled "RAMPS v1.1 and later." However, that created an error because some variables were undefined. It looks like the syntax of variables like "EXTRUDER_0_STEP_PIN" doesn't work with the main firmware script.

I went back and just didn't change the pins.h file at all, and everything worked.

Is this the kind of thing I can expect trying to 1) get a Mendel working and 2) gradually improve it? How do you guys keep on top of changes to the soft/firmware? The different variable syntax implies that someone was trying to add a feature (maybe two extrudres since one is 0 and another is 1?) so they changed the name of the variable but didn't tell anyone else. Or maybe that bit of the wiki only applies to a different firmware?
Sorry, only registered users may post in this forum.

Click here to login