Mendel firmware
December 01, 2017 02:30PM
I have what I believe is an old Mendel (first iteration) with an Arduino Mega and Ramps 1.4. Picture of the printer. I was given it some years ago by a fella that wanted me to print some prototypes. I used it off and on for a few years doing that. Then it ended up covered on my bench for several years, until I recently wanted to print some parts for myself. It wouldn't print. started checking it out as I could and as my research gave me an idea of what to check next. Everything mechanical and electrical seemed to checkout, so I decided the problem lay in the firmware. Failing to find firmware specifically for it, I decided to try Marlin. Again, I could not find any thing to guide this noob in how to set up Marlin for the Mendel. There are some issues I have yet to work out, but I wanted to ask if anybody out there has the configuration file for the Mendel, or can give me guidance in setting up Marlin for it.

Have fun,

Edited 1 time(s). Last edit at 12/01/2017 02:31PM by EZWoodworker.
Re: Mendel firmware
December 01, 2017 10:54PM
Its a standard Cartesian printer... Its not that old.... it has a stepper on the extruder (vs old machines that used a dc motor)

Just follow any of the 1000's of how to set up marlin tutorials

eg watch this []

Edited 1 time(s). Last edit at 12/01/2017 10:54PM by Dust.
Re: Mendel firmware
December 02, 2017 11:18AM
Thank you for your response. Unfortunately, there appears to be more wrong than I first thought. Compiling the off the shelf Marlin works, but not everything works correctly. I had to cut the power when testing because the Z axis went too high. Now nothing works, even compiling per Tom's suggestions. I guess if I want to print, I'll just have to buy a new printer and use this for parts for other projects.
Re: Mendel firmware
December 02, 2017 11:48AM
Still playing with it and I noticed This:

Setting hotend temperature to 185.000000 degrees Celsius.
Setting bed temperature to 60.000000 degrees Celsius.
Error:Heating failed, system stopped! Heater_ID: 0
Errortongue sticking out smileyrinter halted. kill() called!

Although the hotend is at 20 and the bed at 28 according to Pronterface, and this is in Configuration.h:

#define HEATER_0_MINTEMP 5
#define HEATER_1_MINTEMP 5
#define HEATER_2_MINTEMP 5
#define HEATER_3_MINTEMP 5
#define HEATER_4_MINTEMP 5
#define BED_MINTEMP 5

Plus direct readings give 112.8K for the hotend thermistor and 100K for the bed thermistor.

Any idea what is going on?

Edited 1 time(s). Last edit at 12/02/2017 11:53AM by EZWoodworker.
Re: Mendel firmware
December 02, 2017 08:00PM
The firmware thinks there is an issue with heating up your hotend.

It is applying power and checking the temperature its increasing at the expected rate if it doesn't heat up fast enough it presumes there is a issue and stops.

a) there could be an issue with your hotend wiring.,.. or heater (unplug hotend and check the resistance of wires and hotend)
b) your thermistor may have moved away from hotend, so it doesn't read temperature changes fast enough (check its still well attached)
c) you may just need to set the PID see pid tuning []
Re: Mendel firmware
December 03, 2017 02:44PM
a) The resistance of the heating element is 1.7 ohms, and it did heat once when I did a test earlier.
b) The thermistor wires disappear between the insulator sheath and the the heater block, and I am loath to disassemble to find the end.

c) As I get time, I'll try adjusting the heater PID.
Re: Mendel firmware
December 03, 2017 05:08PM
Okay, thanks, the autotuning to get the PIDs worked and that problem is solved. Next to see what else might be a problem.
Sorry, only registered users may post in this forum.

Click here to login