Welcome! Log In Create A New Profile


Hot-Tip issue

Posted by owism8 
Hot-Tip issue
April 29, 2011 10:02AM
Hello All.

I am having a problem reading my temperature using Repsnapper.

I wanted to see maybe this was a firmware issue?

I am using the techzonecom huxley kit. It has a Type K thermocouple wire; This is insulated in a fiberglass braid, it has two wires in there, one wrapped in Yellow the other wrapped in red.

After 45 minutes of warming up the tip and testing if the ABS melts and it does, I tried to print. What happened was that the extruder kept pushing the filament and I guess it wasn't melting, (or maybe the extruder is set too fast?), and that caused the tip to get pushed down to scratch against the print bed.

No damages, just some ripped tape... I followed all directions on the techzone assembly page so im sure I have contact to the tip.

So is this a firmware issue?

Re: Hot-Tip issue
April 29, 2011 02:31PM
What temperature is repsnapper reading from the huxley? What kind of hot end are you using? Are you using the Techzone firmware?
Re: Hot-Tip issue
April 29, 2011 03:27PM
Repsnapper Current temp reading is empty. But the Thermocouple is connected correctly to the board.

The hot end I am using is the one from techzone. You have to wrap the nichrome wires and the thermocouple around the brass tip.

The firmware is also preloaded from techzone.

Re: Hot-Tip issue
April 29, 2011 06:53PM
I think someone already suggested this. Until you're able to read the extruder temperature properly and extrude plastic in the air, you shouldn't try to print anything. I think TZ ships their electronics preloaded with firmware that should work with repsnapper. Make sure that temperature update is enabled in the interactive control.Then try looking at the communication log in the print tab of repsnapper. YOu should see something like the ff being repeated:
Send >> Sending: M105
Send >> Received: ok T: 20 with parameter T:20 *****************

If there are communication errors, repsnapper might not show the temperature even though it's being sent back by the board. The number after T: is the temperature reading.
Re: Hot-Tip issue
April 29, 2011 10:47PM
Hey thank you so much! Yeah i got temp reading! Woohoo! I put it up to 250 and its blackening the plastic yay tongue sticking out smiley

I am now dealing with an issue with skeinforge G code whicih I am trying to print through Repsnapper. My motors are trying to move but they are not One person on the IRC chat suggested the following might be the problem, that skeinforge is trying to push my motors at a speed/torque which my motor cant handle, so he suggested the following: [www.mendel-parts.com]

So Im going to work on that tomorrow.

Gnite reprappers. Please do leave advice!

Re: Hot-Tip issue
April 29, 2011 11:16PM
What version of Skeinforge are you using? I'm sure that the TZ firmware is not compatible with version 40 unless you edit the e_steps_per_mm. In previous versions, this refers to the extruded filament, but in 40 it refers to the feed. You have to make sure that the firmware is consistent with Skeinforge or your extruder will either move to slow and nothing will come out or it will try to move to fast and you'll exceed the torque of the motor and it won't move.
Re: Hot-Tip issue
April 29, 2011 11:47PM
The Skeinforge version is: 11.04.26

So Which version should i use in order to be compatible with TechZone firmware?
Re: Hot-Tip issue
April 30, 2011 01:57AM
I think thats version 41. Like version 40, this version expects the firmware setting for e_steps_per_mm to be in terms of feed, not extruded filament. So, you will need to change your firmware value in order to use this. If you look in the g-code, you will see that the e-values are very small. The filament is not coming out of the hot end because it's not pushing enough feed through. There's a topic in the skeinforge forum about version 40 on how to set the firmware. Please read this: [forums.reprap.org].
Re: Hot-Tip issue
April 30, 2011 08:11AM
Thanks Brnrd,

I'll look into it.

Re: Hot-Tip issue
April 30, 2011 09:30AM
Im having difficulty approaching this.
I looked on the forum here: [forums.reprap.org]
and here: [reprap.org]

but there are no instructions on how to change the firmware to the correct settings.
Could someone send me a firmware file with the correct settings for wades extruder?
Or can I just use the older skeinforge version?
Re: Hot-Tip issue
April 30, 2011 12:03PM
Firmware instructions for Gen 3 electronics is here: [reprap.org].

II'm not sure which electronics you have. But it will show you how to install and use Arduino to edit and load the firmware. Techzone has a downloadable firmware if you go to their website. Download that and then open the Five-D firmware with Aruduino to edit and load it.
Re: Hot-Tip issue
April 30, 2011 07:47PM
I am using the Techzone Monotronics: [www.reprap.org]

Also could I just downgrade to SF39? I'm trying Gcode with Repsnapper and the way its dealing iwth my machine is I think its pushing too much filament too fast and thus causing my tip to smack into the bed everytime.
My temp is fine so thats nto the problem, its the speed at which the extruder is going.

So i figure SF should fix this problem correct, even if its SF 39? I'll post a video of what its doing tonight after I upload it.

Thanks for the help so far Brnrd.
Re: Hot-Tip issue
May 22, 2011 08:15PM
owism8, ever get this working? I'm updating the 20110509 to for the techzone remix boards including their thermocouple. I haven't looke to see how close their monolithic is to those. I've gotten the extruder firmware to compile with their additions, haven't run it yet though. Blocked on some errors in the mainboard firmware. All the options for thermocouples seem to have been removed from config.h, turning off use of a thermisistor causes a compile error. So close.
Re: Hot-Tip issue
May 22, 2011 08:25PM
I did download SF38, but I am still adjusting the numbers in all the gabillion categories tongue sticking out smiley Talk about variables...

SF 38 does work, its just that I changed something and I have no idea what it was. I gotta take it back to defaults and work back again. I was using some guides online and I dunno where i ended up. I tried the calibration files on thingiverse: [www.thingiverse.com] also this one: [www.thingiverse.com]

The only thing I've used so far to print is Techzones website: 3dtoolchain.com , but its been down for two days, so Its not reliable. I need to learn SF.

Its really hard to learn SF because it takes a lot of time. Do you have generic numbers I can pop into SF for the huxley?
Sorry, only registered users may post in this forum.

Click here to login