Welcome! Log In Create A New Profile


MKS GEN L issue uplading firmware

Posted by omrtpsycho 
MKS GEN L issue uplading firmware
March 17, 2019 04:32PM
Hello everyone! I would really appreciate your help!

I am not programmer, I just follow guides and try to make the best of it.

I bought an MKS GEN L v1.0 board in order to replace the old motherboard of my Ender 3 3d-printer. It was supposed to have a bootloader, so the task seemed easy. However, when I tried to upload Marlin on it, I got the following message:

avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

All parameters are correct: board (Arduino Mega), processor (ATMegaA 2560), COM port (COM5, programmer (AVRIS mkll) etc.

I then tried a different pc. Same thing happened.

Then i found a method where I would upload a new bootloader, using an Arduino Uno and the Nick Gammon's Atmega_Board_Programmer. That went well, and the new bootloader seemed to load correctly on the MKS. The I connected the usb cable to the MKS and retried to upload Marlin. Same message: avrdude: stk500v2_ReceiveMessage(): timeout. When ArduinoIDE finishes compiling and tries to upload, a blue led light on the board turns on, and after each timeout, it turns off.....

I am at loss.. I am starting to believe that there is something wrong with the usb port of the board. Is there any way that I try to upload the firmware via the Arduino?

Thank you all....
Re: MKS GEN L issue uplading firmware
March 31, 2019 01:23PM
I'm getting this error when trying to build by pio.
when trying to build 'manually' i'm seeing an LPC1768 Environment error - I need some help to get around this plz.

any help will be greatly appreciated
open | download - ‏‏לכידה.PNG (9.9 KB)
April 01, 2019 04:38AM
I can't get around it and i'm not sure whats causing it, I set the env to a LPC1768 and board to GEN_L,
why am i still getting this error?

Edited 1 time(s). Last edit at 04/01/2019 04:38AM by Of3d.
open | download - LPC1768 env ERROR.png (63.1 KB)
April 01, 2019 04:51AM
Right, first obstacle been passed - had to add to Marlin-bugfix-2.0.x/.pioenvs/LPC1768 new file firmware.bin,
now i'm left only with env LPC1768 ERROR,
any thoughts?
open | download - LPC1768 ERROR.png (119.7 KB)
Re: MKS GEN L issue uplading firmware
April 01, 2019 05:54AM
MKS Gen_L is not a LPC1768 based controller it is a mega2560 based controller.
confused smileyconfused smileyRe: MKS GEN L issue uplading firmware
April 01, 2019 07:35AM
confused smiley

Re: MKS GEN L issue uplading firmware
June 09, 2019 09:29AM

I’m getting this same “timeout” error. I have an Anet A6 with an Anet v1.5 board. The board came without a bootloader so I flashed the board with a USBisp and was able to upload Marlin 1.1.9. I recently purchased a RepRapDiscount full graphic smart controller, when I went in to Arduino IDE to comment everything thing in and reflash, that’s when I get the error...

avrdude: stk500v2_ReceiveMessage(): timeout

Just like the OP states. I’ve tried everything! I can’t flash anything to my board, even my original settings. The weird thing is, I know it communicated with my board because my original Anet 2004 LCD changed the “icons” for my TEMP read out. Another weird thing is, I originally tried uploading with my board set as “Anet v1.0(optiboot)” because I had to originally upload a bootloader, but the IDE always send an error “oops make sure you choose Arduino MEGA for your board. When I switch the board to Arduino MEGA the IDE tries to upload the firmware but comes back with the “timeout” error. I’ve even tried flashing the firmware via the USBisp and the same happens. Luckily the printer still prints so I just gave up until I can get some feedback here. I’m honestly at the point where I’m ready to just purchase the Anet 12864 LCD because I still have to reconfigure the ribbons that came with the RepRapDiscount to make it compatible with the Anet v1.5 board. Any insight would be greatly appreciated, thanks all...
Re: MKS GEN L issue uplading firmware
June 09, 2019 10:58AM

Fairly sure that is a atmega1284p processor... not Arduino MEGA2560

Setting to a board of MEGA also sets the upload baud rate and protocol to

What upload protocol and baud rate your boot loader needs depends on what bootloader you installed

a standard anet aboard needs

and one with optiboot needs

These are set in boards.txt files, not related to baud rates you can set anywhere.

To me it sounds more like you have mucked up the configuration.h you have to set your motherboard to BOARD_ANET_10 then in arduino IDE set the board to Anet v1.0(optiboot)

Edited 3 time(s). Last edit at 06/09/2019 11:02AM by Dust.
Re: MKS GEN L issue uplading firmware
June 13, 2019 11:05AM
Thanks for the reply Dust... I'm sure that somewhere along the way I deffinately mucked something up. My baud rate is correct and oddly, now when I try flashing, Arduino allows me to select the Anet V1.0(optiboot) option in "boards" and it will compile everything. However, when I click upload its now coming back with an error saying, "access to COM4 is denied".

When I got that error I downloaded Repetier Host to see if i could communicate with the printer at all. When I try to connect the host software I get the same error, "access to COM4 port is denied". I'm not exactly sure why. So I went into my devices and removed the printer from my computer so I could reinstall it. After the reinstall I was able to connect to the printer through Repetier Host although I couldn't control the printer, nor wast the printer sending it's info to my computer.

I went back into Arduino IDE and tried to flash again. I got the same access denied error and when I went back to Repetier Host I could no longer connect my computer to the printer (access to COM4 is denied).

I'm guessing that my easiest option is to buy a new motherboard, I wouldnt mind upgrading to the 1.7 version anyway as it has a fuse and the pins will work correctly with the RepRapDiscunt 12864LCD.
Re: MKS GEN L issue uplading firmware
June 13, 2019 11:42PM
Access denied is simply windows being a arsehole (what it does best)

run arduino ide as administrator
Re: MKS GEN L issue uplading firmware
June 22, 2019 08:29AM
Yup, that was the problem. I ended up getting a new board anyway just for the added safety of the fuse and was having the same issue with the V1.7 board. It came to me bricked and when I tried to upload the bootloader same thing. I ended up bypassing the COM and just using my USBISP, but have since gone back and run as Admin and was able to connect. Thanks for your help and time Dust, I truly appreciate it!
Sorry, only registered users may post in this forum.

Click here to login