GTR Marlin Problems
May 10, 2022 11:08AM
This is my first post so I apologize if this is not the place for this or rules not followed correctly etc.

I have had trouble setting up firmware for my 3d printer with a new Bigtreetech GTR motherboard and I was hoping someone here could see what I am doing wrong. It has a 400x400x235 build volume, dual z axis (g34 enabled), all TMC2209 drivers with x/y using sensorless homing, dual extruder with mixing hotend, TFT35 E3 V3.0 touch display, bltouch (UBL 15 grid), and I plan to use a raspberry pi with octoprint through usb. I think I have these settings set up properly but I've only configured marlin for more common boards that have more help online (SKR 1.4 Turbo and a Creality Ender 3 V2 board).

It might just be that I'm doing something wrong with the display settings. From what I've seen I need ports 0 and -1 enabled for the TFT display (I don't need the marlin mode for what I want for what thats worth), but when I enable them both I get errors when compiling;

"error: 'MYSERIAL1' was not declared in this scope; did you mean 'MYSERIAL1'?"
"error: 'MYSERIAL1' was not declared in this scope; did you mean 'MYSERIAL2'?"
"error: request for member 'write' in 'multiSerial', which is of non-class type 'SerialOutputT' {aka 'int'}"

and others similar along with a bunch of yellow prompts that fail the compile. If I just have the first port as -1 it will "successfully" compile without those errors, and definitely loads A firmware onto the motherboard (sd card changes file to firmware.cur instead of bin after trying), but the display never "finds" the printer attached. So I'm hoping its just the display options I have screwed up and someone here can see the issue and set me straight quickly.

If I need to provide any further information or anything like that just let me know and I greatly appreciate any assistance.
open | download - platformio.ini (9.8 KB)
open | download - Configuration.h (108.7 KB)
open | download - Configuration_adv.h (171.9 KB)
Re: GTR Marlin Problems
May 10, 2022 04:38PM
Serial port 0 is not valid for STM32 based controllers.

There would have been hundreds of error messages saying #error "SERIAL_PORT must be from 1 to 6. You can also use -1 if the board supports Native USB." that you have somehow missed.

The serial ports change form motherboard to motherboard and you must look them up in the provided documentation.

This board the TFT is serial port 3

Edited 2 time(s). Last edit at 05/10/2022 06:29PM by Dust.
Re: GTR Marlin Problems
May 20, 2022 03:09PM
That fixed my display issue, thank you.

I am still having a problem I don't understand where when the display connects on startup it gives me messages of "All low" and "eeprom can hold 8 meshes." When I used the other preconfigured firmware I don't get the messages, so again I'm causing the problem with my firmware setup somehow rather than a hardware issue. I tried just slightly moving xyz from the display and they respond like I would expect, but with the error I am not confident to continue further. Hopefully this is another simple mistake I've made. Thanks again.
Re: GTR Marlin Problems
May 20, 2022 08:36PM
Send the machine a M122 ( and examine the result from a control program

This will tell you is if all stepper drivers or just one.

Important. You need the external power supply on to initialize tmc2209's

Ie don't just power the controller from USB

Edited 2 time(s). Last edit at 05/20/2022 08:51PM by Dust.
Re: GTR Marlin Problems
May 20, 2022 08:37PM
"eeprom can hold 8 meshes" is just a message that you have sufficient space in your eeprom to save up to 8 different meshes
Re: GTR Marlin Problems
May 26, 2022 08:19PM
I tried doing an m122 in pronterface and got the response I will paste in next.

>>> m122
X Y Z Z2 E
Address 0 0 0 0 0
Enabled false false false false false
Set current 800 800 800 800 800
RMS current 1436 1436 1436 1436 1436
MAX current 2025 2025 2025 2025 2025
Run current 25/31 25/31 25/31 25/31 25/31
Hold current 12/31 12/31 12/31 12/31 12/31
CS actual 0/31 0/31 0/31 0/31 0/31
PWM scale
vsense 0=.325 0=.325 0=.325 0=.325 0=.325
stealthChop false false false false false
msteps 256 256 256 256 256
interp false false false false false
tstep 0 0 0 0 0
PWM thresh.
OT prewarn false false false false false
OTP false false false false false
pwm scale sum 0 0 0 0 0
pwm scale auto 0 0 0 0 0
pwm offset auto 0 0 0 0 0
pwm grad auto 0 0 0 0 0
off time 0 0 0 0 0
blank time 16 16 16 16 16
-end -3 -3 -3 -3 -3
-start 1 1 1 1 1
Stallguard thrs 8 8 0 0 0
uStep count 0 0 0 0 0
sg_result 0 0 0 0 0
stst * * * * *
Driver registers:
X 0x00:00:00:00 Bad response!
Y 0x00:00:00:00 Bad response!
Z 0x00:00:00:00 Bad response!
Z2 0x00:00:00:00 Bad response!
E 0x00:00:00:00 Bad response!
Testing X connection... Error: All LOW
Testing Y connection... Error: All LOW
Testing Z connection... Error: All LOW
Testing Z2 connection... Error: All LOW
Testing E connection... Error: All LOW

I did have to adjust my marlin config beforehand because I didn't have the expanded details enabled initially. It still shows as "All LOW" and gives the "Bad response" for the drivers (while troubleshooting I did drop the configuration to just one extruder from what I started with until I figure out what I'm doing wrong to cause this driver error because I'm more familiar with the single nozzle/extruder setup). I noticed that it lists stealthchop as false for all of them but it is actually enabled in my config files. Again the motors are actually responding to the just "move" commands through the display, and when I use a preconfigured for a base GTR board it doesn't give me the error (refuses to connect to my computer with the preconfigured firmware so I can't do an m122 for that to compare).

Unfortunately I don't know enough about this output to tell me why it is unhappy other than the last portion with all the bad responses and errors but for me it just lets me know there is a problem, not why.

I have been running it through the power supply, not just USB though so that shouldn't be part of the problem.

Any ideas or direction for further documentation you know of that might help me?
Re: GTR Marlin Problems
May 26, 2022 09:54PM
It tells us that all tmc2209's are not talking.

Since all the tmc2209's are on separate uart pins and not shared its unlikely to be a marlin issue

Much more likely you have a hardware issue

Check you have the jumpers set as follows

Also not all tmc2209 stepper driver are equal. They need to use this following pin for uart communications

Also the TMC2209's modules themselves need to be configured for UART mode.
What type/brand of TMC2209's do you have?

Edited 1 time(s). Last edit at 05/26/2022 11:38PM by Dust.
Re: GTR Marlin Problems
July 02, 2022 10:58PM
Its super late that I am following up on this but things got busy and I didn't have as much time to work with this so it was progressing in small stages. I was able to get past the problems I was having with your last messages, I did miss those pins. I had some other unrelated weird things I was trying to figure out myself before coming back here and now I finally have this thing up and running again. So far haven't gone through how to properly use the mixing extruder setup with a slicer and all, but it seems to be happy with how it is setup and running properly fine otherwise.

The issue is resolved now, but since I hadn't answered yet. I had had the TMC2209's working on my skr1.4 pro board before all this and they are bigtreetech v 1.2s.

Thanks again for all your help.
Sorry, only registered users may post in this forum.

Click here to login