Welcome! Log In Create A New Profile


Issue with Eclipse build for RRF2.05.1

Posted by RL_berk 
Issue with Eclipse build for RRF2.05.1
June 06, 2023 04:12PM
I am attempting to build RRF2.05.1 from Duet3D. I downloaded from the duet3 github, imported to eclipse (version 2018-09) and had some errors, worked through most of them but am stuck on one in particular. The error is line 353 of RRFLibraries/src/RTOSIface/RTOSIface.h which is the following:


error is:
'is_always_lock_free' is not a member of 'std::atomic_uint8_t {aka std::atomic}'

I looked up the error and the function exists for c++17 and newer, I tried adding -std=c++17, -std=c++11, and -std=c++20 to the Cross GCC Compiler/Miscellaneous/Other flags and to Cross G++ Compiler/Miscellaneous/Other flags found in Properties/C/C++ Build/Settings/Tool Settings. I also tried freshening and rebuilding the eclipse index, and restarting. There are other errors present, but they are all make errors or recipe for target failed, and I am assuming they are because of the above described error. Thanks in advance for help.

EDIT: Uninstalled and Reinstalled. Worked fine after that.

Edited 1 time(s). Last edit at 06/06/2023 06:34PM by RL_berk.
Sorry, only registered users may post in this forum.

Click here to login