(solved) Gen 7, Repetier, Pronterface, power supply not turning on
February 25, 2012 02:20AM
Here's the problem,

Like the topic says, I have a Gen 7 1.3 with repetier firmware and pronterface host. I can upload firmware and connect to printer. But when I send M80 to turn on power supply the LED (signifying power supply on) lights up and fades out immediately. I tried Repetier host and had the same result. When trying pronterface I commented out the lines shown in the repetier firmware directions. The Gen 7 test firmware works fine (turns on power supply, blinks light and turns off power supply). I also tried teacup firmware and was still not able to turn on power supply (M190 for teacup).

Any ideas?

Thanks ahead

Edited 1 time(s). Last edit at 02/25/2012 12:35PM by miro87043.
Re: Gen 7, Repetier, Pronterface, power supply not turning on
February 25, 2012 04:04AM
Normally the power supply reacts on different signals like floating input to disable it. I made an update to version 0.50 where I changed the power initialization to the method used in the gen7 test firmware. So with the new Repetier-Firmware your supply should work.

I also added a define to enable power on startup (ENABLE_POWER_ON_STARTUP) so with this set, you shouldn't need to call M80.


Repetier-Software - the home of Repetier-Host (Windows, Linux and Mac OS X) and Repetier-Firmware.
Repetier-Server - the solution to control your printer from everywhere.
Visit us on Facebook and Twitter!
Re: Gen 7, Repetier, Pronterface, power supply not turning on
February 25, 2012 11:59AM
I tried the update and my power supply still won't turn on.
Re: Gen 7, Repetier, Pronterface, power supply not turning on
February 25, 2012 12:06PM
Have you tried M80 and M81 to turn power on? Did you twice M80? (someone wrote he needed to send it twice to work, also I don't see why this should help=.
M81 does the opposite to M80, just in case your atx want's it the other way.

I've also read something about a basic load needed for the atx to work. Have none, so I'm not really the expert for this.


Repetier-Software - the home of Repetier-Host (Windows, Linux and Mac OS X) and Repetier-Firmware.
Repetier-Server - the solution to control your printer from everywhere.
Visit us on Facebook and Twitter!
Re: Gen 7, Repetier, Pronterface, power supply not turning on (solved)
February 25, 2012 12:35PM
No load, was the problem. I plugged a fan in and it turned on!

Thanks a million!!
Sorry, only registered users may post in this forum.

Click here to login