Welcome! Log In Create A New Profile


Teacup Problems-issues

Posted by caslor 
Teacup Problems-issues
May 27, 2017 12:14PM
i am running as small 3d printer i made with Teacup Firmware Branch-Master
I tried to use my 3d printer with Repetier-Host but had a lot of issues so i am testing it with Pronterface that works ok

With pronterface

i have some issues

1) some times for no reason it looses steps

Arduino uno R3 Board
CNC shield V3
A4988 stepper Drivers
28BYJ-48 5v stepper motors
Baud rate : 115200

my settings are slow enough because of these small motors

* Accelaration Type :Ramping
* Acceleration : 200
without LookAhead as i had to have different stepps for X and Y axes and LookAhead doesnt support that yet

* Maximum Jerk : 5
* Movebuffer size : 8

* Maximum Feedrate x,y : 1000
* Absolute E Coordinates

2) Heater problem

my settings for Hotend Heater (i dont have heated bed) are

* Fast pwm
* Heater Sanity check
* Report target temparatures
* Temperature History Size : 8
* Pid Scallin Factor : 1024L
* Temperature Hysteresis : 10
* Temperature Residency time : 60
* Temperature EWMA : 1000

Before start printing the gcode file.. and with the printer connected to the pronterface i can read temperatures from thermistor

when i press to print and the Gcode sends commant to start heating element.... it start heating but the temperature reading freeze.. so i am reaching higher temperatures than the target temp
That only if i select to print. If i just set a temperature manualy from pronterface control panel and select to heat.. then everything work fine.. the element start heating and receiving all the time the temperature from thermistor.. and when it reach target temp switch off mosfet that controls the heater

also i notice that if i havent select the '' Heater Sanity check'' then the heater overcomes the target temp as it is switched on all the time but with '' Heater Sanity check'' the mosfet witching on and off and so heating is more controlled

notice that i have setup configuration pins of my Arduino that the pin for heater be the DI010 that supports PWM signals
I have tried and the default Analog pin for controling the mosfet for the heater but didnt have good results in controling the temperature ... the mosfet was staying on longer

screenshots from settings in Teacup :

Edited 2 time(s). Last edit at 05/27/2017 12:17PM by caslor.
Re: Teacup Problems-issues
May 27, 2017 02:25PM
Ok i find what make freeze the temperature reading

is the M116 command in Gcode (M116 ; wait for temperature to be reached )

But why and what can be done to fix that ? for now i have disable this command just to make printer continue printing for test proposes (without filament.. just to watch stepper movements )

Also i noticed that i am loosing stepps in motors when in the pronterface preview window of ''current layer movement'' freeze for a while before loads the next layer...
when doing that the printer stops until has the new layer on but then it prints out of the original coordinates that the previous layers were

i am not using an sd card... only from pc (linux - ubuntu 16.04)

what settings have i wrong ?
Re: Teacup Problems-issues
June 19, 2017 12:21PM
Hello caslor, sry I cannot help u on that at all but I can use your help plz. I made also a 3d printer using uno and cnc shield and teacup but I'm having problems on how to connect the thermistor and the heater can u plz send me a photo of how u wire them or just tell me? I saw u said that u plugged in the heater on DIO10 but that is pin for the stepper for me also isn't better for mosfet to be on analog pin? last question is how did u managed to changed the declared pin on teacup for the heater cause on mine it doesn't let me choose anything else than the default one AIO2.Thank you in advance.
Re: Teacup Problems-issues
July 10, 2017 03:58PM
I have the same problem too with pronterface does any1 know how to fix that freezing between layers? for the temp problem I have just remove the gcodes as caslor did too. plz reply.
Re: Teacup Problems-issues
August 14, 2017 07:20AM
Try my branch.
it can work with repetier, and have EEPROM settings for commonly used like step/mm, max feedrate

Sorry, only registered users may post in this forum.

Click here to login