Welcome! Log In Create A New Profile


Teacup Wont launch

Posted by SunixDev 
Teacup Wont launch
August 10, 2017 03:39PM

So if i start this topic , its because i'm facing a big problem, i'm trying to launch
Teacup configtool.py but i'm stug getting the same error

========= RESTART: C:\RepRap\firmware\Teacup_Firmware\configtool.py =========

Traceback (most recent call last):
File "C:\RepRap\firmware\Teacup_Firmware\configtool.py", line 185, in
File "C:\RepRap\firmware\Teacup_Firmware\configtool\gui.py", line 615, in StartGui
frame = ConfigFrame(settings)
File "C:\RepRap\firmware\Teacup_Firmware\configtool\gui.py", line 72, in __init__
self.pgPrinter = PrinterPanel(self, self.nb, self.settings)
File "C:\RepRap\firmware\Teacup_Firmware\configtool\printerpanel.py", line 47, in __init__
self.pgMech = self.registerPage(MechanicalPage, "Mechanical")
File "C:\RepRap\firmware\Teacup_Firmware\configtool\printerpanel.py", line 59, in registerPage
font = self.settings.font, **kwargs)
File "C:\RepRap\firmware\Teacup_Firmware\configtool\mechanicalpage.py", line 50, in __init__
sz.AddSpacer((10, 10), pos = (0, 0))
TypeError: Sizer.AddSpacer(): argument 1 has unexpected type 'tuple'

Here is my windows CMD log windows
I have tryed many python version but no result (2.7.11 and 2.7.13)
and wxPython look installed and on winows 10 OS


Edited 1 time(s). Last edit at 08/10/2017 03:39PM by SunixDev.
Re: Teacup Wont launch
August 11, 2017 04:19AM
cant reproduce... windows 10, 64bit, fully pactched...

downloaded [www.python.org]
followed by [newcontinuum.dl.sourceforge.net]

made sure it used correct python by changing into directory with teacup and lanuching with c:\Python27\python.exe configtool.py

Edited 1 time(s). Last edit at 08/11/2017 04:22AM by Dust.
Re: Teacup Wont launch
August 11, 2017 04:29AM
Also check you video device drivers are up to date. Windows 10 seems to just forget to update them...

Select the Start button, type Device Manager, and select it from the list of results.
Expand one of the categories to find the name of your video device, then right-click (or tap and hold) it, and select Update Driver. ...
Select Search automatically for updated driver software.
Re: Teacup Wont launch
August 14, 2017 02:11AM
This problem was solved [github.com]
You need to install wx not with pip. [wiki.wxpython.org]

Triffid Hunter's Calibration Guide --> X <-- Drill for new Monitor Most important Gcode.
Re: Teacup Wont launch
July 08, 2019 07:24PM
I realize this is a bit of an old topic but I'm having the same issues as OP. The fix they have on github doesn't quite seem to work either since the links provided to install wxpython without pip just direct to a page for installing it with pip. Has anyone else had that issue or know how to do what they recommend? I'm unsure how to install it without pip (or even how to uninstall it first so as to re-install).

Sorry, only registered users may post in this forum.

Click here to login