Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 21, 2020 10:51AM
RC9 is now available here:
[github.com]

Tagged repos:
[github.com]
[github.com]
[github.com]
[github.com]
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 21, 2020 11:03AM
And just to point out that conditional gcode is now implemented on the SBC supported version of RRF,


Based in Darlington, North East
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 21, 2020 11:28AM
@jay_s have you tried it at all Jay? I've only tested the basics with the LPC build so far.
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 21, 2020 11:34AM
@gloomyandy

I use it on my Delta running a clone duet 2.
Not got round to testing on an SBC based system yet.


Based in Darlington, North East
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 21, 2020 01:14PM
@gloomyandy

The latest DSF 2.1.0 aren't showing in your LPC-DEV branch on github.
They are only showing under the tag name but not in the branch so its making it slightly difficult to clone the correct version.
Any chance you could look into this


Based in Darlington, North East
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 21, 2020 03:16PM
Should be fixed now, git provides so many ways for me to screw things up!
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 21, 2020 05:31PM
That's sorted it. Thanks


Based in Darlington, North East
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 22, 2020 05:38AM
Hi @gloomyandy,

I was playing with the last RC8, it works right but I have an issue when changing any parameter in config.g by the browser, as you know it tells you to reset the board when pushing "save", the "DCS disconnected" warning appears (normal) and in some seconds the connection is established but the SKR never returns to live, no response to any command (temps are the old ones, homing doesn't work, etc.); I have to push the hardware reset on SKR to return at working condition.
It's not a big deal but could be annoying in some cases.

The same happens with the emergency stop, it never recovers at all.

Kind regards.
Chema

Edited 2 time(s). Last edit at 04/22/2020 05:53AM by ChemaFuji.
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 22, 2020 06:02AM
@ChemaFuji

I'm pretty sure thats fixed with RC9


Based in Darlington, North East
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 22, 2020 06:26AM
Yep that was a common RC8 problem (not LPC specific) and it seems to be fixed with RC9.
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 22, 2020 06:34AM
Many thanks! I would upgrade just now...
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 25, 2020 07:20PM
Hello, ive been using for a while rrf 2 port from sdavi on my delta with mks sbase 1.3

Yesterday i tried latest rrf 3 RC9 but i couldnt get mapped my zprobe (currently using a switch connected to zmin pin on rrf 2).

tried to map my zmin as an endstop to test if worked and it did. (also tried an endstop as my zprobe and didnt work)

Any ideas about how to configure it? everything else just working but cant calibrate my printer so i reverted to rrf2.

This is my current line on rrf 2: M558 P4 C"5" H5 F600 T6000 (pin 5 because is how i defined zmin in board.txt)
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 25, 2020 10:40PM
Just started fooling around with a MKS Sbase board and RRF. I found that the M552 P192.168.1.18 S1 which I have in my config.g is ignored and I need to send this with a USB serial connection in order to have networking work. This is with gloomyandy's RC9 RRF version and DWC 2.1.3. FYI connection is a wired connection not wifi. Once I send the appropriate M552 command, everything works.
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 26, 2020 01:41AM
@darchap

The pin names got standardised a while back and can be found here. [github.com]
Rather than C"5", use C"Zstop" or C"Zmin"


Based in Darlington, North East
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 26, 2020 01:42AM
@cd_edwards

Try moving your M552 command to the end of your config file.


Based in Darlington, North East
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 26, 2020 07:15AM
RC10 is now available:
[github.com]

Please note that the reported version number will be RC9+1, but it is RC10.

Tagged Repos here:
[github.com]
[github.com]
[github.com]
[github.com]
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 26, 2020 08:02AM
Quote
jay_s
@darchap

The pin names got standardised a while back and can be found here. [github.com]
Rather than C"5", use C"Zstop" or C"Zmin"

Yeah C"5" is what i had on my rrf2 config.g. for yor build i tried ZMin but didnt work, now i also tried Zstop but same thing.

This is my current config:

; Endstops
M574 X2 S1 P"!XMax" ; configure active-high endstop for high end on X via pin !XMax
M574 Y2 S1 P"!YMax" ; configure active-high endstop for high end on Y via pin !YMax
M574 Z2 S1 P"!ZMax" ; configure active-high endstop for high end on Z via pin !ZMax

; Z-Probe
M558 P4 C"Zmin" H5 F600 T6000 ; set Z probe type to switch and the dive height + speeds ALSO TRIED ZSTOP
G31 P500 X0 Y0 Z15.9 ; set Z probe trigger value, offset and trigger height
M557 R80 S20 ; define mesh grid

Note that my zprobe is not inverted. Ie if i config my x endstop as this M574 X2 S1 P"Zmin" and trigger my zprobe it works fine but this M558 P4 C"!Xmax" H5 F600 T6000 dont work.

I dont know what i missing. Thanks!
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 26, 2020 08:24AM
Quote
darchap

; Z-Probe
M558 P4 C"Zmin" H5 F600 T6000 ; set Z probe type to switch and the dive height + speeds ALSO TRIED ZSTOP
G31 P500 X0 Y0 Z15.9 ; set Z probe trigger value, offset and trigger height
M557 R80 S20 ; define mesh grid

Note that my zprobe is not inverted. Ie if i config my x endstop as this M574 X2 S1 P"Zmin" and trigger my zprobe it works fine but this M558 P4 C"!Xmax" H5 F600 T6000 dont work.

I dont know what i missing. Thanks!

As per the documentation [duet3d.dozuki.com] probe type 4, 6 and 7 are no longer supported in RRF3. Use type 5 (digital filtered) or 8 (digital unfiltered) instead.
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 26, 2020 10:23AM
Quote
jay_s
@cd_edwards

Try moving your M552 command to the end of your config file.

Moved it to the very end and still the same..

T0
M552 P192.168.1.18 S1 ; IP address
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 26, 2020 11:13AM
@cd_edwards You could try putting a short delay in before the M552 to see if that helps. Try a G4 P5000 or something like that?
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 26, 2020 11:28AM
[prntscr.com]

This really weird. I am using the latest version from gloomyandy rc9+1.
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 26, 2020 11:38AM
@cd_edwards

Is the correct board being reported in M122?


Based in Darlington, North East
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 26, 2020 11:39AM
Deleted.

Edited 2 time(s). Last edit at 04/27/2020 01:12AM by Micktol.
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 26, 2020 11:52AM
fix my issues. seems config.g was not being read at all. also reinstalled the board.txt file which fixed the problem with the wrong board being used.
notice the lack of a missing ; on the three lines which caused config.g to quit immediately and therefore nothing was being configured.
Thanks for the headsup on the board jay_s.



; Configuration file for factory testing Duet Ethernet and Wifi with V2.02 firmware

*******************************************************************************************************************
FOR TESTING ONLY! USE [configurator.reprapfirmware.org] to generate configuration files for your printer!
*******************************************************************************************************************


; Communication and general
M111 S0 ; Debug off
M550 PDuetTest ; Machine name and Netbios name (can be anything you like)
M551 Preprap ; Machine password (used for FTP)
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 26, 2020 07:21PM
Quote
sdavi
Quote
darchap

; Z-Probe
M558 P4 C"Zmin" H5 F600 T6000 ; set Z probe type to switch and the dive height + speeds ALSO TRIED ZSTOP
G31 P500 X0 Y0 Z15.9 ; set Z probe trigger value, offset and trigger height
M557 R80 S20 ; define mesh grid

Note that my zprobe is not inverted. Ie if i config my x endstop as this M574 X2 S1 P"Zmin" and trigger my zprobe it works fine but this M558 P4 C"!Xmax" H5 F600 T6000 dont work.

I dont know what i missing. Thanks!

As per the documentation [duet3d.dozuki.com] probe type 4, 6 and 7 are no longer supported in RRF3. Use type 5 (digital filtered) or 8 (digital unfiltered) instead.

Thanks, that worked!!
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 27, 2020 04:56AM
Hi!

I have trouble configuring SKR 1.4 Turbo. I tried rc 8 9 and 10. I have tried board.txt from wiki + files from either configurator or from the github repository. They both don't work for me but their weird combination at least lets me get M122 output. Other things still don't work.

I have Ender 3 Pro and raspberryPi 4B.

Here is the code that lets me M122. Further I pasted snapshot of codes from wiki, configurator and repository.

//////////////////////
//config from the wiki

//Config for BIQU SKR v1.4
lpc.board = biquskr_1.4
8266wifi.lpcTfrReadyPin = 1.30
8266wifi.espResetPin = 1.31
sbc.lpcTfrReadyPin = 0.28
adc.prefilter.enable =true



//////////////////////////////////////////////////
//config [jaysuk.github.io]

// Board Hardware configuration file for SKR v1.4
// generated by RepRapFirmware Configuration Tool (LPC Version) v2 
// on Sun Apr 19 2020 10:39:32 GMT+0200 (Central European Summer Time)

//Note: Each line should be less than 120 characters.
//    : Unwanted options can be commented out or set to NoPin. Lines commented out will get default values
//    : for pins the default is NoPin.
//    : Values for Arrays need to be contained within { and }
//    : Comments can be defined with // or # (comments are not supported inside arrays)
//    : Each config entry must be all on a single line.

//LED blinks to indicate Platform is spinning or other diagnostic 
//Comment out or set to NoPin if not wanted.
leds.diagnostic = 1.18; 

//Internal SDCard SPI Frequency.
//lpc.internalSDCard.spiFrequencyHz  = 25000000;


//heat.tempSensePins = {bedtemp, e0temp}; //Max of 3 entries
/////////////??????????no entries?????///////////// heat.spiTempSensorCSPins = { }; //Max of 2 entries

	 


//	///////////////////////////////////////////
//	//Alternative, github recommended config///
//	//SKR v1.4 
//
//	//                      Drive        0     1     2     3     4 
//	//                    Typically      X     Y     Z     E0    E1
//	stepper.enablePins =               {2.1, 2.8,  0.21, 2.12, 0.10};
//	stepper.stepPins =                 {2.2, 0.19, 0.22, 2.13, 0.1};    
//	stepper.directionPins =            {2.6, 0.20, 2.11, 0.11, 0.0};
//	stepper.hasDriverCurrentControl = false; 
//
//
//	//RRF equiv     X     Y     Z     E0    E1
//	//RRF C Index   0     1     2     3     4
//	endstop.pins = {1.29, 1.28, 1.27, 1.26, 1.25}; //X, Y, Z, E0, E1 Endstops
//
//	//                    Bed   E0    E1
	heat.tempSensePins = {0.25, 0.24, 0.23}; //tb, th0, th1
	heat.heatOnPins =    {2.5, 2.7, 2.4}; //hbed, he0, he1
//
//	// Z Probe pin
//	// Probe pin can be NoPin and select from an "EndStop Pin" (which are digital input)
//	// using the C parameter of M558. 
//	// Note: Expected to be an ADC pin for certain modes, if needed then a spare A/D capable pin
//	// should be used and set zProbe.pin below. Beware that pins configured for ADC are **NOT** 5V tolerant
//	zProbe.pin = 0.10;
//	zProbe.modulationPin = NoPin
//
//	// Fan PWM pins. If not assigned pin does not support HWPwm, or HWPWM not running at desired fan RPM, 
//	// then also add to Timers array below
//	// Current maximum of 2 fans supported
	fan.pins = {2.3}; //cooling fan

	lpc.slowPWM.pins = {2.5}; 
	lpc.slowPWM.frequencyHz = 10; //10Hz (for Bed PWM)
	lpc.fastPWM.pins = {2.7, 2.4};
	lpc.fastPWM.frequencyHz = 250; //250Hz (for Hotend/Fan PWM)

	lpc.servoPins = {2.0};
	specialPinMap = {2.0};

	//Only supports 1 External SDCard
	externalSDCard.csPin         = 0.16;
	externalSDCard.cardDetectPin = 1.31;

	lpc.externalSDCard.spiFrequencyHz  = 4000000;
	lpc.externalSDCard.spiChannel = 0;

config from the wiki
//Config for BIQU SKR v1.4
lpc.board = biquskr_1.4
8266wifi.lpcTfrReadyPin = 1.30
8266wifi.espResetPin = 1.31
sbc.lpcTfrReadyPin = 0.28
adc.prefilter.enable =true

config from LPC configurator
// Board Hardware configuration file for SKR v1.4
// generated by RepRapFirmware Configuration Tool (LPC Version) v2 
// on Thu Apr 23 2020 11:00:42 GMT+0200 (Central European Summer Time)

//Note: Each line should be less than 120 characters.
//    : Unwanted options can be commented out or set to NoPin. Lines commented out will get default values
//    : for pins the default is NoPin.
//    : Values for Arrays need to be contained within { and }
//    : Comments can be defined with // or # (comments are not supported inside arrays)
//    : Each config entry must be all on a single line.

lpc.board = biquskr_1.4; 

//LED blinks to indicate Platform is spinning or other diagnostic 
//Comment out or set to NoPin if not wanted.
leds.diagnostic = 1.18; 

//Internal SDCard SPI Frequency.
lpc.internalSDCard.spiFrequencyHz  = 25000000;

//Only supports 1 External SDCard
//externalSDCard.csPin               = 0.16;
//externalSDCard.cardDetectPin       = 1.31;
//lpc.externalSDCard.spiFrequencyHz  = 4000000;
//lpc.externalSDCard.spiChannel  = 0;

//LCD Pins (only ST9720 SPI currently supported)
//setup the Software SPI Pins for LCD
lpc.softwareSPI.pins = {1.20, NoPin, 1.18}; //Set to GPIO pins to use as SCK, MISO, MOSI
lcd.spiChannel =     2;
lcd.lcdCSPin =       1.19;
lcd.lcdBeepPin =     1.30;
lcd.encoderPinA =    3.26;
lcd.encoderPinB =    3.25;
lcd.encoderPinSw =   0.28; //click
lcd.lcdDCPin =       NoPin;  //DataControl Pin (A0) if none used set to NoPin
lcd.panelButtonPin = NoPin; //Extra button on RRD Panel


heat.tempSensePins = {bedtemp, e0temp}; //Max of 3 entries
//heat.spiTempSensorCSPins = { }; //Max of 2 entries

config from github repository

Edited 2 time(s). Last edit at 04/27/2020 05:05AM by rudenick.
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 27, 2020 05:31AM
@rudenick

Can I confirm that you are looking to connect a raspberry pi to the SKR and use it in LPC mode?
Have you ran through the sections of the wiki detailing how to setup the pi image, update to the latest DWC version and then deploy gloomyandy's modifications?
Are you using the correct resistors inline with the connections?
How are you getting the M122 information? Through USB?


Based in Darlington, North East
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 27, 2020 05:35AM
I'm getting M122 ( in Duet web interface) through gpio pin connection with soldered R100 resistors. Gold ribbon on the resistor points towards SKR motherboard. USB cable is not connected.

More info, I'm using TMC2209 steppers in UART.

Edited 2 time(s). Last edit at 04/27/2020 05:41AM by rudenick.
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 27, 2020 05:37AM
so you're getting the DWC interface and executing the M122 through that?

Do you have a copy of the output of M122?


Based in Darlington, North East
Re: RepRapFirmware 3.0 port for LPC1768/9 based boards
April 27, 2020 05:43AM
Yes, here it is:

=== Diagnostics ===
RepRapFirmware for LPC176x based Boards (biquskr_1.4) version 3.01-RC9+1 running on LPC176x at 120Mhz
Used output buffers: 1 of 16 (10 max)
=== RTOS ===
Static ram: 3760
Dynamic Memory (RTOS Heap 5): 3520 free, 3496 never used
Exception stack ram used: 200
Never used ram: 484
Tasks: HEAT(blocked,1484) MAIN(running,1768) IDLE(ready,84)
Owned mutexes:
=== Platform ===
Last reset 00:00:13 ago, cause: [power up]
LPC Flash Slot[126]: 
Last software reset at 2020-04-23 14:00, reason: User, spinning module LinuxInterface, available RAM 476 bytes (slot 0)
Software reset code 0x0010 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0042a000 BFAR 0xe000ed38 SP 0x10000008 Task 0x4e49414d
Stack: 40088000 40088000 0004357d 40088000 4002c000 50004120 00000000 88000004 0000d001 00000001 0003eaf1 
Error status: 0
Driver 0: standstill, read errors 0, write errors 0, ifcount 6, reads 50, timeouts 0
Driver 1: standstill, read errors 0, write errors 0, ifcount 6, reads 50, timeouts 0
Driver 2: ok, read errors 0, write errors 0, ifcount 0, reads 0, timeouts 56
Driver 3: standstill, read errors 0, write errors 0, ifcount 6, reads 50, timeouts 0
Driver 4: ok, read errors 0, write errors 0, ifcount 0, reads 0, timeouts 55
Date/time: 2020-04-27 10:43:05
Slowest loop: 3.28ms; fastest: 0.26ms
=== Move ===
Hiccups: 0, FreeDm: 100, MinFreeDm: 100, MaxWait: 0ms
Bed compensation in use: none, comp offset 0.000
=== DDARing ===
Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0  CDDA state: -1
=== Heat ===
Bed heaters = -1, chamberHeaters = -1
=== GCodes ===
Segments left: 0
Movement lock held by null
HTTP* is ready with "M122" in state(s) 0
Telnet is idle in state(s) 0
File is idle in state(s) 0
USB is idle in state(s) 0
Aux is idle in state(s) 0
Trigger* is idle in state(s) 0
Queue is idle in state(s) 0
LCD is idle in state(s) 0
SBC is idle in state(s) 0
Daemon* is idle in state(s) 0
Autopause is idle in state(s) 0
Code queue is empty.
=== Linux interface ===
State: 0, failed transfers: 0
Last transfer: 7ms ago
RX/TX seq numbers: 299/300
SPI underruns 0, overruns 0
Number of disconnects: 0
Buffer RX/TX: 0/0-0

=== Duet Control Server ===
Duet Control Server v2.1.1.0
Code buffer space: 2048
Configured SPI speed: 8000000 Hz
Full transfers per second: 30.07
Sorry, only registered users may post in this forum.

Click here to login