Welcome! Log In Create A New Profile


RepRapFirmware for LPC1768/1769 compile errors

Posted by DocRaptor 
RepRapFirmware for LPC1768/1769 compile errors
July 17, 2020 01:15PM
I tried to compile the RepRapFirmware for LPC, but I always have errors when I try to compile it. I use Visual Code Studio with windows arm-none-eabi and PlatformIO (disabled in the moment). I tried al lot of branches from the git-reposetory from gloomyandy, but it always fails. The error is:

Building RepRapFirmware for LPC1768/1769 based boards:
- Build: Debug
- Linker Script used: ./CoreLPC2/variants/LPC/linker_scripts/gcc/LPC17xx_smoothie_combined.ld
- SBC Interface Enabled
- Smart Drivers: TMC22XX
process_begin: CreateProcess(NULL, mkdir -p build/./CoreLPC2/cores/arduino/, ...) failed.
make (e=2): Das System kann die angegebene Datei nicht finden. // IN ENGLISH: the system cannot find the file specified
make: *** [makefile:162: build/./CoreLPC2/cores/arduino/wdt.o] Error 2
The terminal process "C:\Windows\system32\cmd.exe /d /c make all" terminated with exit code: 2.

What do I wrong?
Re: RepRapFirmware for LPC1768/1769 compile errors
July 17, 2020 01:43PM
Looks like your system does not have a mkdir command installed (or at least there is not one in your path). You either need to install mkdir on your system or edit the makefile and set MKDIR appropriately.

Is there a reason why you are building your own version of the firmware?
Re: RepRapFirmware for LPC1768/1769 compile errors
July 17, 2020 06:06PM
I added mkdir in to the path-variable of my windows from my git-install, but I still have the error.
I want be abble to compile the reprapfirmware for potential custom boards and maybe some mods if needed. I normally use Marlin, but I need to compile it every time I make a change and that is annoying. Currently I use Marlin on my on custom board with a STM32F103. The STM32F103 line is cheap (sometimes they are cheaper than the atmega2560), powerful and don't need as many external components (capacitor for example) like the atsam3x8e (and it is available from 32 to 144 pin packages). But there is only Marlin for the STM32F103, nothing else. But for the LPC1768/1769 there is RepRapFirmware, Marlin and Smoothiware. So I'm thinking about switching to the LPC176x line (even though I really like the STM32F103) and thats why.
Re: RepRapFirmware for LPC1768/1769 compile errors
July 18, 2020 02:13AM
If you are still getting the same error then you still have the same problem. Did you restart vscode after changing the path? Can you run mkdir in a vscode terminal window? Do you have some sort of command line environment (like git-bash)? You should be able to run the make command in that environment (but you may need to make sure that the compiler is setup correctly for use in that environment).
Re: RepRapFirmware for LPC1768/1769 compile errors
July 18, 2020 05:38PM
Now it starts to work after restarting VScode and disableing Platformio complettly.
Sorry, only registered users may post in this forum.

Click here to login