Welcome! Log In Create A New Profile


SKR 1.4T+TFT35v3+RRF 3.1.1-14+BLTouch+TMC2209 Weird Problem

Posted by h3ndrix 
SKR 1.4T+TFT35v3+RRF 3.1.1-14+BLTouch+TMC2209 Weird Problem
December 10, 2020 02:47PM

After a few days of daunting work I was able to upgrade my sidewinder x1 V4.0 to a spec thats mentioned in the title. However, I have a weird problem that I can not find an answer for and I did do the search on various sites and forums.

The problem was there with the original 2.8” LCD that came with the sidewinder but, I thought, it might go away with the TFT35 from BTT, it didnt. Here is a brief explanation and I can provide my config and board.txt if needed.

I was able to update the TFT35 from thro42’s github fork and it looks really nice and everything seems to work except the motor moves. What I mean by that is, when I start up the printer and do a home, everything works, the 2209 sensorless homing works on the X and Y and Bltouch works on the Z and the homing concludes. However, when I try and move any axis by any amount from the touchscreen, nothing happens and any other command from the touchscreen from that point on do not seem to register. I can navigate the touchscreen but, cant command anything UNTIL, which is interesting, I go into “MENU”,”SETTINGS”, then “DISCONNECT” then touch the screen to go out of disconnect and then everyhting starts working again and commands that I gave when I was trying to move the axes start executing one by one, like they were stuck somewhere and now they are not.

I tried to follow every instruction given by gloomyandy and tried to do the right setup but, cant figure this one out and would appreciate the help. Thanx.

Edited 1 time(s). Last edit at 12/10/2020 02:49PM by h3ndrix.
Re: SKR 1.4T+TFT35v3+RRF 3.1.1-14+BLTouch+TMC2209 Weird Problem
December 11, 2020 11:57AM
A few things, this problem is almost certainly a problem with the TFT software not with RRF. There is no notion with RRF of a UART based device (like the TFT) connecting so the disconnect/connect is almost certainly just changing something on the TFT side of things. I'm not sure if the author of the TFT firmware you are using monitors this forum or not, so you may not get any help. I don't use a TFT display and so can not help. You may want to try posting on the LPC/STM discord server as there are a number of folks there that use a TFT and so they may be able to help.
Re: SKR 1.4T+TFT35v3+RRF 3.1.1-14+BLTouch+TMC2209 Weird Problem
December 11, 2020 12:22PM
Thx for the reply gloomyandy.

Today, I made some progress on the issue and it got even more interesting. I was able to add a DuetPi to the setup. I turned the DuetPi into a Access Point so I can connect to it over wifi, everything seems to be working fine with the DuetPi.

After running the SBC firmware on the sidewinder, I tried the movement of motors from the TFT and the problem was still there. Then, for some other reason, I changed the mm/min. setting under machine specific settings for "feedrate for move button" in Duet Web controller. As a person in investigative mode, I try to move the motors feom the TFT after changing anything anywhere. So, this setting was 6000mm/min., same as it was in config.g for max motor speed. I changed it to 1800mm/min. and, for some weird reason, the TFT motor movement controls started to work! I have no idea why this happens but if the speed for "feedrate for move button" value is less than the max. motor speed defined in config.g it works. Does this make sense?

Re: SKR 1.4T+TFT35v3+RRF 3.1.1-14+BLTouch+TMC2209 Weird Problem
December 11, 2020 04:01PM
You really should post on the discord server (see our Wiki for details), there are a number of folks using a similar setup to you.
Sorry, only registered users may post in this forum.

Click here to login