No extruder stepper control
July 19, 2011 01:03PM
Hope someone can give me a bit of aid here, been searching and reading for a few hours now and can't come up with anything. So I decided to switch to the teacup firmware to see how it worked for me. My set up is gen3 electronics on a mendel, 3 stepper drivers, a main controller, and an extruder controller. Basically the problem is everything works like its supposed to except I have no control over the extruder stepper. Heat works all that noise. If I throw the standard firmware in it all works so I know its a fault in the firmware. I'm thinking I must've missed something somewhere, spent a long time going over the firmware checking pins all that stuff but I can find nothing out of place. I don't even know where to look now. Any help would be great.

Thanks
Bronston
Re: No extruder stepper control
July 19, 2011 06:29PM
Are you using the extruder controller hbridge hack? That hack only works ok with reprap host default firmware. What software are you driving your machine with? repsnapper, replicatorg? What do you mean by standard firmware? DO you mean Firmware for makerbot? I think people have better results using 4 stepper drivers, rather than the extruder controller as a stepper driver.
Re: No extruder stepper control
July 19, 2011 07:18PM
I'm using the teacup firmware, mostly unmodified is what I meant by standard. For gen3 electronics. I've tried driving it with all the software I can find, repsnapper, reprap host, replicatorg. I'm afraid I'm not familiar with the hbridge hack, so I doubt I'm using it. I've already spent far more than enough money on this thing, its done getting new hardware, so I will be unable to take the advice of 4 stepper drivers. Hope that offers something to go on.

Thanks
Bronston
Re: No extruder stepper control
July 20, 2011 12:27PM
have you connected the step and dir from your motherboard[sda,scl] to your extruder controller[dio9,dio10] as discussed here and displayed here?


-----------------------------------------------
Wooden Mendel
Teacup Firmware
Re: No extruder stepper control
July 20, 2011 04:27PM
Yeah its all hooked up correctly, I can make it extrude with other firmware, just won't do it with teacup.

Addendum:
I just noticed I didn't have the dimensions option checked in skeinforge. I'm slicing a new gcode right now to see if that fixes it. Still doesn't explain why I can't manually control the extruder in relicatorg though. I'll post if the gcode works.

Edited 1 time(s). Last edit at 07/20/2011 05:12PM by Bronston.
Re: No extruder stepper control
July 20, 2011 07:24PM
try with Kliment's Pronterface, the other host talkers all do funky stuff


-----------------------------------------------
Wooden Mendel
Teacup Firmware
Re: No extruder stepper control
July 20, 2011 08:36PM
Hmm, i tried pronterface and I can't get it to run at all. I'm wondering now if the problem is my skeinforge configuration. With some really old official mendel firmware I can get it to do everything its supposed to. I can even make it print from repsnapper but when I make my gcode with skeinforge my extruder doesn't turn. Here's the first few lines of the gcode.

G90
G21
;M103
;M105
M106
M113 S0.8
;M108 S20000.0
M104 S220.0
;M108 S3120.0
G1 X61.03 Y116.13 Z0.4 F3000.0
;M101
G1 X61.04 Y136.742 F288.0
G1 X64.307 Y138.952
G1 X136.202 Y138.936
G1 X138.96 Y136.361
G1 X139.328 Y75.719
G1 X124.764 Y61.155
G1 X83.989 Y61.074
G1 X78.065 Y62.189
G1 X73.336 Y64.262
G1 X69.434 Y67.038
G1 X67.038 Y69.436
G1 X64.261 Y73.346
G1 X62.836 Y76.284
G1 X61.225 Y82.412
G1 X61.03 Y116.13
;M103
;M108 S20000.0
;M108 S7800.0
;M108 S3120.0
G1 X123.081 Y77.281 F1200.0
;M101
G1 X123.387 Y77.631 F288.0
G1 X133.47 Y83.452
G1 X133.441 Y83.56
G1 X123.654 Y83.56
G1 X123.269 Y83.732
;M103
G1 X123.211 Y84.171 F1200.0
;M101
G1 X123.539 Y84.437 F288.0
G1 X132.107 Y86.733
G1 X132.107 Y86.775
G1 X123.654 Y86.775
G1 X123.288 Y86.952
;M103
G1 X123.252 Y87.366 F1200.0
;M101
G1 X123.582 Y87.603 F288.0
G1 X130.843 Y88.884
G1 X130.843 Y88.891
G1 X130.802 Y88.891
;M103

Anything out of order there?
Re: No extruder stepper control
July 20, 2011 08:46PM
Re: No extruder stepper control
July 20, 2011 09:54PM
It think it's the Dimension option that needs to be turned on.
Re: No extruder stepper control
July 21, 2011 06:40AM
Sorry hoped to post back sooner but all the python addons Pronterface seem to have broke python, anyway got it fixed now, and yeah I have both those options activated in skeinforge. I took my replace.csv out of skein and made a new gcode, here's that, though it didn't seem to help. Also dimensions is turned on. Any other ideas?

Well on second thought I guess I'm not gonna post it cause the server thought it was spam because its identical to the first gcode. Where else should I look to get skein to produce the e values?
Re: No extruder stepper control
July 21, 2011 11:40AM
K here's the most recent g code. It has the e values and the extruder does sort of turn maybe 1 mm/min not exactly fantastic prints or anything that could really be called a print.

G90
G21

M105
M106
M113 S0.8
M108 S210.0
M104 S220.0
M108 S32.76
G1 X61.03 Y116.13 Z0.4 F3000.0
G1 F4500.0
G1 E3.0
G1 F3000.0
G92 E0

G1 X61.04 Y136.742 Z0.4 F288.0 E6.58
G1 X64.307 Y138.952 E7.839
G1 X136.202 Y138.936 E30.7891
G1 X138.96 Y136.361 E31.9938
G1 X139.328 Y75.719 E51.352
G1 X124.764 Y61.155 E57.9269
G1 X83.989 Y61.074 E70.943
G1 X78.065 Y62.189 E72.8674
G1 X73.336 Y64.262 E74.5155
G1 X69.434 Y67.038 E76.0443
G1 X67.038 Y69.436 E77.1263
G1 X64.261 Y73.346 E78.6573
G1 X62.836 Y76.284 E79.6997
G1 X61.225 Y82.412 E81.7222
G1 X61.03 Y116.13 E92.4857
G1 F4500.0
G1 E89.4857
G1 F288.0

M108 S210.0
M108 S81.9
M108 S32.76
G1 X123.081 Y77.281 Z0.4 F1200.0
G1 F4500.0
G1 E92.4857
G1 F1200.0
G92 E0

G1 X123.387 Y77.631 Z0.4 F288.0 E0.1483
G1 X133.47 Y83.452 E3.865
G1 X133.441 Y83.56 E3.9006
G1 X123.654 Y83.56 E7.0247
G1 X123.269 Y83.732 E7.1595
G1 F4500.0
G1 E7.1595
G1 F288.0

Anyone see the problem?
Re: No extruder stepper control
July 21, 2011 01:40PM
It looks like you are using Skeinforge 39 or earlier.

Have you set the firmwares E_Steps_Per_mm to extrude the correct amount? (extruded length not filament input length)


FFF Settings Calculator Gcode post processors Geometric Object Deposition Tool Blog
Tantillus.org Mini Printable Lathe How NOT to install a Pololu driver
Re: No extruder stepper control
July 22, 2011 04:52PM
Well I got it too work with official firmware but still no dice with the teacup. My steps per mm was so low I had to crank the dimensions settings up really high to get it nailed down, now just a matter of a bit of calibration. Thanks very much guys.

Bronston

Edited 1 time(s). Last edit at 07/22/2011 04:54PM by Bronston.
Sorry, only registered users may post in this forum.

Click here to login