Welcome! Log In Create A New Profile


RAMPS or Arduino bad?

Posted by NightOwl 
RAMPS or Arduino bad?
July 06, 2013 05:04AM
I'm hoping someone can help me or point me in the right direction. I just built a Prusa Mendel variant and I'm having a problem with the extruder stepper motor. On the first day it ran acceptably and with a little calibration work I got it to print a nice calibration cube. The print would only work halfway and everything would stop. The printer stopped accepting commands from Pronterface and the only way I could reestablish communication was to disconnect the USB cable then reconnect. Today, my second day of working with the printer, the extruder stepper motor will not turn. It makes a thump-thump-thump noise as it jiggles back and forth, almost looks like half a step. All the other steppers are moving correctly. If I unplug the USB cable, the extruder stepper keeps thumping. The only way to stop it is to remove power.

I am using a RAMPS 1.4 board and an Arduino Mega. Also using Sprinter. But I don't think the firmware is the problem. I ran the RAMPS14 test sketch and all the steppers move back and forth except for the extruder one (still thumping). I've adjusted the pot but it only gets stronger or weaker. I've swapped pololu drivers and the extruder is still thumping. I've swapped the extruder stepper with the x-axis stepper and the x-axis stepper thumps.

So I believe the RAMPS or the Arduino might be faulty. I'm leaning toward the Arduino since the RAMPS is a pretty simple board with no microprocessor. Plus the previous problem where Pronterface would lose communication with the printer. Has anyone come up against this type of problem or have an idea how I can narrow it down further? I would really appreciate it. I was so excited to get this working and on the second day I am dead in the water.
Re: RAMPS or Arduino bad?
July 06, 2013 06:09AM
Are the gears on the extruder a bit 'tight' or possibly damaged a little after that first print ? what happens to the extruder motor when it's running free without the gears attached ? (or have you tried that and it's still thumping ?)
Re: RAMPS or Arduino bad?
July 06, 2013 07:00AM
I did notice the large gear has a flat spot and one sprocket is pushed down a little. So I pulled the stepper off the extruder to isolate the problem and it still thumps.
Re: RAMPS or Arduino bad?
July 06, 2013 08:13AM
if the original E stepper driver and motor works ok in another driver location (x,y or z) then its looks like its a RAMPS or Arduino problem as you say. Knowing what to test though is beyond me.

Ask in the elctronics forum, you probably have a better chance of someone who knows this stuff seeing it.

Reprap RAMPS section
Re: RAMPS or Arduino bad?
July 06, 2013 01:42PM
Thanks so much for the suggestion!
Sorry, only registered users may post in this forum.

Click here to login