Welcome! Log In Create A New Profile


Can't flash my RepRapPro Mono Mendel confused smiley

Posted by Naesstrom 
Can't flash my RepRapPro Mono Mendel confused smiley
September 15, 2015 07:51AM
Hi everyone!

I have a mono mendel from RepRapPro that I want to update with a auto bedlevel but that also means I have to update my Marlin firmware and I've run into some problems.
I downloaded the latest Marlin and configured it to work with my thermistors etc and it compiles just fine, but when I try to upload it I get:
Binary sketch size: 78 552 bytes (of a 129 024 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0xce

From Googling I have found that it usually is because it can't connect to the printer but pronterface works just fine and if I check the Serial-Monitor in Arduino I get the following info so that seems to be working to:
echo: External Reset
Marlin 1.0.1 RRP
echo: Last Updated: 2013-05-16-JMG | Author: eMAKER
echo: Free Memory: 11513  PlannerBufferBytes: 1232
echo: Stored settings retreived:
echo: Steps per unit:
echo: M92 X80.000 Y80.000 Z4000.000 E620.000
echo: Maximum feedrates (mm/s):
echo: M203 X300.000 Y300.000 Z3.000 E45.000
echo: Maximum Acceleration (mm/s2):
echo: M201 X800 Y800 Z30 E250
echo: Acceleration: S=acceleration, T=retract acceleration
echo: M204 S1000.000 T1000.000
echo: Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum xY jerk (mm/s),  Z=maximum Z jerk (mm/s), K=advance_k
echo: M205 S0.000 T0.000 B20000 X15.000 Z0.400 E15.000
echo: M206 X-65.000 Y-30.000 Z0.500
echo: M208 X185.000 Y180.000 Z140.000
echo: PID settings:
echo: M301 P12.000 I2.200 D80.000 W125
echo: Thermistor settings: M304 Hh Bb Rr Tt, H0=Bed, H1..n=nozzle, b=thermistor beta value, r=series resistor, t=thermistor resistance as 25C
echo: M304 H0
 B3960 R10000 T100000 M304 H1
 B3960 R10000 T100000
 FPU Enabled no
transform correction not enabledecho: SD init fail

The auto-reset jumper is bridged and I've set it to get power from USB only according to instructions.
Arduino is setup as follows:
Board: Melzi 1284p 16mhz
Port: Com 7

I've also tried using both Arduino 1.0.6 thar RepRapPro suggests and the latest stable with imported sanguino boards from this link but I still get the same error.

The power light turns off after compiling so I can't see why the "hold reset" trick would make any difference but I've tried that to but with no effect.

So... please, anyone have some more suggestions?
Sorry, only registered users may post in this forum.

Click here to login