Problem with extruder settings
September 05, 2010 01:57AM
I use Wade's Geared Nema 17 Extruder ( with Geared extruder nozzle (, RepRap host software and white ABS. I changed the temperature to 235, all other settings standard for RepRap host software.

The result can be found in the attached file.

I think I need to change some settings by extruder, but do not know what.

Please, help.
open | download - bed-spring_4off.JPG (288.6 KB)
Re: Problem with extruder settings
September 05, 2010 06:10PM
That's a new one - I've never seen anything quite like that! It looks like it's extruding in stops and starts - is the extruder running smoothly? Maybe you've got some extra large gear teeth that are causing it to skip regularly? Or your stepper current is set too low, causing the stepper to skip, or too high, causing the driver chip to periodically overheat?

Got any photos of the extruder itself, or better yet, a short video of it running?

Re: Problem with extruder settings
September 06, 2010 11:50AM
Wade, I think you're absolutely right.

First I used standard extruder nozzle from M6 rod and extruder stops after 30-40 second of work because of melting the plastic rod in extruder, to resolve this problem I installed fan from computer videocard, but problem not been solved completely.

After I was used Geared extruder nozzle, the problem with melting the plastic rod in extruder was solved.

My extruder:

Extruder controller from TechZone:

If my stepper current is set too low, may be this variable resistor adjust the current? (sign ? on picture)

And my RepRap from acrilic:


Edited 1 time(s). Last edit at 09/06/2010 11:51AM by AlexeyShokarev.
Re: Problem with extruder settings
September 06, 2010 11:59AM
You'll have to ask the Techzone guys to be sure, as I haven't used those, but that's probably it. You also need to set the current in the gcode, assuming you're using Adrian's firmware.

Re: Problem with extruder settings
September 09, 2010 12:48AM
The board you are looking at sets the current using the variable resister to set a value in the firmware on that board. The firmware must be configured up to use the variable resister to set the value. And you must not have sent a G-CODE that makes it use a software setting. The board is not a stepper driver, but uses a PWM pulse to "fake" being a stepper driver. (As will all GEN3 electronics)

Re: Problem with extruder settings
October 05, 2010 01:51PM
Wade, davmj thank you!

I resolve the problem.

The firmware was configured to use the variable resister to set the value by default.
I tried to adjust the current stepper motor by variable resistor, but this does not solve the problem.

To resolve the problem I did the following:

1) Too sharp notch in the flow bolt, leading to clogging of the bolt notch chips ABS after printing one or two
small details and the need for disassembly for cleaning extruder - moved on after printing of 200-300 grams of

2) Filing jerks (plastic is not time to melt and uniformly supplied) - the resistance heating coil extruder was 8
ohms instead of the recommended 6 ohm, lack of heat the heating element, the solution - I rewinded a spiral into
6 ohms, plus replaced the nozzle to a more heat (larger outer diameter), wraped more layers of insulation tape.

Now small parts of simple shape are printed well, large - deformed and detached from the platform after a few
more layers (need heating bed!!!), for small with thin walls and complex shapes out of plastic extrusion observed
when filling internal cavities (seems necessary to match the coefficients E0_STEPS_PER_MM = 2.02 and
E1_STEPS_PER_MM = 2.02 in the firmware of the microcontroller, too much plastic is applied by infill).

Why does for the Wade's extruder is recommended ratio 2.02, and for the Adrian extruder is 2.20?
If Wade's use 37/11 = 3.364 geared with 8mm diameter drive and Adrian use 59/11 = 5,364 geared with 8mm diameter
drive, may be need E0_STEPS_PER_MM = 1.38 for Wade's extruder? (2.20 / 59 * 37 = 1.38).

Or maybe need another coefficient for GEN3 electronics?
Re: Problem with extruder settings
October 05, 2010 05:58PM
Adrian has recently changed his from 55/11 to 59/11, not sure which these are for.

Wade's drive diameter is actually about 5mm after you hob it.

Re: Problem with extruder settings
October 05, 2010 06:04PM
Nophead is correct; although mine usually turn out to have a diameter of 6.2 mm or so, but I don't cut them very deep.

Additionally, varying nozzle sizes will result in different E steps/mm values - I use 2.02 as a starting point, and then vary the E parameters in Skeinforge to get the flow rates right. There's an overly complicated spreadsheet at the end of my wiki page that may or may not help you sort out your flow rates:


Sorry, only registered users may post in this forum.

Click here to login