Endstop Y doesnt get in consideration
October 28, 2016 07:08PM
I got a Prusa i3 with Marlin 1.0.2+, updated recently and add an auto bed leveling.
Everything worked fine but now the endstop Y is not taken in consideration when the motor Y try to find the home spot.
My endstop is in front of the print, so the direction is POSITIVE ( tried negative as well but the bed moves the other direction )

What I did:
I checked if the cable works of the end stop
I checked the actual working of the signal
I used the command M119 to check if it works
I double check if I have inverted any of the values on my config but since I didnt touch it, I find it a bit odd

All the above came out correct, all working, Marlin sees the triggering of the endstop but the motor keeps rotating when the endstop is triggered.
I tried to move by 10 and it moved correctly, I found that the Y goes even negative instead of staying between 0 and 180 values.

I am basically with no idea what went wrong, even because it worked fine and suddenly it stopped working.

Any idea?
Re: Endstop Y doesnt get in consideration
November 27, 2016 06:58PM
did you change bed size or move limit switch sounds like some changes made in firmware to auto level may have changed home position
Re: Endstop Y doesnt get in consideration
November 27, 2016 08:07PM
I have flash RC7 and then I changed the direction of one motor ( never had to do before ), but now I think my prints gets mirrored, need to do more digging.
Sorry, only registered users may post in this forum.

Click here to login