Welcome! Log In Create A New Profile


Z axis not lowering

Posted by TerryD15 
Z axis not lowering
January 30, 2020 10:33AM
Hi all,
I hope that someone can help, perhaps someone who has had this problem and solved it.

I built an i3 type RepRap quite a few years ago (around 2011) and it worked really well once I had the configuration.h sorted. I didn't use it then for a few years due to circumstances. It is a wooden framed one and inspired by the Makerfarm early model.

I came back to it a couple of years ago and tried to add bed levelling but had all sorts of problems with the buggy firmware at the time and despite great advice and help from the GitHub forum members I simply could not get it to work and just abandoned the idea and the machine. Inspired by some needs I decided, a couple of weeks ago to get the machine in working condition. I removed the inductive probe and re installed the Z axis microswitch Min_endstop and downloaded a copy of Marlin 1.1.9 intending to upgrade to 2 once I had it working.

I've had some success but mostlly frustration due the Z axis not functioning correctly. Using Pronterface it will rise by 10 mm exactly when instructed and then return down to the original position when the down instruction is sent via Pronterface. However if I issue two up instructions it will only accept one down instruction the net effect is that it is 10 mm higher - it is now almost at the top of it's travel. It will not accept any more 'down instructions' but as many 'up' insructions as I care to send.

When I query the endstops with M119 they all show open and all will trigger if I actuate them manually hence they are working as they should, i think!

My config.h file (heavily edited) is in the attachments in a Word docx file as I can see no way in the menu to add a software box.

Terry D
open | download - Config_h.docx (24.4 KB)
Re: Z axis not lowering
March 10, 2020 11:24AM
Problem resolved thanks!
Sorry, only registered users may post in this forum.

Click here to login